Wireguard vpn langsam bei einzelner Verbindung

UdoAA

Active member
Hallo,

ich habe seit mittlerweile mehreren Wochen folgendes Problem:
Auf einem SBC mit HDD bei meiner Mutter, das unter armbian-Linux läuft, habe ich mittels pivpn einen Wireguard-Server installiert.
War echt easy und am Anfang bekam ich pro Download von meinem Netzwerk auf diesen Rechner auch Transferraten von 4,2 MB/s hin, welches meine Upload-Rate von 43,6 MBit/s gut ausreizt.
Mittlerweile erreicht die Verbindung bei einem Download aber nur noch ca. 512 KB/s. Allerdings erreichen mehrere gleichzeitige Downloads auch diese Geschwindigkeit, weshalb ich annehme, dass der SBC bzw. Wireguard allgemein nicht das bottleneck ist.
Um dies mal zu überprüfen habe ich, als ich bei meiner Mutter war, auch mal einen Download von meinem Heimnetz auf ihren PC gemacht, diesmal zum Wireguard-Server bei mir in Köln verbunden, dies ist ein Core-i3-7100U, also die CPU sollte definitiv nicht das Bottleneck sein. Auch hier habe ich nur Transferraten von ca. 512 KB/s erreicht, obwohl ich mal im Urlaub aus Norwegen Transferraten von 2 MB/s erreichte.
Daher nehme ich an, das irgendwo im Netzwerk eine Bremse herrscht.
Ist Euch bekannt, ob die Telekom oder NetCologne da irgendwo bremsen, wobei ich mich frage, wie das inerhalb eines vpn-Tunnels gehen sollte?

Für Anregungen und Hinweise wäre ich sehr dankbar.

Edit: Meine Netzwerk-Geräte sind als Router eine Fritzbox 7590-AX mit 100/40 MBits VDSL von Netcologne, danach kommt besagte Core-i3-7100U als second-level Firewall mit vpn, dann ein Netgear GS116v2 Switch und dann das NAS, alle via GBit-Ethernet angebunden. Eine iperf-Messung innerhalb meines Netzwerkes ergab überall Transferraten von 800 MBit/s oder mehr.
Bei meiner Mutter ist der Router eine Fritzbox 7490 mit 50/10 MBit/s von der Telekom und dan diesen ist direkt der SBC via GBit-Ethernet angeschlossen, ein Odroid HC1.
 
Zuletzt bearbeitet:
Hey,

Kisten mal neugestartet? Standard-Port (51820/UDP) von Wireguard genutzt, oder einen anderen? Ist es "sicher", dass es an der Wireguard-Verbindung liegt? Nicht, dass einfach nur irgendwo Paketverlust vorhanden ist... Könntest ggf. mal bei der Remote-Kiste via tcpdump den Traffic mitschneiden, mal ein bisschen was machen und Dir dann mal den Mitschnitt anschauen.
 
Auch mal die Tunnel MTU checken. Besonders mit Windows hatte ich da Probleme und musste die MTU anpassen... Hatten wir hier glaube ich auch schon irgendwo thematisiert...
 
Ja, der Wireguard-Port ist die 51820/UDP.
Werde mal etwas mit der MTU spielen und mal tcpdump starten, mal sehen.
 
Angeblich ist die optimale MTU 1392. Allerdings sinkt damit die Transferrate auf nur noch 376 KB/s.
Auch ein tcpdump hat mir nichts neues gezeigt, lost pakets konnte ich nicht sehen.

Any other suggestions?
 
Naja, nach wie vor bleiben noch die Neustarts der (Wireguard-)Kisten, falls nicht eh schon geschehen, nur bist Du darauf bisher nicht eingegangen, deswegen kriegste es jetzt nochmal vor den Latz gehauen 😁
hier habe ich nur Transferraten von ca. 512 KB/s erreicht
Daher nehme ich an, das irgendwo im Netzwerk eine Bremse herrscht.
Wie sieht denn das "ohne" Wireguard aus? Ein normaler Speedtest zeigt Dir dann vermutlich auch die gebuchten Geschwindigkeiten an? Wie sieht es mit einem anderweitigen VPN aus (falls sowas zur Verfügung steht)?
 
Habe gerade mal den SBC bei meiner Mutter neu gestartet mit dem Resultat, dass er nicht mehr ansprechbar ist.
Da ist wohl der Wurm drin.
 
Halb so wild, meine Mutter hat gerade den Stecker vom SBC abgezogen und wieder eingesteckt.
Jetzt läuft das Ding wieder.
Werde mal jetzt testen.

Edit: Keine Besserung, der Transfer via ftp liegt immer noch bei 400 KB/s.
 
Naja, wenn die Bandbreiten ansonsten stimmig sind und die Probleme nur via Wireguard auftauchen, wird bei den Fritzboxen auch eher nix zu finden sein. Weiss ja nicht, was Du so für Möglichkeiten hast, aber theoretisch könnte man halt via SNMP bei den beiden Büchsen mal fleissig Infos sammeln und dann mal schauen, ob es da irgendwelche Fehler bzgl. Netzwerk gibt. Hättest Du denn theoretisch die Möglichkeit zu virtualisieren?
 
Hmm, mit sNMP kenne ich mich nicht aus, da hörts bei mir auf.
In wie weit würde mir virtualisieren etwas bringen? Möglichkeiten hätte ich da, aber as muß man mir mehr erklären.
 
Ich habe mal zwei Dinge gestestet:
- ftp-Server meiner Mutter via Port-Freigabe offen zugänglich gemacht (ich weiß gefährlich, ist wieder weg), keine Verbesserung.
- Mein Notebook direkt an meine Fritzbox gehängt, um mein internes Netzwerk auszuschalten, auch keine Verbesserung.

Dann bleibt nur noch, mein Notebook direkt and die Fritzbox meiner Mutter zu hängen, und dann einen Tranfser via Wireguard zu starten.
Wenn das geht, dann fuhrwerkt mir jemand im Internet dazwischen.
 
Und wenn das dann auch nicht vernünftig funktioniert... dann bleibt nur noch Dein Notebook, oder die Gegenstelle bei Deiner Mutter - ein Hoch auf das Ausschlussverfahren ☺️
 
Ich denke, ich habe das Bottleneck gefunden:
Ein speedtest zu dem Telekom-Server in Frankfurt brachte nur eine Transferrate von 5 MBit/s also die gesehenen 512 KB/s. Also ist offensichtlich der Übergang vom Netcologne zur Telekom überlastet und so langsam.
Habe ich also wohl Pech gehabt.
Werde aber trotzdem am WE mal mein Notebook mitnehmen und bei meiner Mutter testen.
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
4.796
Beiträge
48.630
Mitglieder
4.456
Neuestes Mitglied
Fahren
Zurück
Oben