Wechsel auf SSD - Fehlermeldung RaspberryPi Imager

Moin!

Ich habe mir überlegt von microSD auf SSD zu wechseln und habe mir auch eine kompatible SSD & Zubehör besorgt.
Jetzt habe ich den RaspberryPi Imager 1.7.3 installiert und bekomme beim Start die Fehlermeldung "Fehler beim Herunterladen der Betriebssystemliste aus dem Internet".

Weiß jemand was das ist?

Ich müsste aber ja, so denke ich, eine frische HA Installation auf die SSD packen um dann meine letzte Sicherung drauf zu spielen, richtig?

Grüße
Sky
 

carsten_h

Active member
"Fehler beim Herunterladen der Betriebssystemliste aus dem Internet".
Hast Du irgendeine Firewall im Betrieb?
Du kannst aber auch einfach das Image von der HA Seite herunterladen und mit dem Pi Imager flashen, ohne über die Liste zu gehen.

Ich benutze den seitdem es ihn gibt und bisher gab es keinerlei Probleme. Der Balena Etcher, den ich vorher benutzt habe, hat da mehr Probleme gemacht.

Beides auf einem Mac.
 
Ich mache es jetzt über den Balena Etcher und flashe das R4-64bit auf.

Jetzt würde ich den Pi runterfahren (shutdown), SD Karte raus und SSD anklemmen und dann wieder starten. USB Boot erkennt er selber, korrekt? Und schliesse ich die SSD an zwei USB Ports an bzgl. konstanter Stromversorgung oder reicht ein USB Port?

Fragen über Fragen :)
 

IvoryBalboa90

Active member
Wie schließt man ne SSD denn an zwei Ports an? 🤔

Sonst aber alles richtig. Ordentlich runterfahren, SD raus, SSD ran, HA startet und richtet sich ein. Nach dem ersten Login kannst das Backup hochladen und einspielen, fertig.
 
Ich hatte was gelesen von stabiler Stromversorgung mit doppeltem USB Anschluss. Aber vielleicht ist das auch nicht nötig?!
 

Anhänge

  • chrome_screenshot_1668235617644.png
    chrome_screenshot_1668235617644.png
    887,3 KB · Aufrufe: 1

Pietje

New member
Ich mache es jetzt über den Balena Etcher und flashe das R4-64bit auf.

Jetzt würde ich den Pi runterfahren (shutdown), SD Karte raus und SSD anklemmen und dann wieder starten. USB Boot erkennt er selber, korrekt? Und schliesse ich die SSD an zwei USB Ports an bzgl. konstanter Stromversorgung oder reicht ein USB Port?

Fragen über Fragen :)
Für Balena gibt es keinen Grund. Bleibe in der Rasi Welt mit dem Imager.
Welchen Raspi hast Du und welches Kit? War dort der Doppelstecker für den USB Anschluss am 4er Raspi bei?
Der 4er erkennt das USB Boot selbst. SD Karte rausziehen nach dem Bespielen der SSD ist ok.

Pietje
 

carsten_h

Active member
Der 4er erkennt das USB Boot selbst.
Wenn es ein neuerer ist ja, wenn er noch alte Firmware drauf hat, dann nicht!
Im Pi Imager gibt es aber Images für SD Karten, die auf USB Boot umschalten. Einfach flashen, einstecken, warten bis die grüne LED leuchtet oder an HDMI ein grünes Bild ausgegeben wird und fertig.
 

Pietje

New member
Wenn es ein neuerer ist ja, wenn er noch alte Firmware drauf hat, dann nicht!
Im Pi Imager gibt es aber Images für SD Karten, die auf USB Boot umschalten. Einfach flashen, einstecken, warten bis die grüne LED leuchtet oder an HDMI ein grünes Bild ausgegeben wird und fertig.
Du hast recht. Aber dieses Update ist schon soooooooo lange her.
 
Was soll man sagen. Pi Imager nochmal installiert und jetzt gibt es keine Fehlermeldung mehr. Warum auch immer, die Firewall habe ich zumindest nicht deaktiviert oder modifiziert 😀
 

the other

Well-known member
Moinsen,
naja, wenn die sd-Card fehlt (aka nicht eingesetzt ist), dann kann dein Raspi entweder nicht booten oder aber er bootet von einem angeschlossenen USB medium.
Ergo: wenn keine sd drin und trotzdem wird gebootet, alles ok.
;)
 
'Try and error' Prinzip. Ja, kann man natürlich machen. Aber es wäre natürlich schöner, man wüsste vorher wie der Stand der Dinge ist.
 
Das ist doch zum Mäuse melken. Der Pi wollte nicht von SSD booten. Also wieder erstmal SD rein und Pi Imager neu gestartet. Jetzt kommt wieder die Fehlermeldung. "200 Puls gleich ... doooo"
 

Pietje

New member
Das ist doch zum Mäuse melken. Der Pi wollte nicht von SSD booten. Also wieder erstmal SD rein und Pi Imager neu gestartet. Jetzt kommt wieder die Fehlermeldung. "200 Puls gleich ... doooo"
Da erscheint mir das erste Problem. Wenn Du das Betriebssystem von SD auf die Karte gespielt hast und das erste Mal sauber startest, sofort ein Backup mit dem SD Kart Reader aus dem Menu Zubehör auf einer anderen SD-Karte anlegen. So hast Du die funktionierende SD-Karte und außerdem ein Backup der SSD. Ein fester immer gleicher Asgangspunkt hilft gegen das Mäusemelken.
Welches Kit hast Du gekauft? Ist die Belüftung gut?
Ich habe das Argon One.

Viel Erfolg
Pietje
 

Zurzeit aktive Besucher

Neueste Beiträge

Letzte Anleitungen

Statistik des Forums

Themen
1.334
Beiträge
17.780
Mitglieder
844
Neuestes Mitglied
d4rkw4rden
Oben