Sonoff ZBMINI koppelt nicht

member1

Member
Hallo,
ich verzweifele etwas an zwei ZBMINI. Diese sind in ca. 4m Luftlinie, durch eine Holz-Zimmertür entfernt vom nächsten Router. Im gleichen Raum steht auch ein Sonoff Temperatursensor und der funktioniert einwandfrei. Aber die Schalter wollen beide zum verrecken nicht erkannt werden beim Scan. Ich hab diese schon zigmal vom Netz getrennt und wieder angeschlossen und auch den Taster länger gedrückt.
Eigentlich kann es nicht an der Entfernung liegen... und grün blinken tun sie auch, sind also im pair-mode.

Habe schon zwei andere woanders verbaut und da wurden die quasi sofort gefunden und angezeigt.
 
Steck doch mal nen Plug oder ne Glühlampe (mit Zigbee natürlich) auf der Hälfte zwischen zbmini und dem nächsten Router ein. Nach dem pairen entfernen und gucken, was passiert.

Ich hab 4 zbminis verbaut und die funktionieren einwandfrei und haben ne echt gute Reichweite, obwohl Unterputz verbaut.
 
Ich habe es hinbekommen, aber eher durch Zufall!
Und zwar habe ich in den Logs gesehen das es u.a. immer auch versucht hat ein inzwischen nicht mehr vorhandenes Zigbee-Gerät zu finden. Dieses hatte ich dann einfach mal aus den Zigbee-Devices entfernt und nochmal gescannt und dann wurden mir sofort beide ZBMINI angezeigt. Das kann kein Zufall sein.
 
Dann habe ich es gestern nochmal mit einem IR-Sensor probiert - dasselbe Problem wieder. Zehnmal hintereinander der Sensor resettet, Suche gestartet, immer erfolglos. Am Abend dann, ca. 6h später nochmal probiert und er wurde sofort erkannt. Diesmal habe ich vorher nichts am Setup geändert.
Muss man wirklich einfach nur ewig lang warten? Ich finde es komisch...
 
Uff, ich nochmal. Einen Türsensor (MS01) konnte ich jetzt sofort problemlos kopplen..

Wenn ich nach dem Switch suche finde ich dies im Log
Code:
[0xFB5B](01MINIZB): last_seen is 164168.956510067 seconds ago and ping attempts have been exhausted, marking the device unavailable
[0xFB5B](01MINIZB): Update device availability -  device available: False - new availability: False - changed: False

Evtl. stimmt was mit dem Sonoff Switch nicht?
 
Zuletzt bearbeitet:
So und jetzt schon wieder, auf einmal klappt das Pairing als wenn nie was gewesen wäre
Code:
New device 0x1d7e (00:12:4b:00:24:c1:4a:6d) joined the network
[0x1d7e] Scheduling initialization
Received frame on uninitialized device <Device model=None manuf=None nwk=0x1D7E ieee=00:12:4b:00:24:c1:4a:6d is_initialized=False> from ep 0 to ep 0, cluster 19: b'\x00~\x1dmJ\xc1$\x00K\x12\x00\x8e'
[0x1d7e:zdo] ZDO request ZDOCmd.Device_annce: [0x1D7E, 00:12:4b:00:24:c1:4a:6d, 142]
Tries remaining: 3
[0x1d7e] Requesting 'Node Descriptor'
Tries remaining: 2
[0x1d7e] Extending timeout for 0xcd request
 
Mein Coordinator steckt direkt im Rpi4, zwei Router-Sticks jeweils direkt in einem USB-Netzteil. Wlan (Fritz) auf Auto.
 
Mein Coordinator steckt direkt im Rpi4,
Der sollte gerade beim Pi 4 mit Verlängerungskabel angeschlossen werden und auch möglichst an USB 2, da USB 3 auch im 2,4GHz Netz sendet.
Beim ConBee II steht das auch explizit in der Anleitung.

Und dann sollte der ZigBee Kanal auch möglichst weit weg von den WLAN 2,4GHz Kanälen liegen.
 
Seit wann "senden" USB-Anschlüsse?
Ein USB 3 Anschluß sendet im 2,4GHz Netz, da er mit diesem Takt betrieben wird. Wenn die Leitungen schlecht geschirmt sind, was im Pi 4 der Fall ist und auch bei schlechten USB 3 Kabeln der Fall ist, kann so ein USB 3 Anschluß andere Geräte im 2,4GHz Netz stören.
Das ist ein seit Erscheinen von USB 3 bekanntes Problem.

Hier z.B. zum Nachlesen: https://www.heise.de/newsticker/mel...-0-stoert-WLAN-und-Drahtlos-Maus-3726700.html
 
Ok, jetzt verstehe ich Dich. Dachte Du meintest den USB Port, aber Du meinst den USB Typ (Standard). Das schau ich mir mal an.
Wegen der Verlängerung, reicht so eine kleine 10cm Verlängerung oder sollte es noch länger sein?
Dennoch ist der Coordinator weit weg und nicht in der Lage meinen ZBMINI zu pairen.
Bezüglich des Wlan, ich sende auf Kanal 1, mein Zigbee liegt auf 15. Den sollte ich dann wohl mehr so auf 20 oder 25 bringen um genug Anstand zu haben?
02668E1B-4C3A-453C-963D-242AD11D1434.jpeg

EDE6B9F0-DBE6-47D9-AF80-1F251700B74A.jpeg

Kann man den Zigbee Kanal in HA so ohne weiteres ändern?
 
reicht so eine kleine 10cm Verlängerung
Es kann sein, muß aber nicht. Ich habe eine ca. 1m Verlängerung genommen, weil ich die hier hatte und die geht. Andere habe ich nicht getestet.

Dennoch ist der Coordinator weit weg und nicht in der Lage meinen ZBMINI zu pairen.
Dann gehe doch näher an den Sonoff heran zum pairen. Bei den Ikea Buttons steht dabei, das man möglichst nah herangehen soll. Das ist wohl auch ein Sicherheitsfeature, damit niemand draußen irgendwie ein Gerät pairen kann oder so.

Den sollte ich dann wohl mehr so auf 20 oder 25 bringen um genug Anstand zu haben?
Es kann sein, daß es etwas bringt.

Kann man den Zigbee Kanal in HA so ohne weiteres ändern?
In HA kann man das nicht, das muß man in der jeweiligen ZigBee Software machen. Bei deCONZ geht es, zu den anderen beiden kann ich keine Aussage treffen, da ich die nur dem Namen nach kenne.
 
Ich hab eine 2 Meter Verlängerung dran, weil ich anfangs ähnliche Probleme hatte wie du. Versuch macht klug, aber 10cm wird glaub ich nicht allzu viel bringen.

Probier sonst mal wlan Kanal 11. Ich hab auch Kanal 15 bei Zigbee und mit Kanal 11 beim WLAN keine Probleme mehr.
 
Ich habe ja einen RPi4B, der hat sowohl USB 2.0 als auch USB 3.0 Anschlüsse. Die mit dem "blauen Inlay" sind USB 3.0 und die habe ich nicht genutzt, sondern die ganz außen. Dort steckt mein Sonoff Coordinator im oberen Port und der ist laut Setup USB Port 0, sollte also passen. Habe jetzt noch eine 1m USB-Verlängerung dran gemacht.
Im Netz habe ich Berichte gefunden wie man die USB-Ports einstellt. Ggf. könnte man ja die störenden USB 3.0 Ports einfach deaktivieren?
 

Anhänge

  • rpi4b.png
    rpi4b.png
    662,5 KB · Aufrufe: 0
Probier sonst mal wlan Kanal 11. Ich hab auch Kanal 15 bei Zigbee und mit Kanal 11 beim WLAN keine Probleme mehr.
Wifi Kanal 11 wäre natürlich, wie im Spektrogramm oben gezeigt, deutlich weiter weg vom Zigbee Kanal 15 als mein jetziger Wifi Kanal 1. Auch dürfte es wesentlich minimalinvasiver sein den Wifi-Kanal zu wechseln, als den Zigbee Kanal. Die Berichte hierzu reichen von "Paire alle neu" bis zu "nutze das Migrate Radio Tool".
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
4.484
Beiträge
46.105
Mitglieder
4.111
Neuestes Mitglied
searchingnet
Zurück
Oben