Namesauflösung über ipv6 funktioniert nicht

Kissnofrog

New member
Hallo

ich habe 6590 an einem Vodafone Kabelanschluss. Dahinter einen heimischen Server.
Auf diesem ist ddclient und ein Dyndns eingerichtet, der den host von aussen erreichbar machen soll.

Das tut auch soweit. Auf einem Rechner im Internet kann ich die Adresse auflösen und den host auch erreichen.
Interessanterweise aber nicht innerhalb meines heimischen Netzes!

Ich vermute mal da stimmt etwas mit den DNS/DHCP Einstellungen nicht.
Irgend eine Idee?
 
Hallo Kissnofrog,

ich habe 6590 an einem Vodafone Kabelanschluss. Dahinter einen heimischen Server.
Auf diesem ist ddclient und ein Dyndns eingerichtet, der den host von aussen erreichbar machen soll.

Welche dynamischen DNS-Einträge legt der Client denn an? Einen A-Record, nehme ich mal an, aber legt er auch einen AAAA-Record?
Der A-Record wird für IPv4 benötigt und der AAAA-Record entsprechend für IPv6. Über welchen Weg ist der Server denn von außen erreichbar? IPv4 oder IPv6 bzw. vielleicht auch beide?


Das tut auch soweit. Auf einem Rechner im Internet kann ich die Adresse auflösen und den host auch erreichen.
Interessanterweise aber nicht innerhalb meines heimischen Netzes!

Was kannst Du innerhalb des heimischen Netzes nicht? Den DNS-Namen des Servers auflösen? Oder nach erfolgreich aufgelöstem DNS-Namen dann keine Verbindung aufbauen?
 
Hallo,

Die Verbindung funktioniert, Problem ist nur die Namensauflösung.


dyndns legt nur einen AAAA record an. einen A kann er nicht, da über Vodafone keine IP4 Adresse vergeben wird.

hier der extract aus DNS auf einem Server im Internet (Strato).

dig aaaa nextcloud.vonweitweg.de
; <<>> DiG 9.11.3-1ubuntu1.18-Ubuntu <<>> aaaa nextcloud.vonweitweg.de
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 64229
;; flags: qr rd ra; QUERY: 1, ANSWER: 1, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 4096
; COOKIE: 49c1dc5d20201329687c19dc6405c407335d8f2c4c7befe0 (good)
;; QUESTION SECTION:
;nextcloud.vonweitweg.de. IN AAAA
;; ANSWER SECTION:
nextcloud.vonweitweg.de. 60 IN AAAA 2a02:8070:789:6880:5680:28ff:fe4f:daad
;; Query time: 48 msec
;; SERVER: 81.169.163.106#53(81.169.163.106)
;; WHEN: Mon Mar 06 11:44:23 CET 2023
;; MSG SIZE rcvd: 108

Mache ich das selbe auf meinem heimischen Server bekomme ich keine Antwort.
dig aaaa nextcloud.vonweitweg.de
; <<>> DiG 9.18.1-1ubuntu1.3-Ubuntu <<>> aaaa nextcloud.vonweitweg.de
;; global options: +cmd
;; Got answer:
;; ->>HEADER<<- opcode: QUERY, status: NOERROR, id: 54889
;; flags: qr rd ra; QUERY: 1, ANSWER: 0, AUTHORITY: 0, ADDITIONAL: 1
;; OPT PSEUDOSECTION:
; EDNS: version: 0, flags:; udp: 65494
;; QUESTION SECTION:
;nextcloud.vonweitweg.de. IN AAAA

;; Query time: 0 msec
;; SERVER: 127.0.0.53#53(127.0.0.53) (UDP)
;; WHEN: Mon Mar 06 11:45:49 CET 2023
;; MSG SIZE rcvd: 52

Auch andere clients in meinem LAN können den server nicht auflösen.

Zwinge ich die Auflösung auf den google DNS wird die Adresse aufgelöst:

dig @8.8.8.8 aaaa nextcloud.vonweitweg.de
;; ANSWER SECTION:
nextcloud.vonweitweg.de. 60 IN AAAA 2a02:8070:789:6880:5680:28ff:fe4f:daad
;; Query time: 44 msec
;; SERVER: 8.8.8.8#53(8.8.8.8) (UDP)
;; WHEN: Mon Mar 06 11:52:30 CET 2023
;; MSG SIZE rcvd: 80

Dyndns funktioniert offenbar richtig.
aber scheinbar leitet die Fritz!Box die DNS anfrage nicht richtig weiter.
 
Trage doch mal die Domain "nextcloud.vonweitweg.de" in den DNS-Rebindschutz ein.

1678102582403.png

Ich nutze die FritzBox nicht als DNS-Server im LAN, aber die Beschreibung passt auf das Problemchen.
Zwar ist die IPv6-Adresse Deines Servers eine IPv6-GA (öffentliche IPv6-Adresse), aber sie befindet sich auch bei Dir im LAN.
Die Beschreibung "Ihre FRITZ!Box unterdrückt DNS-Antworten, die auf IP-Adressen im eigenen Heimnetz verweisen (DNS-Rebind-Schutz)." trifft also zu.
 
Hast Du eventuell auch mal versucht die FritzBox zu "erzwingen"?
Und Du könntest auch mal den Upstream-Server der FritzBox testen.
Im Standard scheint Dein Server auf einen lokalen Stub-Resolver zu gehen (127.0.0.53); eventuell ist da auch ein "Problemchen".
Nach diesen drei Schritten solltest Du genau wissen, wo die AAAA-Record Informationen untergehen.
 
oh! jetzt tut's plötzlich. habe nichts mehr geändert.
vielleicht doch der DNS-Rebind-Schutz? und es hat einen Moment gedauert bis das aktiv war?

sieht erst mal gut aus. mal beobachten....
vielen Dank schon mal!
 
Die FritzBox hat einen internen DNS-Cache. Änderungen die Auswirkung auf DNS haben, können ein paar Sekunden bis Minuten dauern, wenn der Eintrag noch im Cache steht. Es wäre also denkbar, dass noch ein "leerer" AAAA-Record im DNS-Cache der FritzBox war und die DNS-Rebindausnahme gar nicht geprüft wurde, weil der gecachte (falsche) Eintrag noch galt. Nachdem der vermutete Cache-Eintrag nun nicht mehr galt, hat die FritzBox erneut ihren Upstream DNS gefragt, der auch wieder geantwortet hat; diesmal hat aber dann der DNS-Rebind nicht gegriffen (weil Ausnahme) und damit ist der korrekte AAAA-Record im Cache und am Client gelandet.
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
4.872
Beiträge
49.053
Mitglieder
4.533
Neuestes Mitglied
Karlmaster
Zurück
Oben