IPv4 Adresse kann bei einem Gerät nicht geändert werden?

carsten_h

Well-known member
Moin!

Bei einem Gerät kann ich seltsamerweise in der Fritz!Box die IPv4 Adresse nicht ändern. Der entsprechende Teil sieht so aus:
Bildschirm­foto 2023-03-15 um 12.10.30.png

Bei anderen Geräten sieht es dann so aus:
Bildschirm­foto 2023-03-15 um 12.13.34.png
Warum fehlt die Eingabemöglichkeit bei dem Gerät oben?
Was kann das sein?
 
Die .201 ist doch ausserhalb des DHCP Bereiches (default .20 - .200), daher kann die Fritzbox dort nichts ändern.

Gruss
 
Tja dann... ist es seltsam. Besteht eine Freigabe/Weiterleitung zu dieser IP?
Andererseits verwundert es mich, das diese Option "...immer gleiche IP..." für statische IPs überhaupt vorhanden ist!?
Ich kenne das nur für über DHCP zugeteilte Adressen.

Gruss
 
Besteht eine Freigabe/Weiterleitung zu dieser IP?
Nein, ich habe den Eintrag für das Gerät sogar eben zurückgesetzt und das Gerät hat wieder die .201 bekommen, obwohl es ja eigentlich eine IP aus dem DHCP Bereich bekommen sollte.

"...immer gleiche IP..." für statische IPs überhaupt vorhanden ist!?
Sicher, das muß doch dort sein, damit die MAC-Adresse immer diese IP Adresse und nicht eine aus dem DHCP Bereich bekommt.
 
Sicher, das muß doch dort sein, damit die MAC-Adresse immer diese IP Adresse und nicht eine aus dem DHCP Bereich bekommt.
Das verstehe ich gerade nicht. Eine statische IP Adresse wird i.d.R. auf dem Client vergeben, wieso sollte die Fritzbox diese ändern können/sollen?

Diese Option macht m.E. nur Sinn, wenn der Client die IP über DHCP erhält und immer dieselbe IP erhalten soll.
Die IP ist trotzdem dem DHCP Pool zugeordnet, nur erhält sie kein anderer Client, selbst wenn der eigentliche "Eigentümer" der IP gerade nicht im Netzwerk und die Lease auch schon abgelaufen ist.

Für eine auf dem Client konfigurierte IP (=statische IP) macht diese Option daher keinen Sinn.

Gruss
 
Eine statische IP Adresse wird i.d.R. auf dem Client vergeben, wieso sollte die Fritzbox diese ändern können/sollen?
Ja, ich weiß. In der Fritz!Box kann man aber auch solche pseudo-statischen IP Adressen vergeben. Dort muß zwar das Gerät immer noch die DHCP Anfrage machen, bekommt aber immer dieselbe Adresse zugeteilt und die kann im gesamten möglichen Bereich liegen.

Das hat aber mit der Frage nichts mehr zu tun.
 
Nur insofern, das Du das auch dazu sagen müsstest , das es eine IP-Reservierung der Box ist. ;).
Welche Unterschiede gibt es denn zwischen der .201 und der .204/.150 noch?

Allein von der IP her ist es nicht erklärlich. Wenn es kein Bug ist, muss es andere Unterschiede geben.
Ganz blöde Frage: das Gerät (.201) ist auch auf DHCP eingestellt?

Gruss
 
das Gerät (.201) ist auch auf DHCP eingestellt?
Ja! Das ist ein Raspberry Pi 4 mit piCorePlayer und bisher hat der von der Fritz!Box die IP .109 bekommen. Aber auf einmal bekommt er die .201 und ist über die auch erreichbar.
Ich habe jetzt den Pi heruntergefahren. Den Eintrag mit dem Pi komplett aus der Fritz!Box gelöscht. Dann den Pi wieder eingeschaltet und schon bekommt er wieder die .201 verpasst, die sich immer noch nicht ändern läßt.

Die .204 und .150 sind Geräte, die auch ganz "normal" per DHCP ihre feste IP-Adresse bekommen. Mit denen klappt das auch wunderbar. Und mit 40 anderen Geräten ebenfalls.
 
Ihr müsst ihr drei Fälle unterscheiden:
  1. statische (manuelle) IP
    wird am Client selbst in der IP-Konfiguration festgelegt, hier hat die FritzBox null Chance und zeigt auch kein änderbares Feld an
  2. statisches DHCP
    hier ist der Client auf DHCP eingestellt, in der FritzBox ist aber fest eine IP zugewiesen, diese kann auch außerhalb des DHCP-Bereichs (eigentlich korrekter dynamischer Adresspool) liegen. Dies erreicht man, in dem man vorher bei einer dynamischen Zuordnung, das IP-Feld in der FritzBox bearbeitet und das Feld "immer gleiche IP zuweisen" aktiviert hat.
  3. (dynamisches) DHCP
    hier ist der Client auf DHCP eingestellt, die FritzBox weist ihm eine verfügbare IP aus dem dynamischen Pool zu.
Dein Symptom spricht eindeutig dafür, dass a) am Client eine statische (manuelle) IP konfiguriert wurde oder b) das sich die FritzBox total verhaspelt hat. Trotzdem würde ich Szenario a) den Vorrang geben.
 
Mal ganz dumm gemacht: schalte den Pi doch noch mal aus, nimm ihn vom Netzwerk und verbinde einen Laptop direkt (laptop mit einer IP aus dem 192.168.178.0 Netzwerk versehen).
Wenn Du den Pi einschaltest, ist er erreichbar, mit welcher IP? Wenn er immer noch die .201 hat, dann ist das die von @Barungar unter 1.) geführte Variante. Nicht, das wir hier Geister jagen. :LOL:
Gegenprobe: den Laptop nun mit einer 169.254.0.x Adresse versehen, ist der Pi dann erreichbar? Ggf. einen ARP request absetzen, da man ja die IP des Pi dann nicht kennt.

Gruss
 
hier hat die FritzBox null Chance und zeigt auch kein änderbares Feld an
Das stimmt nicht. Ich habe hier ganze zwei Geräte im Netz, die eine staische (manuelle) IP Adresse bekommen haben. Das ist zum einen mein QNAP NAS und zum anderen ein Raspberry Pi4 mit Home Assistant. Die werden in der Fritz!Box trotzdem mit veränderbarer IP-Adresse angezeigt.

am Client eine statische (manuelle) IP konfiguriert wurde
Nein, definitiv nicht. Dazu müsste es extra eingestellt werden und etwas zusätzlich installiert werden. Das habe ich nicht gemacht. Der Pi hat bisher immer brav seine .109 bekommen, nur seit heute irgendwie die .201.

Wenn ich einfach nur die Fritz!Box platt mache und die Sicherung wieder einspiele, habe ich sicherlich den gleichen Käse wie jetzt wieder, oder?
Also muß ich dann wirklich wieder alles von ganz vorne per Hand einstellen und allen Geräten mühsam Ihre IP-Adressen und Namen verpassen?
 
Wenn ich die Fritz!Box zurücksetze und dann das WLAN mit denselben SID-Namen und Passwörtern einrichte, kommen die Geräte dann wieder ins Netz oder muß ich zu allen hin und die neu anmelden?
 
Das stimmt nicht. Ich habe hier ganze zwei Geräte im Netz, die eine staische (manuelle) IP Adresse bekommen haben. Das ist zum einen mein QNAP NAS und zum anderen ein Raspberry Pi4 mit Home Assistant. Die werden in der Fritz!Box trotzdem mit veränderbarer IP-Adresse angezeigt.
Wenn ich die Fritz!Box zurücksetze und dann das WLAN mit denselben SID-Namen und Passwörtern einrichte, kommen die Geräte dann wieder ins Netz oder muß ich zu allen hin und die neu anmelden?
Zu Punkt1: Möglich, das die FB das so anzeigt. Wie sie es allerdings bewerkstelligen will, den Geräten eine andere IP zuzuweisen, darauf bin ich gespannt. :p

Zu Punkt2: Ja, dann kommen die Geräte problemlos wieder ins WLAN. Selbst schon gemacht.

Gruss
 
Um "Karteileichen" zu entsorgen hat sich bewährt, die Clients mal kurz auszuschalten, den DHCP-Bereich/die Box-IP im vorletzten Tupel zu verändern, Neuzustarten und dann zurückzuändern, bevor die Clients wieder im alten Netz sich anmelden. Das erspart das mühselige Neueinrichten.
 
Das stimmt nicht. Ich habe hier ganze zwei Geräte im Netz, die eine staische (manuelle) IP Adresse bekommen haben. Das ist zum einen mein QNAP NAS und zum anderen ein Raspberry Pi4 mit Home Assistant. Die werden in der Fritz!Box trotzdem mit veränderbarer IP-Adresse angezeigt.
Das ist unglaublich schön für Dich; aber nicht korrekt.

Das gilt nämlich nur, wenn das Gerät mindestens EINMAL DHCP gemacht hat. z.B. ein QNAP bei der Ersteinrichtung. Bei Geräten, die ausschließlich und immer eine manuelle/statische IP hatten und NIEMALS einen DHCP-Request gestellt haben, gibt es keine Möglichkeit das Feld zu bearbeiten.

Ich habe das bei mir gerade noch einmal an meiner FB nachgeprüft und für mich passt das "Bild". Einmal aktiv DHCP gemacht hat, und das kann sehr lange zurückliegen, dann ist das Feld editierbar. Andernfalls ist es das Feld nicht.

Es bleibt natürlich immer noch die Möglichkeit, dass sich die FritzBox verhaspelt hat... da kenn ich auch Fälle. Da würde das Löschen des Gerätes und anschließender Reboot sowohl der FritzBox als auch des Gerätes in der Regel helfen.
 
Zuletzt bearbeitet:
Also irgendwie ist es seltsam.
Ich hatte die Fritzbox neu gestartet, dadurch hat sich ein Repeater, der über einen anderen Repeater per WLAN im Netz hängt, sich nicht angemeldet (die eine LED blinkt nur orange). Der erste Repeater ist per LAN angeschlossen.
Jetzt auf einmal verhalten sich alle Geräte ganz normal. Der Pi hat auf einmal die IP .21 bekommen, als die erste freie Adresse und läßt sich auch wieder ändern.

Es sieht so aus als würde der zweite Repeater (2400) da irgendwie Probleme im Netz verursachen. Der läßt sich ja auch nicht so schön ins Mesh bringen, weil er sich durch die Mesh Anmeldung immer direkt an der Fritzbox anmeldet und nicht am anderen Repeater, was ziemlicher Unsinn ist.
 

Zurzeit aktive Besucher

Neueste Beiträge

Letzte Anleitungen

Statistik des Forums

Themen
4.806
Beiträge
48.670
Mitglieder
4.462
Neuestes Mitglied
Samuel teilweise schreibt
Zurück
Oben