Energie Dashboard - Solar mit eigennutzung

MarcW

New member
Hallo,

Ich habe es endlich mal Geschaft meinen Zähler Smart zu machen und diesen über Homematic in HA zu integrieren.
Auch der Wechselrichter ist eingebunden und alle relevanten Daten werden abgerufen und sin in HA verfügbar.

Folgendes Habe ich gemacht in HA im Energie Dashboard.

Netzverbrauch: 1.8.0 vom Hauptzähler. Funktionert
Zum Netz zurück: 2.8.0 vom Hauptzähler. Funktionert
Solarproduktion: Habe ich den Wechselrichter angegeben. Daten werden übernommen.

Das Problem:
HA leitet die Gesamte Produzierte Energie ins Netz zurück, ohne den Eigenverbrauch abzuziehen.
Demnach leite ich immer mehr ins Netz zurück wie es tatsächlich der Fall ist. Der wer in HA sollte ja dem am Zweirichtungszähler entsprechen.

Wo liegt mein Fehler? Wie muss ich dass Richtig einstellen? Leider sind die Einstellmöglichkeiten am Energiedashboard sehr Mau..


Mfg
Marc
 

blurrrr

Well-known member
Hey,

ein paar Angaben dazu wären vermutlich ganz hilfreich:

1)
Zähler Smart zu machen
Was für einen und wie?

2)
über Homematic in HA zu integrieren
Wie?

3)
Netzverbrauch: 1.8.0 vom Hauptzähler. Funktionert
Zum Netz zurück: 2.8.0 vom Hauptzähler. Funktionert
Solarproduktion: Habe ich den Wechselrichter angegeben. Daten werden übernommen.
+
HA leitet die Gesamte Produzierte Energie ins Netz zurück, ohne den Eigenverbrauch abzuziehen.
Demnach leite ich immer mehr ins Netz zurück wie es tatsächlich der Fall ist. Der wer in HA sollte ja dem am Zweirichtungszähler entsprechen.

Also mal nebst der Tatsache, dass ich ja bekannterweise keine Ahnung davon habe, würde ich einfach mal davon ausgehen, dass eine Wertigkeit (ggf. Entität) falsch zugeordnet ist.

Du sagst: Es stimmen alle Werte soweit, für mich liest sich das ungefähr so:

Wert X - "Produktion"
Wert Y - "Eigenbedarf"

Wert Z - "Zurück ins Netz", entweder wird dieser Wert auch schon irgendwoher geholt, z.B. von der Elektro-Hardware (hab ich auch keine Ahnung von), oder dieser Wert wird in HA berechnet (X - Y = Z). Die Frage ist bzgl. "Z" wäre jetzt: Woher genau kommt dieser Wert?

Von daher wäre es ggf. auch interessant zu wissen, wie genau Du das ganze jetzt realisiert hast, damit man da ggf. irgendwo Ansatzpunkte hätte. Ich frage mal ganz blöd: Du sagst, der Aufbau wäre wie folgt: "Elektro-Hardware -> Homematic -> HomeAssistant". Wie sieht es denn direkt bei Homematic aus? Hast Du da auch die gleichen Werte wie in HomeAssistant bzgl. der Netzeinspeisung? Falls dem so ist, kann HomeAssistant da ja nix für. Falls dort aber alles richtig ist und nur HomeAssistant davon abweicht, werden ggf. Werte falsch übernommen (oder was weiss ich). Ich würde jedenfalls erstmal prüfen, an welcher Stelle es wirklich schief läuft 🙃
 

bellini

New member
Zeigen Deine Sensoren alle positive Werte an wenn Du unter Entwicklerwerzeuge dir die Werte ansiehst?
Alle 3 Sensoren als state_class: "total_increasing" konfiguriert und zählen auch wirklich hoch, werden also niemals zurückgesetzt?
Ich habe die von dir genannten Zähler

"
Netzverbrauch: 1.8.0 vom Hauptzähler. Funktionert
Zum Netz zurück: 2.8.0 vom Hauptzähler. Funktionert
"

für das Stromnetz konfiguriert und den PV-Zähler natürlich rechts für die Kollektoren.

1655928453364.png

funktioniert! Wobei ich alles nur mit HA gemacht habe.
Mein Beispiel: https://www.it-und-hausautomation-blog.de/energie-dashboard/

Hoffe das gibt dir eine Idee was bei dir falsch sein könnte....
 
Zuletzt bearbeitet:

MarcW

New member
@bellini genau so habe ich es auch gemacht. Heute sieht das bild der Energie verteilung wieder ganz anders aus. Heute verteilt HA den Strom ins haus und ins Netz Die Selbstverbrauchte Solarenergie könnte auch passen. Ich werde das ganze noch weiter beobachten und erstmal so lassen. Mal sehen was HA morgen sagt, was eingespeist und was selbst genutzt wurde.

Evtl. fehlt HA noch die Aktuelle Leistung. Die kann ich grad nicht ablesen weil der Zähler getauscht wurde und ich noch keinen Pin zum freischalten habe.
 

bellini

New member
Nein, die aktuelle Leistung braucht das Energy-Dashboard nicht. Nur die 3 "Zählerstände" Dann funktioniert es (zumindest bei mir).
Die aktuelle Leistung habe ich auf ein extra Dashboard gepackt,

1655998620877.png
Knapp 2kW werden also gerade "verkauft" :)
Jetzt könnte man noch per Template einen errechneten Sensor für den aktuellen Eigenverbrauch anlegen....

Der Sensor für die aktuelle Leistung (4. Sensor) schwankt zwischen +/- je nach aktuellem Verbrauch/Einspeisung.
 

MarcW

New member
Theoretisch reichen die drei Werte.
Habe mal ein Screenshot dabei gemacht.

Der tatsächliche Strombezug aus dem Netz laut Zähler lag bei etwa 18kWh
Die Tatsächliche Einspeisung ins Netz lag bei 65kWh
Solarproduktion 96,7 kWh

Stimmt das nun mit der grafischen Darstellung von HA? vielleicht kommt mir das auch nicht richtig vor da in Wh und kWh angezeigt wird!?
 

Anhänge

  • Screenshot 2022-06-24 045514.png
    Screenshot 2022-06-24 045514.png
    85,4 KB · Aufrufe: 2
Zuletzt bearbeitet:

Zurzeit aktive Besucher

Neueste Beiträge

Letzte Anleitungen

Statistik des Forums

Themen
647
Beiträge
9.532
Mitglieder
239
Neuestes Mitglied
Timyboy
Oben