Bandbreitenlimitierung bei größeren Downloads?

UdoAA

Active member
Hallo Leute,

ich hatte gerade mehrere interessante Gespräche mit dem technischen Kundendienst von Netcologne, meinem Internetprovider.
Hintergrund ist, dass ich seit einiger Zeit beim Download größerer Dateien (meistens iso-Dateien, z.B. von Ubuntu, CentOS etc.) oder auch Update meiner Linux-Distros nur noch Geschwindigkeiten von etwa 2MByte/s erreicher, obwohl ich einen 100MBit/s VDSL Anschluß habe. Der Anschluß ist in Ordnung und liefert auch die 100 MBit, auch mein internes Netzwerk ist kein Bottleneck.
Der letzte Mitarbeiter von Netcologne erklärte mir, dass die Server-Betreiber mittlerweile den Download von größeren Dateien in der Bandbreite limitieren.

Kennt Ihr das Verhalten, vor allen Dingen bei nahezu allen Betreibern?

Gruss, Udo
 

FSC830

Active member
Ich kenne das nur von Filehostern, die außer einem kostenpflichtigen Account auch eine "free to use" Downloadmöglichkeit anbieten.
Allerdings würde es mich wundern, wenn die ISOs alle auf dem gleichen Server liegen, oder wo holst Du die Images?

Gruss
 

UdoAA

Active member
z.B. bei der Uni-Aachen oder auch auf einem mirror-Server von Netcologne.
Sind sind aber generell unterschiedliche Server.
Meine Vermutung ist auch, dass durch das 4K-Streaming das Netzwerk von Netcologne am Anschlag ist.
 

blurrrr

Well-known member
Das kommt wohl ganz auf den Mirror/Anbieter an, einfach mal einen anderen nutzen. Ich habe hier auch 100MBit VDSL und i.d.R. kommen die ISOs hier schon mit ~10MB/s an. Bei regulären ISO-Downloads von offiziellen Spiegeln, gibt es aber normalerweise immer den vollen Speed... Hab grade mal bei Ubuntu geschaut... der automatische Download verweist auf mirror.kamp.de (Kamp issn RZ-Betreiber in Oberhausen (NRW)), der Link "download now" zeigt hingegen auf releases.ubuntu.com. Im Zweifel - wie gesagt - einfach mal einen anderen Mirror ausprobieren. Wenn die Auslastung von den Dingern ggf. zwischenzeitlich was höher ist, kann es natürlich auch zu gewissen Geschwindigkeitseinbußen kommen.
 

UdoAA

Active member
Manchmal bzw. mittlerweile eher selten erreiche ich auch noch recht gute Transferraten, aber meistens tröpfelt das ganze nur noch vor sich hin.
Jedenfalls werde ich mir bei dem Sachverhalt wohl in den nächsten 10 Jahren keinen schnelleren Anschluß zulegen, selbst, wenn die Glasfaser im Keller irgendwann mal bis in die Wohnung gelegt wird.
 

blurrrr

Well-known member
So... hab jetzt mal getestet....

-> ~12MB/s (1Gbit via RZ -> ~30-50MB/s)

-> ~11MB/s (1Gbit via RZ -> ~20MB/s)

Teste einfach mal die Spiegel durch, bis Du was passendes findest und dann bleib einfach dabei 😁

Das ist auch der Grund, warum ich privat "nur" die 100MBit habe (grössere Uploadgeschwindigkeit wäre "nett, aber... naja...). Geht auch alles so und Downloadgeschwindigkeiten von 500-1000Mbit wird vermutlich eh nur zu 0,01% bekommen (man erinnere sich an die Anfangszeiten von DSL, da hat man auch fast nirgendwo die volle Downloadgeschwindigkeit bekommen ☺️).
 

UdoAA

Active member
Boah, ftp.halifax.rwth.aachen.de habe ich auch vorhin versucht mit erwähnten Resultaten....
Gerade landete ich bei max. 1.4 MB/s.
Ich gehe mal davon aus, dass das Netzwerk von Netcologne am Anschlag ist.
 

blurrrr

Well-known member
Also wenn ich mir meine Werte so anschaue und dann Deine Werte... Du bist aber nicht mit ~10Mbit unterwegs? 😜😁

Wie ist das denn, wenn Du mal woanders etwas herunterlädst?
Der Anschluß ist in Ordnung und liefert auch die 100 MBit
Da muss es ja irgendwas zum gegenprüfen geben... Womit hast Du getestet? Hoffentlich nicht mit so einem "Speedtest"... 😉

Traffic-Shaping pro IP/Session macht bei grösseren Download-Servern natürlich schon Sinn, aber wenn es zwei unterschiedliche Ergebnisse gibt, macht mich das schon etwas stutzig bzw. lässt mich eher darauf schliessen, dass es nicht unbedingt an den Download-Servern liegt. Um es anders auszudrücken: 3 Leute fahren aus gleicher Entfernung nach Hamburg, 2 sind innerhalb einer Stunde da, der 3. erreicht Hamburg erst nach 5 Stunden. Liegt es jetzt an Hamburg? ☺️
 

UdoAA

Active member
Ja, getestet mit dem Netcologne Speedtest.
Das Netzwerk bei mir internhabe ich getestet, ein NAS hängt in der DMZ an der Fritzbox und liefert von einer SSD die maximal möglichen 113 MB/s.
Zum heulen.
 

blurrrr

Well-known member
Intern ist bestimmt in Ordnung, aber nutz nicht die Speedtests, die werden teilweise von den ISPs priorisiert (besonders gern die eigenen, zumal das dann auch im eigenen Netz abläuft).
 

UdoAA

Active member
Ja, aber Netcologne sagt keck, solange der Speedtest im Netcologne-Netz o.k., habe ich Pech gehabt.
Und nu?
 

UdoAA

Active member
Habe jetzt mal auf speedtest.net mit einem Server in Düsseldorf getestet: Ergebnis sind 47 MBit/s im Download und 26 MBit/s im Upload.
Sind schonmal andere Zahlen.
 

blurrrr

Well-known member
Jaja, wenn man erstmal "richtig" liest... also vergiss die vorherige Antwort... 🤣

Wenn es so ist, wie es ist, liegt es nicht mehr in deren Verantwortungsbereich. Entweder hakt's noch an deren Netzübergängen (zu anderen), oder das Problem liegt ausserhalb. Verhält sich dann aber so, wie wenn der Typ, der 5 Stunden nach Hamburg fährt, jetzt zu seinem KFZ-Händler rennt und sich darüber beschwert, dass er 5 Stunden braucht. Wenn es irgendein Provider auf dem Weg zum Ziel ist, machste halt "nix". Die Server sind es offensichtlich nicht, wenn bei NetCologne auch nix ist, dann wird es mitunter irgendwo dazwischen liegen.

Mach doch einfach mal einen Traceroute (Windows: "tracert", Linux: "traceroute") zum Zielserver, damit Du erstmal einen Überblick über die Route hast. Das nächste wäre dann z.B. mal ein "pathping" (bzw. unter Linux haste direkt schon Ergebnisse dazu stehen, unter Windows nicht). Ich z.B. habe von hier aus ~1% Packetloss beim letzten Router im Vodafone-Netz (danach wäre es dann "DFN" als Provider und von dort aus geht es zur RWTH-Aachen). Kannst Dir aussuchen, ob Du direkt pathping in der Windows-Eingabeaufforderung ausführen willst, oder via GUI (z.B. PingPlotter Free, das kann man auch länger laufen lassen).

Dann kannst Du mal verschiedene Ziele testen (NetCologne intern, google.de, debian.org, was auch immer Dir so spontan dazu einfällt, einfach nur, damit Du die Strecken für verschiedene Ziele siehst und da ggf. auch mal irgendwo das Problem einigermaßen eingrenzen kannst (z.B. Probleme nur bei bestimmten Providern/Strecken/Hosts)).
 

FSC830

Active member
Beim ersten Link (Netcologne) läuft der Download von Anfangs ca. 2,5MB/s bis etwas über 5MB/s hoch. Hat sich bei ca. 4.8 - 5 MB/s eingependelt.
Hier ein Ausschnitt vom Verlauf:
1638902315837.png
Oder in M Bit/s
1638902672940.png

Der andere Link verhält sich genauso:

1638903194679.png

Nominell habe ich zwar auch VDSL 100, aber es kommen im Download max. zwischen 52-60MB/s an, die Leitungslänge ist leider grenzwertig.
Bei VDSL 50 kriege ich den vollen Speed, aber mehr scheint auch nicht drin zu sein.

Gruss
 

UdoAA

Active member
Danke @FSC830 : Dann scheint es wohl so zu sein, wie ich vermute: Das Netcologne-netz und Teile des weiteren Internet sind am Anschlag.
 

blurrrr

Well-known member
Ich sag mal so: "ja ne...". Wenn Du eh nur 50/60 Mbit rein bekommst, wird sich das ganze um 6-7MB/s bewegen, ganz egal was Du "gebucht" hast.

Angenommen die maximale Downloadrate liegt bei 60Mbit (Leitungskapazität), dann kriegst Du auch nur 60Mbit mit VDSL100. Mit VDSL50 dann halt auch nur 50MBit (aber das macht den Kohl ja nun auch nicht wirklich fett). Bisher ist allerdings noch nicht wirklich etwas greifbares dabei rumgekommen, dass bestätigt, dass Du ansonsten trotzdem die 100Mbit kriegen würdest.

Geschwindigkeiten von etwa 2MByte/s erreicher, obwohl ich einen 100MBit/s VDSL Anschluß habe. Der Anschluß ist in Ordnung und liefert auch die 100 MBit
Das hab ich bisher nicht so gesehen und beim Speedtest, den ich Dir via PN verlinkt habe, komme ich auch problemlos auf die 10+MB/s mit meinem VDSL100, Du allerdings irgendwie... nicht so:

1638903809635.png

Das Problem wäre demnach dann wohl eher auf der Strecke zu suchen, vorausgesetzt, Du kriegst wirklich "irgendwo" die "100"MBit (und ich meine jetzt nicht bei einer lokalen Anzeige am Router/Firewall, sondern schon irgendwo "im Netz" und auch nicht durch einen der geschönten Speedtests vom eigenen Provider).

Wühl Dich einfach mal ein bisschen via Pathping/Traceroute durch und schau einfach mal, wie sich die Dinge verhalten ☺️
 

UdoAA

Active member
Komisch ist nur, dass ich bis vor kurzem Downloads mit konstant 10 MByte/s hingekriegt habe.
 

Laurenzis

New member
Das Problem umgehe ich mittlerweile recht elegant mit FDM.
Da wir hier nur sehr geringe Internetbandbreiten haben (offiziell max. 30 MBit - nach langen Diskussionen mit dem Provider wurde ein 50er Profil geschaltet),
habe ich hier nun 1x 50 Mbit DSL, 1x 42 MBit DSL, 1x Starlink.
Dank pfSense und FDM wird das schön auf die 3 Anschlüsse verteilt und ich habe durchgehend weiterhin hohe Downloadraten.


Gruß,

Lauri
 

FSC830

Active member
Nein, das sehe ich auch am Modem, welche Geschwindigkeit der Anschluss hat. Ein Techniker war auch schon mal am Verteiler und hat versucht ob ein anderes Adernpaar besser funktioniert, aber ohne Erfolg:

Anschluss 1 (der aber gekündigt ist):
1638904447586.png
Anschluss 2 (derjenige um den es geht):

1638904482836.png
Warum zwei Anschlüsse?
Bei mir war monatelang kein VDSL möglich, warum auch immer. Meine Leitung kommt leider aus einer anderen Richtung als bei den Nachbarn.
Da die Nachbarn aber die Schwiegereltern sind, habe ich einen Anschluss dort legen lassen.
Seit Anfang des Jahres gibt es über meinen Leitungsweg auch endlich VDSL. Also habe ich den Interims-Anschluss gekündigt.
Wobei der auch sehr viele Aussetzer hat, erst hatte ich die Fritzbox in Verdacht, nach Wechsel auf das DrayTek ist es aber nicht besser geworden.
Und eine Leitung, die ständig offline geht, brauche ich auch nicht.

Gruss
 

Zurzeit aktive Besucher

Keine Mitglieder online.

Letzte Anleitungen

Statistik des Forums

Themen
937
Beiträge
13.660
Mitglieder
466
Neuestes Mitglied
wischi83
Oben