VPN: LAN_2_LAN

noli.melavo

New member
Moin Moin Liebes Forum,
bei mir klemmt der Schuh:

Ich muss zwei LANs miteinander verbinden und krieg es nicht hin.

Laut Fritzbox ist der Fernzugang eingerichtet. Nach AVM-Wissensdokument #5
1652305357258.jpg

Aber ins andere Netzwerk kann ich nichtmal pingen.
Geschweige denn Datein anzeigen
oder die QNAP-Fernsicherung einstellen.

Die jeweils andere Fritte erreiche ich nur per myFritz-Account.

Diese Anleitung kenne ich. Aber bringt nix. Kann ja nichtmal pingen
Firmware ist aktuell.
Forensuche hat nicht geholfen.

LAN1 Büro
Fritzbox 7530
lokale IP 192.168.0.1
wilhelm.tel

LAN2 Haus
Fritzbox 7530
lokale IP 192.168.20.1
o2

Woran könnte es liegen?
Warum sagt es "grün" aber nix geht? :S


edit: Link zu AVM #5
 
Zuletzt bearbeitet:

blurrrr

Well-known member
Hallo und willkommen :)
Ich muss zwei LANs miteinander verbinden und krieg es nicht hin.

Laut Fritzbox ist der Fernzugang eingerichtet.
1652305357258.jpg
Das sieht mir aber ehrlich gesagt nicht nach einer LAN-zu-LAN-Verbindung aus, sondern nach einer Client-Einwahl. Ich weiss auch nicht, ob die QNAP in der Lage ist, ein Site2Site-VPN bereitzustellen. Theoretisch könnte man "vielleicht" mit Routing und ggf. DNAT-Regeln (auf der QNAP) etwas basteln, aber das erscheint mir doch etwas oversized für diesen Anwendungsfall.

Machen wir es daher ganz einfach: Du hast 2 Fritzboxen - nutzt die einfach für die Site2Site-Verbindung. Das macht auch mehr Sinn, wenn Du "Netze" und nicht "Endgeräte" via VPN verbinden willst. Versuch es mal mit dieser Anleitung:

https://avm.de/service/wissensdaten...wischen-zwei-FRITZ-Box-Netzwerken-einrichten/

Wird schon schief gehen... ☺️
 

noli.melavo

New member
Hallo blurr,

"QNAP-VPN" ist nur der Name von dem Fernzugang

Machen wir es daher ganz einfach: Du hast 2 Fritzboxen - nutzt die einfach für die Site2Site-Verbindung. Das macht auch mehr Sinn, wenn Du "Netze" und nicht "Endgeräte" via VPN verbinden willst. Versuch es mal mit dieser Anleitung:
https://avm.de/service/wissensdaten...wischen-zwei-FRITZ-Box-Netzwerken-einrichten/

Das war genau die Idee und genau so ist es auch eingerichtet.
Einrichten ist ganz einfach, klappen nicht so sehr :)
 

blurrrr

Well-known member
"QNAP-VPN" ist nur der Name von dem Fernzugang
Das entscheidene Wort hier ist "Fernzugang", so heisst das bei einem Site2Site-VPN nicht ;)

1660338131347.png

Diesen Punkt solltest Du bei der Einrichtung wählen :)

Ferner muss der Eintrag zum VPN auch an einer bestimmten Stelle auftauchen:

1660338611603.png

Dort siehst Du dann auch jeweils das lokale und das entfernte (interne) Netz. Du solltest - bei bestehender Verbindung - auf alle Geräte via IP zugreifen können.
 

noli.melavo

New member
Hi
genauso hab ich es gemacht (LAN-LAN-Kopplung)
FSN73fOXwAArodA.jpg
>Dort siehst Du dann auch jeweils das lokale und das entfernte (interne) Netz. Du solltest - bei bestehender Verbindung - auf alle Geräte via IP zugreifen können.
Danke. Das wär cool.
 

blurrrr

Well-known member
"Eingabeaufforderung" -> "ping 192.168.0.1"... wenn das funktioniert, funktioniert der Tunnel auch entsprechend. Auf was genau möchtest Du denn im Büro zugreifen?

EDIT: Btw solltest Du bei der Site2Site-VPN-Einrichtung noch diese beiden Haken setzen:

1660340561070.png
 

noli.melavo

New member
FSN73fOXwAArodA.jpg

Ich will nur die Fernsicherung von den zwei QNAP einrichten.
(1x im Büro und 1x in der Bude hier). Menschlichen Zugriff per VPN brauch ich nicht.
Das lief bisher über Anydesk, falls nötig.
 

blurrrr

Well-known member
Btw mitunter hilft es auch, wenn Du mal hingehst und die beiden Fritzboxen neustartest. Wenn das auch nicht hilft, schmeiss die Verbindungen auf beiden Seiten nochmal weg, starte die Geräte neu und dann richte die VPN-Verbindung wieder ein. Manchmal ist das alles etwas zickig 🙂
 

blurrrr

Well-known member
Du kannst übrigens mit einem "tracert 192.168.0.1" schauen, welchen Weg die Pakete einschlagen. Theoretisch sollte es von Deinem Rechner 1 Hop zu Deiner Fritzbox sein, der nächste sollte auf die Remote-Fritzbox gehen. Taucht auf dem Weg irgendwo eine "öffentliche" IP-Adresse auf, nehmen die Pakete den falschen Weg (direkt ins Internet und nicht in den VPN-Tunnel).
 

blurrrr

Well-known member
Schade, das ist jetzt leider wenig aussagekräftig... Wäre eine öffentliche IP aufgetaucht, wären die Pakete nicht in den Tunnel gegangen, so kann man das jetzt schlecht beurteilen 😄 Ich weiss jedenfalls, dass es durchaus Momente gibt, wo die Fritzbox behauptet, dass der Tunnel verbunden wäre (grün), der Tunnel aber faktisch nicht aufgebaut ist.

"ping" ist jedenfalls sinnvoll, um kurz zu prüfen, ob man sein Ziel erreicht, "traceroute" ist gut, um die Strecke zu verfolgen, welche die Pakete zum Ziel nehmen. So wie sich das derzeit bei Dir gestaltet, würde ich einfach mal behaupten, dass die Pakete entweder a) ins Internet geschickt werden (deswegen auch keine Antwort mehr, private Pakete werden im Internet nicht weitergeleitet), oder b) die Fritzbox der Meinung ist, dass der Tunnel steht, obwohl die Verbindung nicht steht.

Ich würde wirklich zu der Reboot-Geschichte (und ggf. der Neueinrichtung der VPN-Verbindung tendieren).
 

blurrrr

Well-known member

Stationary

Active member
Hast Du mindestens eine öffentliche IPv4? Mindestens eine der beiden Boxen benötigt eine IPv4 aus dem “öffentlichen“ Bereich. Wenn beide Boxen nur eine IPv4 aus dem CG-NAT-Bereich haben, wird das so nichts.
Könntest Du mal von beiden Boxen zumindest die ersten zwei Zahlengruppen der IP posten? Unter Internet, Online-Monitor:
AB71F9D1-1F13-4AE7-A981-D29CBB03F73F.jpeg
 
Zuletzt bearbeitet:

noli.melavo

New member
Moin, Hi,

@blurrrr
hab heute nochmal alles eingerichtet.
Hat leider nix gebracht meh

@blurrrr
die Qnaps sind recht neu und pro, also sollte gehen, mach ich aber nicht
-man soll keine VPNs auf Endgeräte terminieren
-QNAP hat bei mir kein Vertrauen mehr https://www.youtube.com/watch?v=c5k8FWe6u60
-die Fritzbox gibs nur im DACH-Raum, alle anderen arbeiten mit Zyxel/Cisco/Netgear/etc --> Fritzbox ist sichererer
-die Fritzbox sollte es können :>

@Stationary

Burchardkai - Kopie - Kopie.jpg

Es hat bestimmt irgendwas mit diesem Scheiß-Glasfaser zu tun.
Hier im Gewerbepark bricht immer so ab 9.00h das Internet und das Handynetz zusammen.
Sollen sie doch leiebr was bauen, was sie auch beherrschen. Anstelle UHHH GLASFASER 50€ EXTRA JETZE.
Abends, wenn die ganzen 9-to-5s zuhause sind, geht's dann.
 
Zuletzt bearbeitet:

blurrrr

Well-known member
Es hat bestimmt irgendwas mit diesem Scheiß-Glasfaser zu tun.
Nah, wenn der Tunnel steht, dann steht der Tunnel, da hat die Glasfaser nu nix mit zu tun.

Du kannst aber auch mal folgendes versuchen: Lass bei den Tests einfach mal einen Ping auf die öffentliche IP der Gegenstelle laufen (bzw. das zuerst anwerfen, dann Tunnel aufbauen, dann zusätzlich durch den Tunnel pingen). Somit würdest Du auf jeden Fall sehen, wenn die Gegenstelle Aussetzer hätte, so dass der Tunnel ständig zusammenbricht. Grundsätzlich kannst Du dann bei den Tests einfach beide Fenster (ping ext. ip + ping int. ip) einfach offen lassen und laufen lassen. Via Parameter "-t" wird dann auch dauerhaft gepingt, sieht dann z.B. so aus: "ping -t 192.168.0.1", kann via STRG+C abgebrochen werden.

EDIT: Wenn es nur "von Gerät zu Gerät" gehen soll, ist diese Option garnicht so verkehrt, denn Site2Site werden beide Netze "komplett" miteinander verbunden. Da die Fritzbox keine vernünftig konfigurierbare Firewall hat, kann jeder alles aus dem jeweiligen anderen Netz erreichen, ausser Du bastelst Dir manuell eine eigene Config, welche Du dann in die Fritzboxen importieren musst.
 

Letzte Anleitungen

Statistik des Forums

Themen
968
Beiträge
14.039
Mitglieder
500
Neuestes Mitglied
McKay1408
Oben