Umzug von Micro SD auf SSD

killie

New member
Hallo Leute,

ich habe Home Assistant auf dem Raspi 4 laufen und hatte zum herumprobieren ganz normal mit der Micro SD Karte gearbeitet. Nun möchte ich mit dem gesamten System auf eine SSD Platte umziehen. Wer kann mir da helfen?

LG
Sven
 

tiermutter

Well-known member
Moin,

Raspi ist jetzt zwar nicht mein Spezialgebiet, aber solche Umzüge mache ich systemunabhängig gerne indem ich den Datenträger klone.
Ich klone vorzugsweise mit Clonezilla, in Deinem Fall gibt es aber sicherlich eine einfacher zu bedienende Möglichkeit über Klon-Tools die unter Windows etc. laufen. Dazu müsste man beide Datenträger an den entsprechenden Rechner hängen können...
 

blurrrr

Well-known member
Wobei genau brauchst Du denn Unterstützung? Ich würde - so oder so - erstmal ein frisches Image von der SD-Karte erstellen, damit hast Du erstmal ein Backup Deiner SD-Karte (sicher ist sicher, auch wenn theoretisch nix mit der SD-Karte passieren sollte ☺️).
 

carsten_h

Active member
Das geht ganz einfach!
Du hast ja wahrscheinlich Home Assistant OS installiert, oder?

Hier sind die Schritte.
Mit der SD-Karte und laufendem Home Assistant ein Backup erstellen (Einstellungen/Add-ons, Backup&Supervisor/Backup/Backup erstellen) und das irgendwo lokal auf Deinen Rechner packen.
Mit dem Raspberry Pi Imager die 64bit Version von Home Assistant OS auf die SSD flashen.
Den Raspberry Pi auf USB Boot umstellen (wenn gewünscht kann ich noch eine Anleitung posten)
Den Raspberry Pi von der SSD starten lassen (SD-Karte einfach raus).
Warten bis der Onboarding Screen von Home Assistant zugreifbar ist.
Dort das gesicherte Backup hochladen.
Warten
Jetzt hast Du ein Home Assistant System, das haargenau so ist wie vorher von der SD-Karte, nur viel schneller.

Fertig!

Und danach auf jeden Fall ein automatisches Backup mit entweder dem "Samba Backup" Addon oder dem "Google Drive Backup" Addon einrichten!
Ohne Backup ist es immer schlecht!
 

killie

New member
Wobei genau brauchst Du denn Unterstützung? Ich würde - so oder so - erstmal ein frisches Image von der SD-Karte erstellen, damit hast Du erstmal ein Backup Deiner SD-Karte (sicher ist sicher, auch wenn theoretisch nix mit der SD-Karte passieren sollte ☺️).
Ich weiß momentan gar nicht wie ich den Raspi dazu bekomme später alles von der SSD zu booten
 

killie

New member
Das geht ganz einfach!
Du hast ja wahrscheinlich Home Assistant OS installiert, oder?

Hier sind die Schritte.
Mit der SD-Karte und laufendem Home Assistant ein Backup erstellen (Einstellungen/Add-ons, Backup&Supervisor/Backup/Backup erstellen) und das irgendwo lokal auf Deinen Rechner packen.
Mit dem Raspberry Pi Imager die 64bit Version von Home Assistant OS auf die SSD flashen.
Den Raspberry Pi auf USB Boot umstellen (wenn gewünscht kann ich noch eine Anleitung posten)
Den Raspberry Pi von der SSD starten lassen (SD-Karte einfach raus).
Warten bis der Onboarding Screen von Home Assistant zugreifbar ist.
Dort das gesicherte Backup hochladen.
Warten
Jetzt hast Du ein Home Assistant System, das haargenau so ist wie vorher von der SD-Karte, nur viel schneller.

Fertig!

Und danach auf jeden Fall ein automatisches Backup mit entweder dem "Samba Backup" Addon oder dem "Google Drive Backup" Addon einrichten!
Ohne Backup ist es immer schlecht!
Für eine Anleitung USB Boot wäre ich sehr dankbar. Ich weiß gar nicht wo ich ansetzen soll.
 

blurrrr

Well-known member
Sollte theoretisch von USB booten, sobald keine SD-Karte drin ist. Eigentlich probiert jedes System diverse Möglichkeiten durch (auch Dein Rechner, z.B. CD, USB, HDD, Netzwerk) 🙂
 

carsten_h

Active member
Ich weiß gar nicht wo ich ansetzen soll.
Es ist total simpel:
Raspberry Pi Imager nehmen und "OS wählen/Misc Utility Images/Bootloader/USB Boot" auswählen.
Das auf eine SD-Karte flashen
In den Pi stecken und den Pi einschalten.
Sobald die grüne LED blinkt (geht echt schnell) oder an HDMI ein komplett grünes Bild sichtbar ist den Pi wieder ausstellen.
SSD anschließen und Pi wieder einschalten und freuen.

Bei der ganzen Sache mußt Du aber daran denken, daß der USB-SATA Controller in dieser Liste stehen sollte: https://forum-raspberrypi.de/forum/thread/47876-magische-usb-sata-adapter-und-wo-sie-zu-finden-sind/
 

killie

New member
Es ist total simpel:
Raspberry Pi Imager nehmen und "OS wählen/Misc Utility Images/Bootloader/USB Boot" auswählen.
Das auf eine SD-Karte flashen
In den Pi stecken und den Pi einschalten.
Sobald die grüne LED blinkt (geht echt schnell) oder an HDMI ein komplett grünes Bild sichtbar ist den Pi wieder ausstellen.
SSD anschließen und Pi wieder einschalten und freuen.

Bei der ganzen Sache mußt Du aber daran denken, daß der USB-SATA Controller in dieser Liste stehen sollte: https://forum-raspberrypi.de/forum/thread/47876-magische-usb-sata-adapter-und-wo-sie-zu-finden-sind/
Gut das Du das mit den Adaptern erwähnst, das wusste ich z.B. gar nicht. Ich habe eben mal nachgesehen und Glück gehabt. Der von mir gekaufte Adapter mit USB 3 steht in der Liste. Ich werde das heute abend alles mal ausprobieren und bin sehr gespannt was mich erwartet. Vielen Dank erst einmal für Eure schnelle Hilfe.
 

carsten_h

Active member
und bin sehr gespannt was mich erwartet.
Noch einen Hinweis zu USB 3 Adaptern.
Es gibt welche, die ganz merkwürdige Effekte mit HA erzeugen. Bei mir war es z.B. seit einer HA Version so, daß es ziemlich lange gedauert hat bis eine Logdatei angezeigt wurde. Alles andere war schnell. Um das zu beheben, mußte ich die UASP-Unterstützung für meinen USB3-M.2 Adapter (im Argon One M.2 Gehäuse) ausschalten. Dadurch wurde auch der Zugriff auf die SSD schneller, was ja eigentlich widersinnig ist, da UASP ja Geschwindigkeit bringen soll.
Wenn Du also merkst, daß die Logdateien teilweise bis zu 20 Sekunden brauchen um angezeigt zu werden, dann lies hier: https://community.home-assistant.io/t/supervisor-logs-extremely-slow-to-open/344375/22 nach wie man das behebt.
 

killie

New member
Vielen Dank an alle für die schnelle Hilfe. Es läuft jetzt einwandfrei mit meiner SSD. Das ging tatsächlich einfacher wie ich es für möglich gehalten hätte. :)
(y)
 

Zurzeit aktive Besucher

Keine Mitglieder online.

Neueste Beiträge

Letzte Anleitungen

Statistik des Forums

Themen
565
Beiträge
8.272
Mitglieder
193
Neuestes Mitglied
cekap
Oben