Tasmota zeigt keine Geräte

Wolfgang

New member
Hallo zusammen,

ich bin noch recht neu bei HA (komme von Pimatic) und versuche mich gerade durch das Dunkel ins Licht zu begeben.

Bei meiner Tasmota Integration werden keine Geräte angezeigt, obwohl ich sie über MQTT erreichen kann (und sie dort auch angezeigt werden).
HA läuft bei mir als VM über ein Synology NAS. Mosquitto Broker als Container auch über Synology, also nicht in HA.

Nun habe ich aus diversen Links diverse Informationen rausgelesen, die für mich aber kein ganzes Bild ergeben, wie z.B. ich muss einen eigenen Benutzer anlegen (wenn ja, warum? wo würde ich den dann einer Integration oder einem Gerät zuweisen?) - oder der Broker sollte intern innerhalb von HA laufen und nicht extern?

Bin für jeden Tipp dankbar - auch wenn ich noch mehr Informationen liefern sollte.

Danke,
Wolfgang
 
Hi,

also ich hab von der Thematik mal so gar keine Ahnung, hab also nur ein minimales (bis gar kein) Verständnis, ich versuch es trotzdem mal (so als mögliche theoretische Ideen-Hilfe) 😁

HA auf der Syno - Wir reden hier schon von "HAOS", oder?
Mosquitto Broker als Container auf der der Syno - Warum?

Bei der HA-Installation gehe ich mal davon aus, dass Du evtl. auch einfach nur die OVA als VM importierst hast, dann sollte alles in Butter sein (und auch alles dabei sein). Was den MQTT-Broker angeht... das ganze gibt es auch einfach als Addon für HA, allerdings müsste man da vermutlich dann - es wird ja noch irgendein Stück Hardware bzgl. der Kommunikation geben (USB-Stick?) - den entsprechenden Stick noch an die VM durchreichen.

Alternativ (um das jetzt auch nicht unnötig kompliziert zu machen)...

HA-VM -> Broker-Container -> USB-Stick -> Geräte (wenn ich das bisher korrekt verstanden habe).

Was funktioniert: Broker-Container -> USB-Stick -> Geräte
Was nicht funktioniert: HA-VM -> Broker-Container (zumindestens werden keine Geräte angezeigt)

Soweit korrekt?

Grundsätzlich ist es IMMER eine gute Idee, einfach mal in die Logs/Protokolle zu schauen (sowohl HA als auch Container). Falls akut nichts zu finden ist, ruhig mal irgendwas anstossen (k.a. Geräte via MQTT suchen, ansprechen, was weiss ich). Halt irgendwas, was eine funktionierende Verbindung zwischen HA und Broker benötigt (damit in den Logs dann ggf. Fehlermeldungen auftauchen, mit welchen man dann weiterarbeiten kann).

Vielleicht stimmt einfach nur etwas mit der Verbindung zwischen HA und Broker nicht, das sollte man über die Logs schon herausfinden :)
 
Hallo @blurrrr ,

danke für die Rückmeldung - ich war nur ein paar Tage wegen Krankheit ausgefallen.
Das ist meine Version:
Home Assistant 2022.11.2; Supervisor 2022.10.2; Operating System 9.3; Frontend 20221108.0 - latest

Mosquitto Broker als Container über Syno, weil ich modulare Architekturen bevorzuge. Sollte ich zusätzliche Hardware benötigen, um MQTT Broker als Addon in HA laufen zu lassen, wäre das bereits ein Grund das nicht zu tun.

Der Broker kann sowohl mit HA als auch mit den Clients kommunizieren, ich erhalte Daten von diversen Clients über den Broker in HA und kann diese auch steuern.
Beispiel ist diese WiFi STeckdose, auf die ich Tasmota geflasht habe:
1668357895575.png
Lediglich die Integration "Tasmota" zeigt keine Geräte an:
1668357996065.png

In den Logs habe ich zu Tasmota oder MQTT keine Meldungen erhalten.
 
Lediglich die Integration "Tasmota" zeigt keine Geräte an
Öhm... ich bin da jetzt nicht so ganz im Thema, aber...
Der Broker kann sowohl mit HA als auch mit den Clients kommunizieren, ich erhalte Daten von diversen Clients über den Broker in HA und kann diese auch steuern.
Hätte/müsste/sollte das nicht über die Tasmota-Integration laufen? :unsure:

You must also configure each Tasmota device’s MQTT settings to communicate with whatever MQTT broker you are using. Enter the broker address under host and enter a username/password combination that allows access to the broker.

If using the Mosquitto Broker add-on for Home Assistant, first create a new Home Assistant user under Settings > People. Then, in Tasmota > Configure MQTT under “Host” enter the address of your Home Assistant instance and under “User” and “Password” enter the Home Assistant user you just created.
(Quelle: https://www.home-assistant.io/integrations/tasmota/)

Du gehst dann vermutlich über das Mosquitto-Broker-Addon und nicht über das Tasmota-Ding?

.oO(Hoffe hier redet nochmal jemand mit, der sich damit auch auskennt... 😁)
 
Schau mal auf deinem Tasmota unter console
Gebe nachstehendes ein
Code:
SetOption19 0
Dann sollte er sich unter dem Tasmota AddIn melden, nachteil dann ist MQTT weg
Mit
Code:
SetOption19 1
Sendet er wieder über MQTT nachteil er verschwindet unter Tasmota
 
Ich habe ein ganz anderes Problem: Bei mir tauchen frisch geflashte Steckdosen (Sonoff S20) zwar automatisch in der Tasmota-Integration auf und ich kann von dort das Webinterface der Steckdose aufrufen, die installierte Firmware sehen usw., aber alle Steuerlemente sind ausgegraut. Ich kann die Steckdosen zwar benutzen, muss aber die MQTT-Befehle direkt in der Automation verwenden.
In den Einstellungen sieht eine Steckdose z. B. so aus:

1672749815791.png

Hat da jemand eine Idee, was ich evtl. falsch mache?
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
3.238
Beiträge
35.539
Mitglieder
2.663
Neuestes Mitglied
Delles
Zurück
Oben