TASMOTA IR-Reader

TomOene

New member
Hallo!
Ich nutze einen TASMOTA IR-Reader und lese so meinen Stromzähler aus. Die Daten werden auch an Homeassistant gesendet. Soweit also alles gut.
Jetzt würde ich gerne die Entität im Energie-Dashboard wählen. Dort gibt es sie allerdings nicht zur Auswahl.
Ich weiß, dass ich die Entitäts-Attribute verändern muss. Ich hab allerdings keine Ahnung, wie.
Gibt es jemanden, der mir da weiterhelfen kann.
Vielen Dank schon mal!
 

blurrrr

Well-known member
Jetzt würde ich gerne die Entität im Energie-Dashboard wählen. Dort gibt es sie allerdings nicht zur Auswahl.
Ich weiß, dass ich die Entitäts-Attribute verändern muss. Ich hab allerdings keine Ahnung, wie.
Wie soll in HomeAssistant etwas angezeigt werden, was es vermeintlich nicht gibt? Irgendwas muss ja da sein zur Anzeige? :unsure: Was genau meinst Du mit der Veränderung der Entitätsattribute?

EDIT: Damit ist gemeint, dass eine genaue Beschreibung dessen, was Du bisher getan hast und wie weit Du damit gekommen bist, mitunter ganz hilfreich sein könnte für Leute, die zwar helfen wollen, aber nichts mit einem "TASMOTA IR-Reader" zu tun haben - geht ja prinzipiell erstmal nur noch um die Verarbeitung der Daten innerhalb von HomeAssistant, aber dazu wäre es schon hilfreich, "wie" die Daten da überhaupt gelandet sind und wo genau es jetzt hakt (gerne auch mit Auszügen aus der Config) :)
 
Zuletzt bearbeitet:

the other

Well-known member
Moinsen,
es wäre in der Tat hilfreich, wenn bekannt wäre
- welches Tasmota Modell mit welcher Firmware genutzt wird
- wie du die Daten vom IR Reader an HomeAssistant (hier als Abkürzung HA im weiteren ;) )schickst, MQTT?
Ich bin zwar ebenfalls kein HA Freak (soll heißen, ich mach da was mit, aber nicht solch komplexeren Dinge wie du, ist also nicht despektierlich gemeint), aber das Forum wird ja auch von Menschen genutzt, die da viel mehr Erfahrungen mitbringen.
Was ein kurzes googlen meinerseits lediglich ergeben hat:
-mit weiteren HA Versionen kann es sein, dass dein Model dann doch direkt via GUI unterstützt wird in der Anzeige
-oder du musst dann wirklich via yaml Anpassungen vornehmen, um die Messwerte für das Energy Dashboard zu "übersetzen", die jetzt scheinbar noch nicht kompatibel ankommen.
Welche Anpassungen dann im Detail nötig werden, hängt eben auch vom Modell / Firmware mit ab...
:)
 

alexamend

Active member
Hallo TomOene,

@the other, muss dier hier leider wiedersprechen, es liegt einzig und allein an den customize_glob: Settings, hat nichts mit der FW Tasmota und/oder des ESP zu tun.

hierzu benötigts du nachstehenden Eintrag in deiner configuration.yaml

Einmal HA Neu Starten danach sollten die Sensoren in der Energie Sichtbar sein

YAML:
# IR Stromzähler auslesen
homeassistant:
  customize_glob:
    sensor.netz_netz_total_in:
      unit_of_measurement: "kWh"   
      device_class: energy
      state_class: total_increasing
      last_reset: 1970-01-01T00:00:00+00:00
    sensor.netz_netz_power_cur:
      unit_of_measurement: "Wh"   
      device_class: energy
      state_class: total
      last_reset: 1970-01-01T00:00:00+00:00

EDIT: Die Einstellungen musst du dann über " Einstelungen -> Dashboard -> Energie " vornehmen.
 
Zuletzt bearbeitet:

alexamend

Active member
hier noch die Einstellungen für das ESP

dies muss unter Script Eingetragen werden


Code:
>D
>B
=>sensor53 r
>M 1
+1,3,s,16,9600,Netz
1,77070100010800ff@1000,Gesamtverbrauch,KWh,Total_in,3
1,77070100100700ff@1,Leistung,W,Power_cur,2
1,77070100000009ff@#,Service ID,,Meter_id,0|
#

ESP Script.JPG

und dies unter MQTT -> Full Topic

Code:
%prefix%/%topic%/%total_increasing%/%state_class%/%unit_of_measurement%/

ESP MQTT FGull Topic.JPG
 

TomOene

New member
Hallo TomOene,

@the other, muss dier hier leider wiedersprechen, es liegt einzig und allein an den customize_glob: Settings, hat nichts mit der FW Tasmota und/oder des ESP zu tun.

hierzu benötigts du nachstehenden Eintrag in deiner configuration.yaml

Einmal HA Neu Starten danach sollten die Sensoren in der Energie Sichtbar sein

YAML:
# IR Stromzähler auslesen
homeassistant:
  customize_glob:
    sensor.netz_netz_total_in:
      unit_of_measurement: "kWh"  
      device_class: energy
      state_class: total_increasing
      last_reset: 1970-01-01T00:00:00+00:00
    sensor.netz_netz_power_cur:
      unit_of_measurement: "Wh"  
      device_class: energy
      state_class: total
      last_reset: 1970-01-01T00:00:00+00:00

EDIT: Die Einstellungen musst du dann über " Einstelungen -> Dashboard -> Energie " vornehmen.
Danke, Problem gelöst. Vielen Dank für die Hilfe!
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
968
Beiträge
14.038
Mitglieder
499
Neuestes Mitglied
John58
Oben