Shelly EM3 Verbrauch summiert anzeigen lassen

Frama

Member
Hallo, habe den Homeassistant soweit zum laufen gebracht und auch schon einiges nach Anleitung ausprobiert. Soweit komme ich eigentlich gut zurecht in der neuen Umgebung. An einer Sache jedoch bin ich hängen geblieben und komme einfach nicht weiter. Ich habe mir den Shelly EM3 eingebunden um meinen aktuellen Stromverbrauch zu überwachen. Soweit so gut....Von den zu verfügung stehenden Entitäten wird nur jede einzelne Phase zum auslesen angeboten jedoch kein Gesamtverbrauch. Gibt es irgendwie die Möglichkeit z.b. mit einem Helfer angebotenen PowerA, Power B und Power C zusammen zu fassen damit ich den Gesamtstromverbrauch anzeigen lassen kann ? Würde mich echt freuen wenn jemand eine einfache Lösung für mich hätte.
 
Ich bin auch Anfänger und habe erst jetzt rausgefunden das die Änderung mit dem file editor in der Configuration yaml erfolgen muss:

YAML:
template

- sensor:
    - name: "Total Power"
      device_class: power
      state_class: total
      unit_of_measurement: "W"
      state: >
        {{
        states('sensor.gesamtverbrauch_channel_a_power')| float(0) +
        states('sensor.gesamtverbrauch_channel_b_power')| float(0) +
        states('sensor.gesamtverbrauch_channel_c_power')| float(0)
        }}



Dadurch gibt es eine neue Entität Total power.
 
Zuletzt bearbeitet von einem Moderator:
Hallo Stone1, vielen dank für deine Nachricht.
habe versucht die änderung im Editor so zu machen aber ich produziere irgendwie nur Fehler. Kannst du dir bitte die Hardcopy mal anschauen ob die einträge mit deinen übereinstimmen und mir einen Tipp geben was ich noch ändern muss das es passt. 2022-10-06 23_35_31-Window.png
 
Ach, ich sehe Du bist schon nen Schritt weiter als in dem anderen Thread.

Hier hast Du die Einrückungen leider völlig ignoriert, die sind in yaml extrem wichtig - und auch sonst den Code etwas arg abgeändert. Lösch alles ab Zeile 14 und schreib hier das rein, was Du versucht hast im Dashboard einzutragen, dann sollte das laufen.

Sollte es dann noch Fehler geben, sei so nett und poste den Code (auch als Code formatiert) hier rein anstelle von Screenshots, das erleichtert die Fehlersuche erheblich.
 
Ja, habe zwar etwas gebraucht um zu verstehen aber durch die super Unterstützung hier im Forum bin ich dann doch dahinter gekommen was ich falsch gemacht habe. Läuft jetzt wie ich es mir vorgestellt habe.
Vielen Dank nochmal👍
 
@Frama sehr schön! :)

Bist Du so lieb und hinterlässt nochmal kurz, was Dein Weg war / wie Dein Problem am Ende gelöst wurde? Für andere Menschen, die vor dem gleichen Problem stehen ;)
 
Hallo Nival,
Mein Hautproblem war eigentlich das ich erst ganz am Anfang stehe die Zusammenhänge in HA zu verstehen. Dementsprechend habe ich erst mal nicht gewusst wo ich den Code reinkopieren soll. Erst nach einiger Unterstützung und geduldigen Erklärungen habe ich den Code mit einem Editor (Studio Code Server aus HACS) in configuration.yaml eingetragen, wodurch die Entität "sensor.energy_total" erzeugt wurde die ich dann in der Elemente-Kartenkonfiguration Total Energy verwenden konnte um mir die summierte Leistung anzeigen zu lassen. Die angepassten Einträge sehen bei mir so aus ....
YAML:
sensor:
  - platform: template
    sensors:
      energy_total:
        friendly_name: 'Total Energy'
        value_template: "{{ (states('sensor.shelly_em3_channel_a_power')|float + states('sensor.shelly_em3_channel_b_power')|float + states('sensor.shelly_em3_channel_c_power')|float)|round(3) }}"
        unit_of_measurement: "W"
 
Hi zusammen,
Ich nutze seit gestern Home Assistant und stehe vor dem gleichen Problem.
Ich habe jetzt folgendes über denn File Editor eingegeben.

YAML:
sensor:
  - platform: template
    sensors:
      energy_total:
        friendly_name: 'Total Energy'
        value_template: "{{ (states('sensor.shelly_em3_channel_A_power')|float + states('sensor.shelly_em3_channel_B_power')|float + states('sensor.shelly_em3_channel_C_power')|float)|round(3) }}"
        unit_of_measurement: "W"
 
Zuletzt bearbeitet von einem Moderator:
Moinsen,
Tipp: es ist für helfende Menschen immer toll, wenn viele konkrete Infos mitgegeben werden...
soll heißen:
Jetzt habe ich eine Fehlermeldung und weiß aber nicht was diese bedeutet
wir auch alle nicht, wir sehen ja nicht mal die Meldung.
Also, screenshots sind top, einfache Angabe des Fehlers im Protokoll sind auch ok.
;)
Ansonsten bist du bei @Nival in superduper Händen...
 
Die Fehlermeldung konnte ich beseitigen und die Messung habe ich auch hin bekommen. Danke für denn Tipp mit denn Sensoren diese hatten einen anderen Namen
 
Guten morgen,

Hätte doch noch eine Frage?
Ich würde denn erstellten Sensor gerne als Trigger benutzen. Er sollte z.b. bei einer Einspeisung von mindestens -300 W einen Luftentfeuchter der an einer smarten Steckdose hängt ( ist schon im Home Assitant eingepflegt) einschalten. Was muss ich bei denn Automationen wählen.
 
Aktuell habe ich es noch mit zwei Automatisierungen gelöst, lässt sich aber auch auf nur eine realisieren, war bisher nur zu faul.
Code:
alias: Laden einschalten bei < -50 Watt
description: ""
trigger:
  - type: power
    platform: device
    device_id: 2e562692166a7f556412a313a97fe3eb
    entity_id: sensor.electricity_rodgener_strasse_22_total_power
    domain: sensor
    below: -50
    for:
      hours: 0
      minutes: 0
      seconds: 5
condition:
  - condition: device
    type: is_off
    device_id: 8108003bdaed789a110dae8cf2a57cd3
    entity_id: switch.messstelle
    domain: switch
action:
  - type: turn_on
    device_id: 8108003bdaed789a110dae8cf2a57cd3
    entity_id: switch.messstelle
    domain: switch
mode: restart

Code:
alias: Laden ausschalten bei > 10 Watt
description: ""
trigger:
  - type: power
    platform: device
    device_id: 2e562692166a7f556412a313a97fe3eb
    entity_id: sensor.electricity_rodgener_strasse_22_total_power
    domain: sensor
    above: 10
    for:
      hours: 0
      minutes: 0
      seconds: 5
condition:
  - condition: device
    type: is_on
    device_id: 8108003bdaed789a110dae8cf2a57cd3
    entity_id: switch.messstelle
    domain: switch
  - condition: state
    entity_id: input_boolean.laden_ohne_uberschuss
    state: "off"
action:
  - type: turn_off
    device_id: 8108003bdaed789a110dae8cf2a57cd3
    entity_id: switch.messstelle
    domain: switch
mode: restart

Wenn die Einspeisung ins öffentliche Netz mehr als -50 Watt sind, schaltet er die Steckdose, wo das Ladegerät für die Batterie dran hängt.
Geht der Verbrauch auf über 10 Watt, wird diese Steckdose wieder ausgeschaltet.
Mußt natürlich deine eigenen Geräte dort auswählen.
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
4.484
Beiträge
46.110
Mitglieder
4.111
Neuestes Mitglied
searchingnet
Zurück
Oben