selve github

Nina92

New member
Hallo,

HomeAssistent ist endlich installiert und soweit eingerichtet. Ich habe Rollladen von selve und würde gerne folgendes Modul installieren:


Kann mir jemand erklären, wie ich das installiert bekomme?

Viele Grüße
Nina
 

blurrrr

Well-known member
Scheint wohl so, als müsstest Du so ein "usb-rtf gateway" an das Gerät anschliessen, wo auch Deine HomeAssistant-Installation läuft. Hast Du denn schon so ein USB-Gateway?

https://www.selve.de/Service-Downloads/Software/

Das commeo USB-RF Gateway ist das Bindeglied zwischen den SELVE Funktechnologien commeo, iveo (intronic) und der eigenen individuellen Anwendung.

Ohne sowas, dürfte es wohl eher schwierig (bis unmöglich) werden. Wohin dann ggf. noch https://github.com/gpulido/python-selve muss, kann ich Dir leider nicht sagen, aber danach sieht es ja so aus, als müsste nur noch der Eintrag...

selve:
port: /dev/ttyUSB0

... in die HomeAssistant-Konfigurationsdatei geschrieben werden.

Allerdings gibt es hier sicherlich einige Leute, die sich mit HomeAssistant wesentlich besser auskennen als ich, ich hatte das bisher nur mal kurz installiert :)
 

Nina92

New member
Das USB-Gateway von selve habe ich. Mir geht es eher darum, was ich jetzt genau in HomeAssistent machen muss. :D also wie bekomme ich das Modul installiert.
 

azrael783

Active member
Du musst die Dateien aus dem "custom_component" Ordner aus dem Github Repo auf deine HA Maschine kopieren. Am einfachsten kopierst du den gesamten Ordner in den "config" Ordner von HA. Je nachdem wie du HA installiert hast, musst du dann den Befehl von @blurrrr auch noch ausführen.
 

Nina92

New member
So..Dateien sind kopiert und USB Stick ist drin. Nur sie installiere ich das Modul? Also wo gebe ich pip install python-selve ein? Nutze die grafische Oberfläche.
 

blurrrr

Well-known member
Also wo gebe ich pip install python-selve ein?
Da wirst Du die grafische Oberfläche wohl verlassen und Dich in die Untiefen der Shell begeben müssen 😇 "SSH" wäre so das Stichwort, allerdings spielt die Installationsart mitunter auch noch ein wenig rein. "Wie" wurde HA denn installiert? Je nachdem, gestaltet sich der Weg zum Ziel ein wenig anders.
 

carsten_h

Active member
Du musst die Dateien aus dem "custom_component" Ordner aus dem Github Repo auf deine HA Maschine kopieren.
Gibt es diese Software nicht auch irgendwie über HACS? Oder kann man dieses hier nicht über HACS einbinden?
Das ist doch viel einfacher als das selber irgendwo hinzukopieren. Dann muß man sich ja auch um Updates selber kümmern.
 

Nina92

New member
Gibt es diese Software nicht auch irgendwie über HACS? Oder kann man dieses hier nicht über HACS einbinden?
Das ist doch viel einfacher als das selber irgendwo hinzukopieren. Dann muß man sich ja auch um Updates selber kümmern.
So wie ich es verstanden habe, gibt es die nicht über HACS. Aber ich glaube, dass mir jetzt auch die automationen zu kompliziert werden. Bzw. Wollte ich die Rollläden eigentlich in HomeKit haben. Aber ich habe jetzt die Dateien rein kompiert komme nicht weiter. Zumal es ja noch die Libery gibt, die ich bestimmt auch noch benötige:

 

Nina92

New member

blurrrr

Well-known member
Ich rate jetzt einfach mal:

Links im Menü auf Hass.io, dort oben bei den Menüpunkten auf "ADD-ON STORE". Dann in der Auswahl SSH installieren. Unten drunter sollte dann noch ein Feld "Options" vorhanden sein. Dort trägst Du ein:
{
"password": "Dein-gewünschtes-Passwort"
}
Danach unten drunter auf "Save" klicken. Danach solltest Du Dich mittels SSH-Client (z.B. PuTTY) mit der IP der Installation verbinden können (IP + Port 22). Die Logindaten sollten dann "root" und "Dein-gewünschtes-Passwort" lauten. Falls das nicht direkt klappen sollte, ggf. den Raspi einfach mal neustarten. Da solltest Du dann die Möglichkeit haben, den pip-Befehl auszuführen.
 

Nina92

New member
Ich rate jetzt einfach mal:

Links im Menü auf Hass.io, dort oben bei den Menüpunkten auf "ADD-ON STORE". Dann in der Auswahl SSH installieren. Unten drunter sollte dann noch ein Feld "Options" vorhanden sein. Dort trägst Du ein:

Danach unten drunter auf "Save" klicken. Danach solltest Du Dich mittels SSH-Client (z.B. PuTTY) mit der IP der Installation verbinden können (IP + Port 22). Die Logindaten sollten dann "root" und "Dein-gewünschtes-Passwort" lauten. Falls das nicht direkt klappen sollte, ggf. den Raspi einfach mal neustarten. Da solltest Du dann die Möglichkeit haben, den pip-Befehl auszuführen.
Sehr gut...das hat schon mal funktioniert...vielen dank! :) wenn ich die konfig nun überprüfe, dann kommt folgende Mitteilung:
Component error: port - Integration 'port' not found. Invalid config for [selve]: required key not provided @ data['selve']['port']. Got None. (See ?, line ?).
 

blurrrr

Well-known member
https://github.com/gpulido/python-selve besagt:

Example of use​


Create a new instance of the gateway:

gat = Gateway(portname)

portname is the name of the serial port where the usb rf gateway is listed on the os. Please refer to the serial library documentation.

Vermutlich wurde kein entsprechendes Gateway angegeben? Habe grade mal kurz geschaut und bin über folgendes gestossen:

https://github.com/gpulido/homeassistant-selve

Da wird in der HomeAssistant-Config anscheinend nur ein neues Device angelegt und dann "sollte" es vermutlich "theoretisch" funktionieren, aber eigentlich hab ich auch mal so gar keine Ahnung und ob das in Kombi mit dem anderen Gedöns funktioniert... also wenn es jemand weiss, ich definitiv nicht 😇
 

Nina92

New member
https://github.com/gpulido/python-selve besagt:


Vermutlich wurde kein entsprechendes Gateway angegeben? Habe grade mal kurz geschaut und bin über folgendes gestossen:

https://github.com/gpulido/homeassistant-selve

Da wird in der HomeAssistant-Config anscheinend nur ein neues Device angelegt und dann "sollte" es vermutlich "theoretisch" funktionieren, aber eigentlich hab ich auch mal so gar keine Ahnung und ob das in Kombi mit dem anderen Gedöns funktioniert... also wenn es jemand weiss, ich definitiv nicht 😇
Das heißt, ich schreibe gat = Gateway(portname) noch in die Konfig Datei und portname ersetze ich durch ttyUSB0?
 

blurrrr

Well-known member
Keine Ahnung, ich hätte vermutlich in die HA-Config erstmal das geschrieben, was in dem verlinkten steht (selve: ...) und mich vermutlich erstmal an dem anderen bedient. Zu dem zuletzten von Dir verlinkten Artikel findet man ja irgendwie mal so garnichts was irgendwie hilfreich wäre (sofern man jetzt kein Programmierer ist) 😄
 

Nina92

New member
Keine Ahnung, ich hätte vermutlich in die HA-Config erstmal das geschrieben, was in dem verlinkten steht (selve: ...) und mich vermutlich erstmal an dem anderen bedient. Zu dem zuletzten von Dir verlinkten Artikel findet man ja irgendwie mal so garnichts was irgendwie hilfreich wäre (sofern man jetzt kein Programmierer ist) 😄
so...die Konfig sagt jetzt, dass alles in Ordnung ist. Ich habe die zweite Zeile nicht eingerückt. :D
selve:
port: /dev/ttyUSB0
Nur wie geht es jetzt wieder? Wie finde ich die Rollläden jetzt in HomeAssistent?
 

blurrrr

Well-known member
Keine Ahnung, ich hab von HA "kaum" Ahnung, von dem ganzen Rest... garnicht 😅 Ich würde aber mal "vermuten", dass theoretisch im HA jetzt zumindestens das USB-Ding irgendwie gelistet sein sollte und darüber dann die entsprechenden Entitäten zu finden sein sollten (natürlich nur, falls alles funktioniert hat). Von daher würde ich da einfach mal bei diesem Developer-Ding in HA schauen, ob sich da ggf. etwas getan hat und neue Entitäten aufgetaucht sind. Ist jetzt aber auch nur eine grobe Vermutung...
 

Nina92

New member
Keine Ahnung, ich hab von HA "kaum" Ahnung, von dem ganzen Rest... garnicht 😅 Ich würde aber mal "vermuten", dass theoretisch im HA jetzt zumindestens das USB-Ding irgendwie gelistet sein sollte und darüber dann die entsprechenden Entitäten zu finden sein sollten (natürlich nur, falls alles funktioniert hat). Von daher würde ich da einfach mal bei diesem Developer-Ding in HA schauen, ob sich da ggf. etwas getan hat und neue Entitäten aufgetaucht sind. Ist jetzt aber auch nur eine grobe Vermutung...
ja..die entitäten sind alle da....auch in Homekit werden die Rollläden jetzt angezeigt :) Nur sie fahren weder rauf noch runter....also auf Homekit reagieren sie nicht und in HomeAssistent wüsste ich nicht, wie man das macht :D
 

Zurzeit aktive Besucher

Keine Mitglieder online.

Neueste Beiträge

Letzte Anleitungen

Statistik des Forums

Themen
565
Beiträge
8.272
Mitglieder
193
Neuestes Mitglied
cekap
Oben