Rezension Shelly Plus H&T WLAN Thermo- und Hygrometer und Einrichtung unter Home Assistant

Guten Abend zusammen,
mein Name ist Hausanschlussraum und ich nutze seit ca. 10 Tagen Home Assistant. Hatte mir dafür unter anderem ein Shelly Plus H&T WLAN Thermo- und Hygrometer gekauft, und mit relativ viel Mühe eine Rezension für Amazon geschrieben, welche aber abgelehnt wurde (möglicherweise weil ich als Teil der Konfiguration Beispiele mit wss-URLs angegeben habe). Vielleicht hilft es ja jemanden hier.

---

Ich benutze das Shelly Plus H&T jetzt seit einigen Tagen mit Home Assistant und bin im wesentlichen zufrieden. Die teilweise schlechten Erfahrungen anderer Rezensionen kann ich nicht wirklich nachvollziehen. Eventuell wurden Probleme per Softwareupdate behoben (habe Version 0.12.0), oder die Probleme traten bei Benutzung der Shelly App auf, welche ich nicht nutze.

Das Display ist ein sehr schönes und scharfes ePaper-Display. Die Temperatur ist auf das Zehntelgrad gleich wie bei einem anderen digitalen Thermo- und Hygrometer, welches wir seit vielen Jahren nutzen. Die Luftfeuchte war 5 Prozent höher als bei dem alten Gerät. Für beide Werte kann man aber einen Offset konfigurieren.

Zunächst der negative Punkt: Es ist wirklich sehr schwer, den kleinen Ständer anzubringen, wenn man das Produkt auf dem Tisch verwenden möchte. Mir ist die eine Seite des Ständers dann sogar abgebrochen. Eventuell hilft es, das Plastik kurz etwas zu erwärmen, um es flexibler zu machen. Auf jeden Fall muss man sowohl kraftvoll als auch vorsichtig sein.

Jetzt zur Einrichtung:

Die Abdeckung geht nicht leicht ab, aber im Gegensatz zu anderen hier habe ich statt eines Schraubenziehers (der dann das Gehäuse beschädigt) meinen Fingernagel genutzt, damit ging es dann gut.

Man kann sowohl mit Batterien, als auch mit USB-C, sowie beiden gleichzeitig die Stromversorgung herstellen. Wenn man beides verwendet, dann werden die Batterien nur genutzt, wenn kein Strom über USB kommt.

Für die Einrichtung muss man den Knopf unter der Abdeckung drücken. Dann wird "Set - AP" angezeigt und es werden interner Hotspot und Webserver aktiviert. Beim ersten Einrichten dann mit dem Laptop oder Smartphone mit dem WLAN-Hotspot ShellyPlus-HT-123456 verbinden (eventuell dem Handy sagen, dass es die Verbindung trotz fehlendem Internet aufrecht erhalten soll), angeben und dann im Browser 192.168.33.1 aufrufen.

Falls sich das Gerät zwischendurch abschaltet, einfach den Knopf noch einmal drücken und die Seite neu laden.

Dann als erstes die WLAN-Einstellungen ändern, WiFi 1 aktivieren und den Namen sowie das Passwort des heimischen WLAN-Netzwerks eingeben, sowie am besten gleich eine statische IP-Adresse vergeben (sowie Netzwerkmaske, Gateway und DNS). Nach dem Speichern ist das Gerät auf der eingegebenen IP-Adresse im Heimnetz erreichbar.

Als erstes führt man am besten ein Firmwareupdate unter Settings->Firmware aus.

Dann kann man unter Settings noch Standort, Zeitzone und Zeitserver (bei mir die Fritzbox) eingeben.

Und damit das ganze unter Home Assistant funktioniert, dann unter Settings->Outbound websocket den Websocket aktivieren und konfigurieren. Mein Home Assistant läuft mit https und hat einen Domain-Namen, der auch mit IPv6 funktioniert. Daher muss man dann unter Server "wss://meinservername.duckdns.org/api/shelly/ws" eingeben. Wer Home Assistant ohne Verschlüsselung und Domain-Namen laufen hat, kann "ws://192.168.1.2/api/shelly/ws" nutzen, wo die IP-Adresse die IP-Adresse der Home-Assistant-Instanz ist.

In den Einstellungen kann man auch einen Namen, sowie einen Offset für Temperatur und Luftfeuchte angeben; außerdem, nach welcher Höhe der Änderung eine Aktualisierung an das Netzwerk gesendet werden soll (Tradeoff Batterielaufzeit - Schnelligkeit der Aktualisierung der Temperatur).

Während man Firmwareupdate und Einstellungen intensiv nutzt, erwärmt sich das Gerät und es wird kurz eine hohe Temperatur angezeigt (bei mir fast 30°C). Davon nicht irritieren lassen, das normalisiert sich nach einer Viertelstunde wieder.

Nachdem alles eingerichtet ist, kann man das Gerät dann einfach im Home Assistant unter Settings->Devices and Services hinzufügen (war zumindest bei mir automatisch erkannt), und dann z.B. beim Dashboard eine entsprechende Karte hinzufügen.

Das ganze läuft bisher stabil und genau. Ich werde die Rezension mit langfristigeren Erfahrungen aktualisieren.

Ich habe vor, unsere Heizungssteuerung (Raumthermostate für Fußbodenheizung) zu erneuern und plane, eventuell die Shelly Plus H&T als Temperatursensoren zu verwenden. Daher werde ich das Verhalten genau beobachten.

chrome_2023-02-04_16-18-20.png
 
Hallo Hausanschlussraum,

habe mich sehr über den Beitrag gefreut. Der Shelly H&T plus ließ sich bei mir nicht in Home Assistant einbinden.
Meine vorhanden drei Shelly`s H&T (normal) funktionieren perfekt.

Deshalb habe ich gedacht der H&T plus ist defekt und ich habe einen weitern gekauft. Doch hier genau dasselbe Spiel, auch dieser läßt sich nicht einbinden. Und nun lese ich Deinen Beitrag und hier benötige ich Hilfe.

Was muss genau in --> Settings->Outbound websocket <-- eingetragen werden ???

Meine HA starte ich wie folgt: http://homeassistant.local:8123

Neustarts des Shelly Gerätes und HA. Alles nichts. Hab nach mehreren Stunden aufgegeben.

Mit Spannung hoffe ich auf eine Lösung. Mit freundlichen Grüßen Rainer
 
ws://homeassistant.local/api/shelly/ws würde ich sagen. Und wenn das nicht geht, dann statt homeassistant.local die IP-Adresse von Deinem Home Assistant.
Wobei ich mir nicht ganz sicher bin, ob das Home Assistant beim Hinzufügen auch selbst einrichten kann.
 
Also ich habe zwei Shelly Plus H&T. Beide laufen mit HA. Hast du die aktuelle Firmware drauf und einen Web Socket eingetragen?

ws://homeassistantipaddress:8123/api/shelly/ws

Gruß
Michael
 
Vielen Dank an Hausanschlussraum und mkonline für die Info`s.

Ich habe im Laufe der letzten 2 Jahre mehr als 70 Shelly Geräte in meinem Haus installiert und in Betrieb genommen.
Kenne mich also ein bißchen (!) aus.
Doch dieses Shelly plus H&T bringt mich langsam auf die Palme.

Im aufgewachten Gerät habe ich es natürlich mit den vorgeschlagenen Einträgen:
--> ws://homeassistantipaddress:8123/api/shelly/ws

--> ca.pem und auch mit --> user_ca.pem
=> ws://123.123.123.91:8123/api/shelly/ws
sowohl auch
=> ws://homeassistant.local:8123/api/shelly/ws
versucht.

Es wird wie in (Anhang 1) folgende Meldung ausgegeben: ERFOLG
Dann ist der Eintrag in der Shelly Liste (Anhang 2)
!!! Aber es ist kein Gerät und Entitäten eingetragen (Anhang 3) !!!

Es scheint die Konfiguration in HA NICHT zu funktionieren.

Vielen Dank für Eure Hilfe.
 

Anhänge

  • Anhang 1.png
    Anhang 1.png
    24,5 KB · Aufrufe: 6
  • Anhang 2.png
    Anhang 2.png
    27,2 KB · Aufrufe: 6
  • Anhang 3.png
    Anhang 3.png
    17 KB · Aufrufe: 6
Moin, ich bin neu hier, hatte aber mit den gleichen Schwierigkeiten zu kämpfen. Habe mein "Heimnetz" bereits vor 10 Jahre angefangen mit Hue, Netatmo und Conrad Connect/IFTTT zu "automatisieren". Nun seit einer Woche mit Homeassistant unterwegs und echt begeistert. Nun aber zu meinem erst Beitrag: :)

Bei mir war der gleiche Effekt wie bei @Rsc_Rainer, Der Shelly Plus HT hat sich nicht als eigenes Gerät mit Entitäten integriert. Mit den Empfehlungen hier habe ich weiter experimentiert und bin letztendlich zum Erfolg gekommen:

1. Homeassistant 2023-02 läuft z.Z. auf einem iMac (192.178.168.20) unter VirtualBox und ist auf Port Homeassistant.local:8123 normal erreichbar.
2. In der Fritz!box habe ich festgestellt, dass Homeassistant eine eigene IP Adresse bekommen hat.
3. Als ich den WebSocket mit diese Adresse (bei mir 192.168.178.45:8123 und "*" anstatt "ca.pem") konfiguriert habe konnte ich auf der Shelly HT Seite sehen, dass die Socket-Verbindung etabliert wurde (Shelly Plus HT mit Cloud enabled).
4. Nach der WebSocket Verbindung erschien in HA dann auch der Shelly Plus HT als 1 Gerät mit 4 Entitäten.

Hoffe das hilft euch bei eurem nächsten Versuch. Bei mir waren es >5 :)
 
Zuletzt bearbeitet:
Hallo Innovator,
Danke für Deinen Beitrag.

Ich habe den WebSocket unter
3. genau so konfiguriert !!! --> Nach einem Neustart des Shelly Plus H&T ist der Eintrag auch dort gespeichert.
Wo bitteschön finde ich einen Eintrag --> das die Socket-Verbindung etabliert wurde
(Shelly Plus HT mit Cloud enabled). ???????

Natürlich ist auch nach dem 10. Versuch in den HA Integrationen das Gerät --> shellyplusht-08b61fcd05b0 eingetragen,
aber NICHT als Gerät und auch ohne Entitäten.

Kannst Du nochmals Info?s schicken.
Wenn`s dann nicht klappt, schmeiss ich das Ding in den BaldeneySee

Mit freundlichen Grüßen aus Essen
Rainer
 
Kannst Du nochmals Info?s schicken.
Wenn`s dann nicht klappt, schmeiss ich das Ding in den BaldeneySee
In der Shelly App gehst Du auf den HT (mit Cloud) und wählst Einstellungen -> Netzwerk -> Ausgehendes Websocket. Da sollte dann "Status: verbunden"! über dem blauen Auswahl-Feld zum aktivieren der WebSocket-Verbindung stehen. Das Pull-Down Menü unter der gelben Warnung zeigt den * und darunter deine HA-Adresse wie oben beschrieben.

Ich habe den falsch Integrierten HT in HA gelöscht und den geöffneten HT über den Reset-Kopf aktiviert. Dann bei den WebSocket-Enstellungen auf speichern gedrückt und den Neustart abgewartet. Irgendwann kam dann Status: verbunden und HA hat den vollständigen HT zur Integration gefunden. Ob die aktivierte Shelly-Cloud erforderlich ist, habe ich nicht weiter untersucht. Btw. bevor du den HT in den schönen See schmeißt, schicke ihn zu mir ;-)

Ach ja, welche Firmware hat Dein HT? Ich bekam am Sonntag (per Cloud) vor dem erfolgreichen Versuch noch den Hinweis, dass ich zum letzten Stabilen-Release zurückgehen soll. => 20221206-142534/0.12.0-gafc2404

Geht Websocket überhaupt gleichzeitig mit Shelly Cloud?
Offensichtlich ja. ;)
 
Danke.
Funktioniert leider nicht.
Die Firmware hab ich auch installiert.

Die Anzeige über dem blauen Haken zeigt immer: Status: getrennt
Beim speichern wird gemeldet: Ausgangsserver aktiv
Nach zigmal Neustart und Änderung der Serveradresse ca.pem /user_ca.pem oder * -->bleibt der Status getrennt
Auch die Adressenänderung -->homeassistant.local:8123
Alles ohne Erfolg.

Noch ne` Idee ???
 
Nee, nicht wirklich. Vor dem Neustart habe ich mehrmals den Resetknopf am HT betätig und auch >5 Sekunden den Hardware Reset durchgeführt und ich habe auch die IP-Adresse in der Fritz!box gelöscht. Warum genau auf einmal die Verbindung etabliert wurde weiß ich nicht.
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
4.872
Beiträge
49.053
Mitglieder
4.533
Neuestes Mitglied
Karlmaster
Zurück
Oben