MQTT: neue Geräte und Entitäten werden von MQTT nicht übernommen

Interceptor43

New member
Hallo zusammen
Ich habe gestern eine Gosund SP111 mit Tasmota geflashed und diese mit den Einstellungen versehen die ich bei einer anderen Gosund vorgenommen habe.
Das MQTT Topic ist natürlich nicht dasselbe.
Im MQTT Explorer kann ich die Steckdose auch sehen nur in Homeassistant taucht diese nicht auf.

Gibt es aktuell Probleme mit MQTT ?

Wie gesagt im Broker, hier Mosquitto , ist das Gerät zu sehen nur die MQTT Integration aktualisiert sich nicht.

Danke im Voraus

Version Home Assistant :
1675751267035.png
 
Gibt es aktuell Probleme mit MQTT ?
Nein das liegt nicht daran...

Du hast vermutlich die aktuelle Version Tasmota verwendet, hier wurde der home assistant discover deaktiviert da man möchte das mehr und mehr die Tasmota Integration verwendet wird,
Es gibt hier zwei Möglichkeiten.
Du greifst dein discover manuell ab
Oder
Du compelierst dir Tasmota mit den gewünschten Einstellungen selbst.

Der manuelle discover schaut etwa so aus, müsstest du auf deinen natürlich anpassen.

YAML:
# mqtt
mqtt:
  sensor:
    - name: 'Haus Gas - Zählerstand'
      unique_id: haus_gaszaehler_zaehlerstand
      state_topic: "tele/haus_gaszaehler/json"
      value_template: '{{ value_json.gastotal }}'
      unit_of_measurement: 'm3'
      payload_available: "Online"
      payload_not_available: "Offline"
      device_class: gas
      state_class: total_increasing
 
Also, ich habe zwar keine Gosund Steckdose, aber eine ähnliche auch mit Tasmota, und die arbeiten derzeit in gleicher Konstellation einwandfrei über MQTT auch mit dem aktuellen HA 2023.2.2
 
Nein das liegt nicht daran...

Du hast vermutlich die aktuelle Version Tasmota verwendet, hier wurde der home assistant discover deaktiviert da man möchte das mehr und mehr die Tasmota Integration verwendet wird,
Es gibt hier zwei Möglichkeiten.
Du greifst dein discover manuell ab
Oder
Du compelierst dir Tasmota mit den gewünschten Einstellungen selbst.
Ich habe die Steckdose mit Tuya-Convert over the air geflashed, gehe also davon aus das die Version aktuell bzw die neuste Version ist.

Wäre es dann nicht sinnvoller die Tasmota Integration zu nutzen ?
SetOption19 0 ?!
Müsste ich sonst noch was tun ?!
Ich habe bisher nur mit der MQTT Integration gearbeitet.
 
Meine ganzen Tasmota Geräten hatten früher auch den Discover Modus angeschaltet. Das habe ich bei allen abgeschaltet und nutze jetzt die Tasmota Integration (Mosquitto ist natürlich trotzdem als Add-On da). Das funktioniert perfekt.
Vor allem funktioniert damit auch die Farbeinstellung der LED richtig, die vorher nur mit Mosquitto nicht so richtig wollte.
 
Na ja, deine Frage im Eröffnungspost war ob es da mit der aktuellen Version evtl. Probleme gibt.

„Gibt es aktuell Probleme mit MQTT“?

Diese Frage habe ich beantwortet.
Wenn dir das nicht weiterhilft? 🤷🏻‍♂️

Sorry für den Versuch dir helfen zu wollen.
OK da hast Du natürlich Recht.
Kein Problem mit MQTT aber halt scheinbar mit der Konfiguration.

Trotzdem danke
 
Ich erwähne ja gerne ESPHome - damit sprechen die Geräte direkt mit HA, ohne MQTT.
Ich bilde mir ein, die Config ist einfacher und man hat viel mehr möglichkeiten - yaml eben.
Die Sensoren können direkt konfiguriert werden, Icon, Name, Einheit usw.
https://forum.heimnetz.de/threads/e...nell-ueber-chrom-ium-einrichten-flashen.1313/
Alles schön und gut nur haben die von mir verwendeten Steckdosen keinen USB Anschluss.

Hört sich aber trotzdem interessant an.
 
Wie carsten_h schon schrieb, solltest du vielleicht zusätzlich die Tasmota Integration installieren, das habe ich auch.
Dann kamen die Entitäten von selbst.
 
Wie carsten_h schon schrieb, solltest du vielleicht zusätzlich die Tasmota Integration installieren, das habe ich auch.
Dann kamen die Entitäten von selbst.
Leider kamen die gestern auch nicht, hatte ich probiert.

Ich habe aber gerade gelesen das die Tasmota Integration nicht mit Tasmota Lite funktioniert welches Tuya Convert flasht.

Ergo werde ich heute Abend mal probieren Tasmota upzudaten und Versuche noch Mal die Tasmota Integration zu nutzen.
 
nicht mit Tasmota Lite funktioniert welches Tuya Convert flasht.
Hier ist auf allen Geräten das komplette Tasmota drauf.
Zur Verwaltung in Home Assistant nutze ich dann das TasmotaAdmin-Add-On. Allerdings habe ich es in letzter Zeit nicht mehr hinbekommen alle Geräte von dort aus mit einer neuen Tasmota Version zu versorgen. Es blieb nur der steinige Weg über jede einzelne Webseite.
 
Ich weiß, daß es die Lite Version gibt auch nur daher, das die mit in dem Verzeichnis der Versionen http://ota.tasmota.com/tasmota/ zum Download liegt. Ich meine auch bei Tuya Convert hätte ich gleich die normale Tasmota Version geflashed, aber das ist auch schon über zweieinhalb Jahre her.
Vielleicht wir das ja unter Information auf der Webseite angezeigt:
6C8EFD9D-009E-435B-858A-F4C78E66A5EB.jpeg
 
Bis jetzt grade wusste ich nicht mal das es ein Tasmota Lite und Full gibt.
Woran erkenne ich das?
Puh woran Du das erkennen kannst weiß ich jetzt so auch nicht, bin gerade nicht zu Hause.
Könnte sein das man das auf der Informationsseite sehen kann im Webinterface.
Ich habe einige ESP8266 mit der Basisversion geflasht, die lassen sich leider nicht mehr updaten, somit sind die gebrickt.
 
Ich weiß, daß es die Lite Version gibt auch nur daher, das die mit in dem Verzeichnis der Versionen http://ota.tasmota.com/tasmota/ zum Download liegt. Ich meine auch bei Tuya Convert hätte ich gleich die normale Tasmota Version geflashed, aber das ist auch schon über zweieinhalb Jahre her.
Ich habe das gestern das erste mal ausprobiert.
Man kann wohl das volle Image downloaden und auch nutzen, das wusste ich leider nicht.
Wird heute Abend direkt angepasst.
 
Auch nicht mit der minimal-Version in der .gz Variante? Die muß ich nämlich bei allen Geräten erst einmal installieren bevor die volle Version (auch die .gz-Datei) installiert wird.
Du meinst über das Webinterface hoch laden und dann flashen ?!
Habe ich noch nicht probiert.
Über die Flashsoftware (USB) ging es nicht mehr
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
4.872
Beiträge
49.053
Mitglieder
4.533
Neuestes Mitglied
Karlmaster
Zurück
Oben