KM200 Buderus durch ESP Box von BBQKees ersetzen / Erfahrungen zur Konfiguration

bellini

New member
Hi, hat Jemand von euch Erfahrung mit der ESP-Box https://bbqkees-electronics.nl/wiki/gateway/connecting-a-gateway-e32.html
Ich habe das in HA über die mqtt Integration zwar grundsätzlich zum Laufen bekommen - allerdings fehlt die Konfiguration der "aktiven" Sensoren, also die Sensoren, die Befehle senden. Für einige wenige Befehle wie Warmwasser aus/an habe ich Skripte geschrieben. Man könnte das aber auch irgendwie über configuration.yaml unter mqtt: konfigurieren. Die mqtt Doku, die ich bisher gefunden habe, ist relativ dürftig.... Wenn es Jemand schon umgesetzt hat, würde mir das bestimmt Zeit des Ausprobierens ersparen. Freue mich auf Feedback.
 

blurrrr

Well-known member
Dann wird das Ding wohl niemand benutzen 😁 Könntest für die Ahnungslosen natürlich noch beschreiben, wie genau da was mit was zusammenhängt, damit man erstmal ein Bild von dem Konstrukt bekommt und dann besteht zumindestens die Chance, dass "theoretische" Ansätze genannt werden.

Ich z.B. hab davon mal so gar keine Ahnung, aber wenn ich mir das in meiner naiven Art so vorstelle, würde so ein Sensor irgendwas zu dieser Box senden und diese wiederum müsste es weiterleiten an HA (oder HA greift es ab, wie auch immer). Dann würde ich das Problem in erster Instanz bei der Konfiguration dieser Box vermuten. Vielleicht erzähl ich grade auch völligen Unsinn, aber wie gesagt, das wäre so "mein" logischer erster Ansatz (ohne überhaupt zu wissen, wie die ganze Nummer funktioniert) 😇

Ist jetzt meiner Meinung nach auch kein Produkt, welches man an jeder Strassenecke bekommt, den Firmennamen z.B. habe ich noch nie zuvor gesehen, da muss man den Leuten vielleicht auch schon ein wenig mehr Infos vor die Nase halten 🙃
 

bellini

New member
Danke für die Antwort. Ich habe "das Ding" schon am Laufen, wollte mir nur Tipparbeit mit der configuration.yaml sparen... Kein Thema - ich suche in anderen Foren weiter, poste wohl eher in die Home Assistant Community. Wenn sich dann quasi "weltweit" Niemand findet, der es -- außer mir -- einsetzt, muss ich mir so langsam Gedanken machen ;-) ...
 

blurrrr

Well-known member
Na dann wünsch ich mal viel Glück! Wenn es rein um die "aktiven" Geschichten geht (wo ja wohl auch die Kommunikation andersherum läuft), gibt es ja eigentlich auch nur 4 Möglichkeiten:

- Aktor sendet nicht
- Zwischending empfängt nicht
- Zwischending sendet nicht
- HA empfängt nicht

Da ich davon leider zu wenig Ahnung habe, weiss ich auch nicht, wie man es testen könnte. HA bietet halt entsprechende Logs an, von dem Zwischending und den Aktoren hab ich halt keine Ahnung, wünsche Dir aber gutes Gelingen 🙂
 

azrael783

Active member
Das ist halt schon eine recht spezielle Lösung, daher wird es wohl nicht allzu oft verwendet. Und weltweit wirst du da auch keinen finden, da die Heizungen hauptsächlich in Deutschland und den Niederlanden verkauft werden.
Ich vermute mal, dass du das Gateway per MQTT eingebunden hast? Dann musst du einfach entsprechende Einträge dafür machen, oder das Gateway so konfigurieren, dass du die automatische Erkennung von HA nutzen kannst. Dazu muss das Gateway die Sensoren / Schalter auf einem bestimmten Topic publishen.
 

bellini

New member
Das ist halt schon eine recht spezielle Lösung, daher wird es wohl nicht allzu oft verwendet. Und weltweit wirst du da auch keinen finden, da die Heizungen hauptsächlich in Deutschland und den Niederlanden verkauft werden.
Ich vermute mal, dass du das Gateway per MQTT eingebunden hast? Dann musst du einfach entsprechende Einträge dafür machen, oder das Gateway so konfigurieren, dass du die automatische Erkennung von HA nutzen kannst. Dazu muss das Gateway die Sensoren / Schalter auf einem bestimmten Topic publishen.
yepp, das mache ich schon so (siehe Bild) - wollte mir nur die Tipparbeit im yaml für die "aktiven" Teile ersparen, falls vor mir schon Jemand was umgesetzt hätte - ist aber wohl nicht der Fall. Also muss ich selbst ran :)
bye bye..

just zur Info: Mit autodiscover werden nur die (passiven) Sensoren angezeigt.
1655144937124.png
 

bellini

New member
Liebes Forum, habe die Lösung selbst "gefunden" Falls jemand von euch mal damit was machen möchte... Ping genügt :)
 

rednag

Well-known member
Wie @azrael783 ja schon geschrieben hat - etwas speziell. Sowas haben vermutlich nicht viele Leute im Einsatz.
Das würde auch die geringe Beteiligung erklären. Aber wenn Du Deine Lösung hier mit der Community teilst, profitieren in Zukunft bestimmt neue Mitglieder davon.
 

alexamend

Active member
bellini,

Zu Kommunikation must du idealerweise einen separaten MQTT Benutzer in HA anlegen, diese Benutzer gibt's du bei den MQTT settings an und im Web Interface auf dem ESP unter MQTT die Kommunikation wenn nicht schon default steht auf homeassistant, der Host ist die IP von deinem HA system, port bleibt wie er ist, den Rest kannst du lassen wie es ist.

Nach kurzer Zeit meldet sich dein ESP im MQTT brocker, dann solltest du ähnliche Möglichkeiten zur Konfiguration finden.
Screenshot_20220718-193805_Home Assistant.jpgScreenshot_20220718-193749_Home Assistant.jpgScreenshot_20220718-193720_Home Assistant.jpg

Etwas aufwändig sind dann die ganzen friendly name zu vergeben.

Jetzt ist auch schreiben/Werte setzten auf der Heizungsanlage möglich, das sich das ESP als Service Key an der Anlage anmeldet.

Edit: Zur Info das KM200 kann weiterhin parallel betrieben werden.
 

bellini

New member
Danke! Ich hatte die Lösung schon selbst gefunden .... bin aber glücklich, dass ich offensichtlich nicht der einzige Anwender bin :)

Bei mir war das folgende Häkchen nicht gesetzt (siehe im Bild gelb). Danach funktionierte es auch mit den Steuerelementen in HA. Und mit dem neuesten ESP-EMS Uprade kann man dort bereits festlegen, welche Sensoren überhaupt per MQTT an HA gemeldet werden sollen. Super Sache - da brauchst du in HA nur eine handvoll Sensoren/Schalter und den Rest macht die Buderus Steuerung weiter automatisch.
1658226551401.png

Eine Sache noch: Wenn ich die FriendlyNames in HA ändere und danach das EMS Gatway neu starte, wird wieder alles überschrieben. Könnte am HA AutoDiscovery liegen. Ist das bei Dir auch so?
 

alexamend

Active member
bellini,
Bin aktuell geschäftlich unterwegs, werde ich testen sobald ich wieder zuhause bin.
Gebe dir dann Rückmeldung.

So hab es gerade mal remote neu gestartet...
Kurioserweise werden nicht alle friendlyname ersetzt.
Muss ich mir nochmlal genauer Anschauen an welcher Stelle ich da die Namen vergeben habe.
friendly_names.JPG
 
Zuletzt bearbeitet:

alexamend

Active member
So habe jetzt eine Lösung gefunden, in der neuen Firmware lassen sich die Namen direkt auf dem EMS-ESP einstellen
Unter Settings -> Customizing
Screenshot_20220822-212438_Samsung Internet.jpg

Dann auf den blauen Text rechts
Hier kann man den fullname bearbeiten
Screenshot_20220822-212501_Samsung Internet.jpg
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
913
Beiträge
13.421
Mitglieder
440
Neuestes Mitglied
nrnrp
Oben