FritzBox 7590 DynDNS Update URL funktioniert nicht korrekt

PeetBL

New member
Hallo zusammen,
ich habe folgendes Problem, seit dem Firmware-Update auf 7.50, mit der Update-URL.
https://www.anydns.info/update.php?user=<username>&password=<passwd>&host=<domain>&ip=<ipaddr>
werden IPv4 udn IPv6 beim Dienst Anydns eingetragen.
IPv4 und IPv6 übergeben.
Bisher wurde so nur die IPv4 an AnyDNS eingetragen.

Hat jemand einen Hinweis für mich, was da sein kann, oder wie man die von FB an den Dienst übergeben URL überprüfen kann?

Der Support von AVM konnte bisher nicht weiterhelfen. Hier die letzt Antwort:
"...vielen Dank für Ihre Geduld und Mitarbeit.

Nach Rücksprache und Auswertung Ihrer Daten können wir auf Seiten der FRITZ!Box keine Probleme erkennen.

Wenn Sie die Update-Syntax ohne IPv6 einrichten, kann die FRITZ!Box die IPv6-Adresse für Ihren Anschluss gar nicht übermittelt, da die technische Voraussetzung nicht gegeben ist."

Ich hoffen hier kann mir jemand helfen.

LG
Peet
 
Ich weiß ja nicht, wie es den anderen geht. Aber ich habe nicht verstanden, was Dein Problem ist.
 
So ganz verstanden hab ich das Problem auch nicht, aber... vllt hilft ja jener hier... ☺️

Anhang anzeigen 2750
(Quelle: https://anydns.info/faq.php)

Da ist dann die IPv6-Adresse nochmal extra aufgeführt in der Update-URL 🙃
Danke blurrrr. Ja das ist korrekt so.
Ich möchte aber nur IPv4 von der Box eintragen lassen, also den IPv6Teil weg lassen, dann wird die IPv6 nicht eingetragen. Vor OS-Version 7.50, war das auch so.
Jetzt wird die IPv6 auch eingetragen, obwohl sie nicht mit angegeben wird.

Ich hoffe dass das Problem jetzt deutlich wird.

Ich kann bei Anydns den IPv6-Eintrag nicht gebrauchen.

Gruß
Peet
 
Wenn Anydns keine Prefix Aktualisierung unterstützt (AVM ip6lanprefix), dann zeigt die IPv6 auf die Fritzbox anstatt den korrekten Host im LAN. Das stört dann vermutlich.
 
Wenn Anydns keine Prefix Aktualisierung unterstützt (AVM ip6lanprefix), dann zeigt die IPv6 auf die Fritzbox anstatt den korrekten Host im LAN. Das stört dann vermutlich.
In dem Fall muss AnyDNS aus dem Host selbst laufen, dafür haben die auch Windows, MAC und Linux "Clients" um den AnyDNS-Namen upzudaten.

Bessere wäre es IPv4 abzuschalten. Ende.
 
Wenn sich das nicht wie gewünscht verhält, würde ich einfach mal ein Support-Ticket bei AVM eröffnen: AVM-Support
Der Support von AVM konnte bisher nicht weiterhelfen. Hier die letzt Antwort:
"...vielen Dank für Ihre Geduld und Mitarbeit.

Nach Rücksprache und Auswertung Ihrer Daten können wir auf Seiten der FRITZ!Box keine Probleme erkennen.

Wenn Sie die Update-Syntax ohne IPv6 einrichten, kann die FRITZ!Box die IPv6-Adresse für Ihren Anschluss gar nicht übermittelt, da die technische Voraussetzung nicht gegeben ist."
 
Bessere wäre es IPv4 abzuschalten. Ende.
Ich benötige aber IPv4. Vor dem Update war das Problemlos möglich.

Ich habe noch Zugriff auf eine weitere FB7590 mit der gleichen Firmware 7.50. Dort verhält es sich genau so!!

Vielleicht kann das jemand einmal nachstellen mit alter und neuer Firmware?
 
Hast du mal bei Anydns nachgefragt?
Vielleicht setzen die auch ungefragt die IPv6 des angfragenden Gerätes (Fritzbox IPv6).
 
Und? Gibt es eine Lösung?
Habe leider das gleiche Problem. Portforwarding nicht möglich.
Interner Zugriff: Hat die Box bie Port 443 auf die Fritzbox-Seite umgelenkt. Ok - das scheint bekannt zu sein. Aber von extern hat es das auch zuerste gemacht. Nach Neustart der Fritzbox und auch Port geändert auf 451, geht der Zugriff über 451 aber leider auch nicht.
Aktuelle öffentlich IP mit Port 451 funktioniert. Aber per DynDns Hostnamen geht es nicht - seit OS 7.50.
 
@Positiv79

Das hab ich irgendwie sogar nicht verstanden was du meinst.

Ich versteh auch nicht wirklich warum der Fehler in der FB liegen soll. Selbst wenn Sie an AnyDNS die IPv6 mitgibt sollte es AnyDNS ignorieren da nur IPv4 eingestellt ist. Ich würde sogar soweit gehen und sagen das FB egal ist ob in dem Link IPv4 oder IPv6 steht sie schickt an den Link einfach beides. Das es vor dem Update geklappt hat wird daran liegen das vermutlich in der vorversion IPv6 deaktiviert war was mit der neuen Version per Default Aktiviert ist und nach Update auch angeschlagen wurde.

Bei dem Problem was du daraus ableitest warum du kein IPv6 haben möchtest würde ich als erstes einmal überprüfen ob bei der Portfreigabe diese auch für IPv6 eingerichtet wurde.

Alternativ kannst du IPv6 auch in der FB deaktivieren was dir auf lange Sicht aber nicht viel bringen wird.
 
@Spielebernd
Du hast vollkommen Recht. Und tatsächlich war es die fehlende ip6 Anweisung im Link.
War erst mal nicht einleuchtend für mich, weil es mit einer anderen Fritzbox woanders genau in der Form nicht funktioniert. Aber gut, jetzt geht wieder alles und ich bin glücklich.
Danke.
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
4.808
Beiträge
48.676
Mitglieder
4.464
Neuestes Mitglied
Hoschy
Zurück
Oben