Falsche Werte Riemann Summenintegralsensor für korrigiert Verlauf/Graf bleibt unverändert

claudeju

New member
Guten Abend zusammen,

ich noch ziemlich neu in der Materie Home Assistant und bin auf folgendes Problem gestoßen.

Ich habe einen Helfer Riemann Summenintegralsensor erstellt dieser zählt die Watt/h meiner Klimaanlage
Nach Neustart meines Raspberry schlich sich auf einmal ein hoher wert von irgendwie um 10000000 Watt/h ein. ich habe diesen über Entwicklerwerkzeuge und Statistik korrigiert.
Die Werte im Energy Dashboard waren danach sofort richtig.
Im Verlauf/Graf blieb allerdings der falsche Wert bestehen.
Wie könnte ich den hohen Wert hier entfernen?

Bildschirm­foto 2023-02-04 um 16.59.50.png
 
Moin! Dafür musst Du wohl oder übel einmal kurz an die Datenbank ran.

Wie immer, vorher: Backup ziehen - die Datei /config/home-assistant_v2.db lokal wegspeichern.

Dann einmal unter den Addons SQLite Web installieren, die Oberfläche davon öffnen, links die Tabelle "states" auswählen, oben den Reiter "Query" anklicken, dies (mit angepasstem Sensornamen natürlich) eintragen:
SQL:
SELECT * FROM states WHERE entity_id LIKE 'sensor.meinname' AND state NOT LIKE 'unknown';
und "Execute" klicken.

Edit - wenn Deine Liste sehr lang ist, pass die Query noch auf das Datum des falschen Eintrages an:

SQL:
SELECT * FROM states WHERE entity_id LIKE 'sensor.meinname' AND state NOT LIKE 'unknown' AND last_updated LIKE '2023-02-05%';

Bei Dir dürfte die Ergebnisliste etwas länger sein, bei mir sieht das dann so aus mit einem absichtlich fehlerhaft erhöhtem Wert:
1675574282869.png
- jetzt alle Zeilen raussuchen die bei "state" etwas stehen haben, was sie nicht stehen haben sollten, von diesen die state_id notieren (eventuell ist das auch bei Dir nur eine einzige Zeile, das musst Du selber rausfinden).

Jetzt diese Query an Deine Bedürfnisse anpassen:
SQL:
UPDATE states SET state = '0.9' WHERE state_id = 833607;
- als "state" eben einen Wert eintragen der realistisch wäre, state_id natürlich durch den zuvor notierten Wert ersetzen, sollte es mehrere Zeilen betreffen einfach eine nach der anderen bearbeiten.

Nochmal schauen dass die Werte auch wirklich richtig sind, wieder auf "Execute" drücken, das sollte dann ungefähr so aussehen:
1675574572305.png
eine Reihe wurde bearbeitet, genau so sollte das sein.

Wenn alle fehlerhaften Einträge auf diese Art bearbeitet wurden wars das auch schon, dann sind die hohen Werte auch in den Grafen verschwunden.
 
Vielen Dank für deine Antwort.

Ich bin wie beschrieben vorgegangen, bei dem Helfer für die Klimaanlage finde ich überhaupt keinen Falschen Wert.
Habe dann mal bei dem Sensor vom TV geguckt wo der selbe Fehler auftrat dort sieht es so aus:
Bildschirm­foto 2023-02-05 um 18.22.28.png

Die Werte im Energie Dashboard sind alle korrekt.
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
4.673
Beiträge
47.691
Mitglieder
4.318
Neuestes Mitglied
brockau
Zurück
Oben