E-Auto Mess-Automation

Wolfgang H

New member
Hallo zusammen,

mein Thema: Ich habe meine Steckdose am E-Auto mit einem Shelly Plus 1PM via HomeAssistant managebar gemacht.

Mein E-Auto kann leider nur bis 100% aufladen. Ein kleinerer Wert (z.B. 80 %) lässt sich nicht einstellen, wäre aber aus mehreren Gründen sinnvoll.

Ich habe nun die Ladekurve (Leistung, W) mal gemessen und ich glaube, einen Triggerpunkt gefunden zu haben: Es sind zwei signifikante Peak in den Messwerten innerhalb eines bestimmten Zeitintervalls.

Nun die Frage: Wie könnte ich eine Automation bauen, die das Auftreten bestimmter Sensorwerte innerhalb eines bestimmten Zeitrahmens als Trigger für eine Automation (nämlich das Abschalten der Steckdose) verwendet. Ich habe schon einige Automationen am Laufen, aber das mit dem Zeitintervall will mir einfach nicht gelingen und im Netz (auch in diesem Forum hier) habe ich nichts gefunden. Das mag daran liegen, dass das Thema auch nicht mit drei Schlagworten beschrieben werden kann :)

Danke für jeden Hinweis !

Gruß

Wolfgang
 
Hallo und willkommen! :)

Ich habe meine Steckdose am E-Auto mit einem Shelly Plus 1PM via HomeAssistant managebar gemacht
Woher soll der Shelly denn wissen, wie der Ladestand Deines Autos ist? :unsure:

Hast Du Dein Auto ggf. auch in HA integriert, so dass HA den Ladestand des Autos erkennen könnte? Ich habe zwar mit HA eher weniger an der Mütze, weiss aber, dass es einige Integration für div. KFZ-Hersteller gibt - falls Du da etwas entsprechendes integriert hast, wäre es von Vorteil, wenn Du noch sagen könntest, um welche Integration es sich dabei handelt. Andernfalls dürfte es wohl eher schwierig werden, an entsprechende Ladezustandswerte zu kommen, auf welche man ja theoretisch reagieren müsste... 🙃
 
Hallo blurr,

es ist nur die Shelly Integration und die liefert z.B. die Leistung in Watt. Eine Fahrzeug Integration gibt es wohl nicht wirklich (Fiat 500E).
Ich messe mit dem 1PM die Leistung in Watt und ich habe ein signifikantes Muster in der Leistungskurve gefunden, das passen könnte: Zwei signifikante Leistungswerte in einem bestimmten Zeitintervall. Das könnte mir die 80% Abschaltung simulieren. Aber ich weiss eben nicht, wie ich die Automation in HA schreibe.

Gruss

Wolfgang
 
Die Steckdose sollte ja theoretisch die aktuelle Belastung wiedergeben können, so dass man sagen könnte, dass wenn die Belastung unter einen bestimmten Wert fällt, der Strom einfach abgeschaltet wird. Das wäre jetzt so ganz laienhaft gesprochen.

Alternativ schau Dir mal die folgenden Dinge an:

1) EVCC (da steht auch Fiat mit in der Liste)
2) Thread (da hat es jemand mit Fiat gelöst, aber wohl auf einem etwas anderem Wege)
3) HomeAssistant-Addon für EVCC

Ersteres mal anschauen, den Thread lesen und dann hast Du vermutlich schon einen groben Eindruck davon, wie Du Dein Auto auch in HomeAssistant (halbwegs vernünftig) integrieren kannst. Wie Du es schlussendlich machst, bleibt natürlich Dir überlassen, aber dem Screenshot im Thread nach, scheint sich da ja einiges auslesen zu lassen (inkl. Akku-Stand), was die Sache natürlich deutlich komfortabler machen würde.

Allerdings... hab ich davon wie gesagt keine Ahnung, von daher ist das jetzt mal nur eine kleine Info am Rande, aber vllt meldet sich ja noch wer zu Wort mit etwas mehr Ahnung 😇

EDIT: Bin grade noch über https://my500e.com/connect-de/gestolpert und hier https://my500e.com/communityapps/ steht ganz unten was von einem HomeAssistant-Dashboard (könnte ggf. als Vorlage dienen, keine Ahnung), allerdings steht auch beim zweiten Link ganz unten dabei "my500e CONNECT only works with the 2013-2018 Fiat 500e (US-Version)!", scheint also vermutlich weniger eine Option zu sein... 😕
 
Hmm, wenn ich er wäre würde ich von solchen Spielereien die Finger lassen.
Wenn etwas mit dem Akku kaputt geht und FIAT die Ladedaten ausliest und feststellt, dass da extern manipuliert wurde, war es das mit der Garantie, dann wirds teuer.
Ich weiss, wovon ich rede...
 
Moinsen,
aus dem Bauch sehe ich das wie @UdoAA...
Da würde ich dann persönlich eher mal nach guten Ladestationen suchen, die sich ggf. so programmieren lassen, dass ab 80% runtergefahren wird (integriert).
Alternativ: viele der e-brummbrumms haben heute doch sogar ne App (hihihi), die oft auch den Ladestand anzeigen kann...da dann ggf. mehr Optionen?
 
Ja, wenn es eine Ladestation gibt, die das offiziell unterstützt und ggf. von FIAT zertifiziert ist (falls es bei denen sowas gibt), ist das o.k.
Wieso willst du den Akku überhaupt nur auf 80% laden? Wenn das wegen der vielen Berichte ist, das man das bei Akkus (Smartphone?) man besten wegen der Lebendauer so macht, dann muß das bei dem 500E nicht unbedingt so sein.
FIAT wird den Akku und die Ladeelektronik im Entwicklungsprozeß auf diverse Parameter hin optimiert haben und dazu gehört bei dir dann auch die 100% Ladung. Weiterhin wurde der Akku vor dem initialen Einbau während der Produktion auf diese Parameter hin konditioniert und bringt damit die Beste Leistung und Lebensdauer.
Wenn Du das jetzt overrulest kannst Du im schlechsten Fall auch die Leistung der Batterie negativ beeinflussen, von dem Verlust der Gewährleistung mal abgesehen.
Noch ein Rat: Bringe das Wägelchen die ersten Jahre am Besten in eine FIAT-Vertragswerkstatt, auch wenn es Teurer ist. Die Techniker vor Ort haben ganz andere Möglichkeiten, das Auto zu prüfen als derzeit noch die freien Werkstätten und spielen evtl. noch Software-Updates für die diversen Steuergeräte auf, die Fehler beseitigen (auch wenn du davon nicht merkst) oder die Lebensdauer und Zuverlässigkeit verbessern, das können die freien Werkstätten meistens nicht.
Du hast relativ viel Geld für ein neues hochmodernes Auto ausgegeben, dann pflege es auch gut.
Die Zeiten, wo man an seinem Auto noch alles selbst machen konnte, sind mit den E-Autos definitiv vorbei.

Ist aber nur meine Meinung.

Grüße aus Köln!
 
Danke für Eure Infos. Die Tipps mit den Apps sind ok und das wäre auch meine erste Wahl gewesen. Der Haken ist nur: Der 500E kommuniziert ausschließlich via Mobilfunk und da ist in meiner Tiefgarage leider tote Hose. Er hat auch WLAN und das ist auch konfiguriert, nur kommuniziert das Auto halt darüber nicht. Insofern habe ich nur die Daten der intelligenten Steckdose und muss über die Messdaten dahin kommen, wo ich will. Ja, der Hintergrund der 80% sind allgemeine Ladeempfehlungen für Autoakkus. Außerdem ist es für einen Schwaben extrem ärgerlich, zum Kaufland zum Einkaufen zu fahren, dort doch tatsächlich einen kostenfreien Ladeplatz zu finden und dann nicht laden zu können, weil das Auto ja schon voll ist :) Ein weiterer Grund für <100% könnte eine eingeschränkte Rekuperation sein. Allerdings konnte ich das noch nie beobachten.
Bzgl. Garantie sehe ich keine Probleme: Würde es so funktionieren, wie ich mir das wünsche, wäre das schlicht ein abgebrochener Ladevorgang - eine normale Sache.

Gruß

Wolfgang
 
Kenne jetzt den Fiat 500E nicht, aber die Ladeelektronik diverser Akkus. Viele Hersteller zeigen die zwar 0% bis 100% an, die Elektronik lädt den Akku aber in Wirklichkeit nur z.b. zwischen 15-85% eben weil sie schon auf die Optimierung der Akku Lebensdauer ausgelegt ist.
Nur anzeigen will man dem Kunden das nicht.
Wenn du jetzt bei 80% stoppst hätte er in Wirklichkeit dann eventuell nur 70%. Also eventuell "verschenkte" Reichweite.
Aber wie gesagt weiß ich nicht aus dem Stand wie das der Fiat macht.

Bezüglich HA vielleicht wie hier mit Waschmaschine
https://community.home-assistant.io/t/automation-with-shelly-not-working-washing-machine/230189
 
Ja, das mit den 85% habe ich auch schon gehört. Dafür spricht, dass die Rekuperation auch bei 100% funktioniert, was eigentlich nicht geht und auch in der Betriebsanleitung so beschrieben ist. Was bleibt ist allerdings, dass er mehr wie 100% (wieviel das real auch immer ist) nicht lädt.
Zur Waschmaschine: Ja genau in der Art. So eine Automation habe ich übrigens auch schon erfolgreich am Laufen. Der Unterschied hier ist nur die Zeitspanne zwischen zwei Messungen (Peaks, signifikant), die hier wichtig ist und ich weiss nicht, wie ich die in die Automation bekomme. Aber trotzdem Danke für den Hinweis, denn in dem Forum mit der Waschmaschine bin ich vielleicht mit dieser speziellen Frage richtig. Probiere ich mal.

Gruß

Wolfgang
 
@Wolfgang H
Bei unserem Auto kann man anhand des Ladestandes einschätzen, wieviele kWh es braucht, um auf die 80% zu kommen.
Ich habe einen input.boolean für "Voll laden" und drei input.number Helfer.
Einer merkt sich den Zählerstand beim Ladestart, der zweite die bereits geladene Energiemenge und mit dem dritten wird eingestellt, wieviel kWh geladen werden sollen.
Ist der gewünschte Wert überschritten oder der Ladestrom unter 200W, wird der Shelly abgeschaltet und eine XMPP Nachricht verschickt.
 
@u5zzug: Ja klar, das ist natürlich eine alternative Methode, falls das von mir nicht funktioniert. Ich bin immer noch am Testen und ganz 100% ist es noch nicht. Frage an Dich: Du hast auch einen Shelly Plus 1PM im Einsatz und das an Deinem Auto ? Falls ja, hätte ich da eine Anschlussfrage bzgl. Device-Temperatur. Das ist für mich nämlich die nächste Baustelle.
 
Einen 1PM ohne Plus. Vermutlich könnte man die 80% auch irgendwie rausfinden, habe das noch nicht tiefgehend beobachtet. Bei 80% balanciert er die Zellen, da geht die Leistung runter. Von daher muss man auch hin und wieder voll laden.

Ich würde mir die diversen Helferaggregatfunktionen anschauen, ob man da irgendwo einen eindeutigen Punkt findet. Durchschnitt oder min/max über eine bestimmte Zeit, da gibt es ja einige..
 
Zuletzt bearbeitet:
Einen 1PM ohne Plus. Vermutlich könnte man die 80% auch irgendwie rausfinden, habe das noch nicht tiefgehend beobachtet. Bei 80% balanciert er die Zellen, da geht die Leistung runter. Von daher muss man auch hin und wieder voll laden.

Ich würde mir die diversen Helferaggregatfunktionen anschauen, ob man da irgendwo einen eindeutigen Punkt findet. Durchschnitt oder min/max über eine bestimmte Zeit, da gibt es ja einige..
Vielleicht hier mal ein paar Details:
Ich habe mehrere Messungen durchgeführt und glaube herausgefunden zu haben, dass der Lader um die 80% herum zwei "Glitches" produziert.
Bildschirmfoto 2022-08-16 um 13.07.12.png
Diese zwei Glitches (roter Kringel) sind <2000 W und innerhalb eines bestimmten, kurzen Zeitintervalls. Die Messung in HA ist recht tricky, aber mit Hilfe des HA-Forums konnte ich eine Automation erzeugen, die darauf triggern kann (der rote Bereich ist der eigentliche Gag mit dem Zeitintervall):

Code:
alias: eAuto Abschaltung 80%
description: ""
trigger:
  - type: power
    platform: device
    device_id: b06ea1947938fc0905301d2596f73ca2
    entity_id: sensor.shellyplus1pm_3c610579b164_switch_0_power
    domain: sensor
    below: 2000
condition: []
action:
  - wait_for_trigger:
      - platform: numeric_state
        entity_id: sensor.shellyplus1pm_3c610579b164_switch_0_power
        below: "2000"
    timeout:
      minutes: 15
    continue_on_timeout: false
  - type: turn_off
    device_id: b06ea1947938fc0905301d2596f73ca2
    entity_id: switch.shellyplus1pm_3c610579b164_switch_0
    domain: switch
  - service: notify.mobile_app_iphone_5
    data:
      message: EAuto Doppelpeak
mode: single

Ich brauche aber noch ein paar Ladevorgänge um herauszufinden, ob diese Glitches immer bei ca. 80% passieren oder zufällig. Dann wäre ich natürlich lost und das Ganze würde nicht sicher funktionieren. Wir werden sehen.

Ein Problem bei der Energiemessung hatte ich übrigens auch, weswegen ich vom Shelly-Support eine Beta-Firmware bekommen habe, bei der die Energiemessung dann passt. Die lag immerhin krasse 25% daneben. Stimmt die bei Dir ? Einfach mal händisch mit dem Ladestrom und Zeit nachrechnen und mit der gemessenen Energiemenge vergleichen. Ist bei mir recht einfach, weil der Ladestrom über Stunden quasi konstant ist.

Nun zum Temperaturproblem: Mein 1PM Plus macht schon im Leerlauf eine Temperatur von ca. 50 Grad. Beim Ladevorgang geht das auf sagenhafte 95 Grad hoch. Der Shelly-Support hat mir bestätigt, dass das auch die Cutoff Temperatur ist, wo sich das Ding selbst abschaltet. Passiert ist das jetzt nicht, aber es war wohl kurz davor. Der Shelly-Support ist ratlos und rät zum EM plus Schütz, was ich Wahnsinn finde. Vor allem: Der Shelly hat ein Relais, dass man auch hören kann. Warum also sollte die angeschlossene Last einen derart großen Einfluss auf die Device-Temperature haben ? Vor allem sinkt die Temperatur nach 2-3 Stunde quasi schlagartig um 30 Grad, obwohl die Ladeleistung noch Stunden weitergeht. Ich weiss nicht, ob Du bei Deinem mal auf die Temperatur geschaut hast. Würde mich mal interessieren. Kann sein, dass die Temperatur eine versteckte Entität ist - die müsstest Du dann erst aktivieren. Auch die 50 Grad im Leerlauf finde ich schon nicht wenig, vor allem weil diese Temperatur ja auch mit einem Lerrlaufstrom erzeugt wird ..

Gruss

Wolfgang
 
Zuletzt bearbeitet von einem Moderator:
Die Messung stimmt so ungefähr, da war erst noch ein Zähler dazwischen.
Temperatur habe ich normalerweise aus, ist jetzt bei 30 Grad. Ich glaube, heute muss geladen werden, mal gucken.
Messkorrektur kann man auch im Shelly was einstellen.
 
Der hat mir die Temp. in ein Attribut geschrieben, wenn ich hingeguckt habe, war sie bei 73, 74 beim Laden mit ca. 2000W.
 
Mal ungeachtet der Tatsache, das du mit deinem Shelly an der Leistungsgrenze bist !!!
Benötigst du zur Auswertung mehr Informationen von deinem Auto, hierfür würde (Ich) mir einen OBD2-Wlan "vorausgesetzt dein Wlan deckt den bereich deines Auto mit ab" besorgen, damit diesen lassen sich dann Ladezustand, Batterietemperatur, und Spannung auslesen, (zusätzlich noch weitere Parameter deines Auto) somit hast du definierte Trigger die deine Abschaltung beauftragen.
 
Mal ungeachtet der Tatsache, das du mit deinem Shelly an der Leistungsgrenze bist !!!
Warum das ? Die Ladeleistung liegt bei ca. 2.300 W, also 10A Strom. Spezifiziert ist der doch aber bis 16 A. Insofern ...
Hier noch die Temperaturkurve von der Ladung gestern:Bildschirmfoto 2022-08-18 um 15.50.54.png
Der Wahnsinn ist eben, das die Temperatur nicht proportional mit dem Ladestrom ist. Was bringt das Teil für rund 1h auf 95 Grad und damit an den Rand der Abschaltung. Was passiert dann, obwohl die Ladung mit weiterhin 2,3 kW noch Stunden weitergeht, dass die Temperatur ziemlich flott auf 70 Grad sinkt, was ok ist. Ich kapiers nicht ...
 

Zurzeit aktive Besucher

Keine Mitglieder online.

Neueste Beiträge

Letzte Anleitungen

Statistik des Forums

Themen
4.240
Beiträge
44.131
Mitglieder
3.840
Neuestes Mitglied
karflyer
Zurück
Oben