[ARTIKEL] QTS Migration auf neue Geräte - Fluch oder Segen?

tiermutter

Well-known member
[PROLOG]
QNAP bietet die komfortable Möglichkeit sein System von einem alten Gerät auf ein neues Gerät zu migrieren, sofern die Geräte dafür kompatibel sind: Datenträger im neuen Gerät einbauen, einschalten und fertig. So ungefähr jedenfalls.
Nicht selten habe ich in diversen Forenthreads davon abgeraten eine Migration durchzuführen und empfohlen das NAS neu zu initialisieren, sofern keine zeitlichen Aspekte dagegen sprechen.
Warum ich das empfehle? Tja, dazu habe ich mich noch nie geäußert, sondern immer nur die Behauptung in den Raum geworfen dass eine Migration Probleme verursachen kann, für viele sicherlich unverständlich, denn meist geht dabei nichts schief und die Systeme laufen anschließend vermeintlich stabil und problemlos.
Beweise für meine These sind natürlich so eine Sache, kurzum: Beweisen kann ich gar nichts. Ich kann euch aber meine Erfahrung mit der Migration schildern und aufzeigen, weshalb ich bedenken habe.

[DAS NAS MIT MIGRATIONSHINTERGRUND]
Es ist schon ein paar Tage her, da hatte ich ein TS-459pro II daheim stehen. Nicht mein erstes QNAP NAS, aber die Reise der Migration beginnt erst hier. Das System lief viele Jahre super zuverlässig und solide. Für viele kaum vorstellbar, aber ich rede wirklich davon, dass es keinerlei Fehlfunktionen in Hard- oder Software gab. Naja bis zum Tag X jedenfalls, da war das NAS plötzlich aus und ließ sich auch nicht wieder einschalten. Bis heute glaube ich, dass das interne Netzteil ein Problem hatte, und wie man mit diesem Fehlerbild umgeht ist doch klar: Ein paar Stunden spannungsfrei ruhen lassen und danach ist wieder alles schick. So war es auch. Ich will nicht von Jahren reden, aber danach hatte ich das NAS noch etliche Monate im Einsatz, der Gedanke an ein aktuelleres NAS war durch den einmaligen Ausfall aber bereits geboren.
So flatterte mir irgendwann ein TS-453A ins Haus, auf das ich sehr vorbildlich gemäß Vorgaben migriert habe. Das Ergebnis: Alles wundervoll und schick, weiterhin Null Probleme. Naja bis HBS3 gekommen ist, aber das ist wirklich ein anderes Thema. Auch das Gerät war einige Zeit im Einsatz, zwischendurch habe ich mich noch aufgerafft und mich daran gemacht das Legacy Volume los zu werden. Volume gelöscht, Pool und Volumes nach Bedarf erstellt, fertig.
Wie der Zufall es wollte [1], fand nach nichtmal 2 Jahren aber schon ein TVS-473 Einzug in meinem Rack. Auch hier wurde ganz anständig migriert, am Ergebnis gab es zunächst nichts zu meckern, jedenfalls gab es augenscheinlich keine Probleme.

[VERBORGENE MISSSTÄNDE]
Zumindest sah es einige Zeit so aus, als gäbe es keine Probleme, bis ich mich dem Thema „HDD Standby“ widmen musste, mit dem ich bislang keine Probleme hatte [2]. Die HDD wollten von Beginn an partout nicht schlafen gehen, sodass ich über den Helpdesk den Standby Test durchführen wollte. Bei dem „wollte“ ist es aber auch geblieben, denn in dem entsprechenden Menu konnte ich keine Auswahl des Gehäuses (NAS Host) treffen um den Test zu starten. Selbstredend habe ich das erstmal auf ein Fehler in QTS geschoben und ein Ticket erstellt. Ebenfalls selbstredend war die Antwort vom Support, dass das im Zusammenhang mit dem von mir installierten RAM steht, da ich schließlich auch etliche Segfaults (https://de.wikipedia.org/wiki/Schutzverletzung) im Dumplog habe. „Ja klar, aber kannste haben!“.
Der Umbau des RAM auf das Original schaffte keine Abhilfe, der Standby-Test funktionierte weiterhin nicht und auch die Segfaults haben nicht abgenommen. „Tja Mister Support, und nun?“.
Die Empfehlung des Supports war es das NAS neu zu initialisieren, wenn nicht der RAM der Übeltäter ist, dann ist irgendwas am System nicht sauber. Klingt einleuchtend. Ich habe das Ticket geschlossen, weil es mir zu blöd war neu zu initalisieren, nur um den Standby Test durchführen zu können, so wichtig war mir der HDD Standby dann auch nicht.
Die Segfaults allerdings haben mir keine Ruhe gelassen, auch wenn ich keine spürbaren Auswirkungen feststellen konnte, niemand mag Segfaults in seinem System haben, wer weiß was dadurch noch für Probleme zustande kommen oder bereits unbemerkt exisiteren. Ziemlich blöd, was ich nun plötzlich so für Probleme hatte, von denen ich gar nichts wusste.
Nachdem ich auch die RAM Slots als Verursacher ausgeschlossen habe, habe ich mal schnell das System auf einem anderen Datenträger aufgesetzt und mir einen taglang angeschaut: HDD-Standby funktioniert, na gut, läuft ja nicht viel drauf. Der Standby Test funktionierte nun ebenfalls wie vorgesehen und auch von Segfaults war keine Spur.
Scheint also keinen Ausweg zu geben, neu initialisieren ist angesagt. Samt RAID Rebuild hat das alles ein bisschen Zeit beansprucht, als das durch war die Erkenntnis:
Keine Segfaults und der Standby Test Button funktioniert auch. Herrlich, System gerettet (bisschen komisch von Rettung zu sprechen wenn man sich nichtmal in Not gesehen hat)! Entsprechend habe ich im Anschluss die zuvor gesicherte Konfiguration wiederhergestellt und alle weiteren Einstellungen vorgenommen.
Es hat gar nicht lange gedauert, das System war längst nicht vollständig betriebsbereit, da stehe ich plötzlich wieder vor denselben Problemen wie zuvor. Eindeutiger Zusammenhang: Die Konfig!
Mit diesem Wissen dachte ich mir, dass ich mir ein erneutes Initialisieren sparen kann, es muss ausreichen die Konfig zurückzusetzen damit die Probleme ein Ende nehmen. Wie das ausgegangen kann sich jetzt sicherlich jeder denken: Gar nichts hat sich durch den Reset auf Werkseinstellungen geändert! Irgendwas aus der offensichtlich durch (mehrfache) Migration verkorkste Konfig baut hier richtigen Mist im System ein, der so einfach nicht ausgebessert werden kann.
Eine weitere Initialisierung, ein weiteres Rebuild und ein komplettes Neueinrichten des System später gab es dann endlich die Erleichterung: Segfaults weg, Standby Test funktionsfähig. Der HDD Standby war mir in diesem Moment egal und interessierte mich fortan auch nicht mehr.

[TRIVIA]
[1] „Zufall“ nenne ich das eigentlich nur um mich besser zu fühlen… ich bin auch kein Rockefeller der sich ständig neue Geräte leisten kann. Ich kaufe meine Geräte (meistens) gebraucht, weil ich geizig und umweltbewusst bin, wobei ich „umweltbewusst“ wiederum nur anfüge damit ich nicht in allzu schlechtem Licht dastehe 😉. Na sagen wir es doch lieber anders: Ich bin glücklich wenn ich spare, und damit bin ich bislang immer gut gefahren.
[2] Ja auch ich habe meine HDD einst gerne schlafen gesehen, wenn sie nichts zu tun hatten. Dass ich darüber mittlerweile anders denke liegt unter anderem auch daran, dass es immer schwerer geworden ist die HDDs zum Schlafen zu bekommen und der Standby nicht unbedingt besser für die HDD ist.


[EPILOG]
Wie man sieht, sieht man viele Worte die lediglich meine Beaobachtungen schildern. Kein Beweis dafür woher die Fehlfunktion des NAS tatsächlich kam. Nur Vermutungen. Es besteht kein Zweifel daran, dass die Probleme mit der eingespielten Konfiguration im Zusammenhang stehen. Ein Zusammenhang mit einer Konfiguration, die wie das System (mehrfach) migriert wurde. Es besteht auch kein Zweifel daran, dass ich den ganzen Zauber hätte umgehen können, wenn ich beim Wechsel des NAS gleich neu initialisiert und die Konfiguration komplett neu vorgenommen hätte. Die Zeit erlaubt einem das unter Umständen jedoch nicht, sodass die Möglichkeit der Migration weiterhin eine tolle Möglichkeit ist, die oft funktioniert, aber auch zu Problemen führen kann, die einem erst spät oder gar niemals auffallen.

Ein System das Segfaults am laufenden Band produziert klingt erstmal nicht wild, so lange doch alle Funktionen gegeben sind und man keine spürbaren Einbußen hat. Das bedeutet aber auch, dass ständig Logs geschrieben werden müssen, und wer hätte es geahnt: Dann gehen die HDD auch nicht schlafen. Wenn jemand mit dem HDD Standby Problem um die Ecke kommt folgen meist etliche Fragen wie „Welche Dienste laufen?“, „Ist ein Firmwareupdate erfolgt?“, … Die Frage ob das NAS migriert wurde oder ob das Dumplog mit Fehlern oder anderen ständigen Einträgen gefüllt ist, ist dabei noch nie aufgekommen, hätte aber durchaus seine Berechtigung, und wer weiß welche Fehlerbilder sich sonst noch durch eine Migration ergeben können, die auf den ersten Blick erfolgreich und ohne negative Folgen verlief?!
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
969
Beiträge
14.049
Mitglieder
500
Neuestes Mitglied
McKay1408
Oben