Zwei HA in einem Netz, oder eine "Verlängerung über eine Raspi" bauen?

remmiz

New member
Moin zusammen,
ich bin erst seit kurzen mit HA am probieren und bin dabei aber quasi schon an das erste größere Problem gestoßen.
Aktuell habe ich HA auf einen Raspi installiert. Lag rum und schien mir am einfachsten. Wenn ich jetzt allerdings sehe was da so schon installiert ist und wie es eventuell noch weitergehen kann, dann würde ich HA lieber als Docker oder VM auf meiner NAS betreiben. Allerdings ist da wieder das Problem, die steht im Keller und wie komme ich dann per Zigbee und BT an die Sensoren usw. ran ...
Jetzt wäre eine Idee 2x HA im Netzwerk zu betrieben, einmal als Docker und als Raspi. Allerdings finden die sich gegenseitig nicht. Habe ich versucht, aber nicht hinbekommen.
Andere Idee, HA auf einem Docker, Conbee2 und BT auf einem Raspi. Conbee könnte ja noch funktionieren, mit einem Image von Phoscon. Aber wie bekäme ich die BT Sensoren über einen Raspi an HA in einem Docker angebunden ... Habe hier im Forum gesucht und Google bemüht. Allerdings nicht so fündig geworden, wie man sowas baut.

Ich kann mir aber nicht verstellen, dass nur ich sowas benötige? Hat Jemand von Euch einen Tipp?

Viele Grüße und schon einmal besten Dank
Gruß
Björn
 

blurrrr

Well-known member
Wenn ich jetzt allerdings sehe was da so schon installiert ist und wie es eventuell noch weitergehen kann, dann würde ich HA lieber als Docker oder VM auf meiner NAS betreiben.
Hi,

inwiefern ist das jetzt ein Problem? So ein Raspi verkraftet erstmal eine ganze Menge, statt der SD-Card kann man auch einfach eine kleine SSD nutzen. Wenn ggf. noch Grafana+InfluxDB ins Spiel kommen, könntest Du den Part ggf. auch auf eine VM auf dem NAS auslagern.

Btw.... wenn es wirklich in Richtung von 2 einzelnen HA-Installationen gehen soll, wäre vllt jenes hier garnicht so uninteressant: https://github.com/custom-components/remote_homeassistant :)
 

azrael783

Active member
Ich würde Home-Assistant nicht zweimal betreiben. Ich hatte Home-Assistant anfangs auch auf meinem NAS laufen, hab mich dann aber für einen Pi entschieden. Aus dem einfachen Grund, dass Updates auf dem NAS durchaus mehrere Minuten dauern und Home-Assistant dann nicht verfügbar ist.
Wenn du es wirklich auf dem NAS betreiben willst, würde ich den Pi für Deconz und evtl auch den BT Kram verwenden. Ich habe aber keine Ahnung wie du die BT Sachen einbinden kannst.
Die andere Möglichkeit wäre Home-Assistant auf dem Pi laufen zu lassen und lediglich die Datenbank von Home-Assistant aufs NAS verlagern. Das mache ich auch so - auch wenn Home-Assistant bei mir nicht mehr auf einem Pi läuft. Das schont die SD-Karte / SSD um einiges, setzt allerdings voraus, dass das NAS 24/7 läuft.
 

remmiz

New member
Das NAS läuft 24/7 ... wäre daher kein Thema etwas dorthin auszulagern. Wäre mir ja eben ganz recht!
Ich habe halt Sorge wegen der SD Card in dem Raspi. Die fliegen mir immer so alle 1/2 Jahr um die Ohren. Das wäre dann ja schade um die Datenbanken. Ich habe Influx mit Grafana eingerichtet ... Statistik ist ja das halbe Leben :cool:
Wenn jetzt noch Einiges an Automatisierung kommt, dann wäre der Aufwand für die Wiederherstellung ja enorm. Backup scheint ja nicht so automatisch irgendwo gemacht zu werden. Wenn das automatisch per CIFS oder was auch immer zum NAS gehen würde, wäre ich beruhigter. Habe aber da jetzt in der Einstellungen noch nichts gesehen, aber auch noch nicht gegoogelt!

Bei mir ist der Raspi3 in der Tat langsamer, als der Docker auf dem NAS!
 

Stationary

Active member
SD Card in dem Raspi. Die fliegen mir immer so alle 1/2 Jahr um die Ohren.
was kaufst Du denn für SD Karten? Die Sandisk Ultra oder Extreme halten bei mir jetzt schon eine ganze Weile (etwa seit Januar 2020 als ich mit den Raspis begonnen habe, habe allerdings kein HA Szenario, sondern moode, pihole/unbound, minecraft-server, vielleicht liegt es daran).
 

carsten_h

Active member
HA auf einem Docker, Conbee2 und BT auf einem Raspi.
Hier läuft HA OS wunderbar auf einem Pi4 und auf einem anderen Pi4, der zentraler im Haus steht ist per Verlängerungskabel an USB 2 (sehr wichtig!) der ConBee 2 Stick. Dort läuft Raspberry Pi OS und darauf unter anderem deCONZ.
In HA ist nur die deCONZ Integration installiert (nicht das Addon!) und die erkennt das deCONZ im Netz auf Anhieb. Das ist gar kein Problem.

Bluetooth könnte problematischer werden, aber seit der Version 2022.9 von HA werden auch sogenannte Bluetooth Proxies unterstützt. Da müsstest Du einmal in den Releasenotes dazu nachlesen.
 

azrael783

Active member
Das wäre dann ja schade um die Datenbanken. Ich habe Influx mit Grafana eingerichtet
Wie gesagt, verschiebe doch einfach die Datenbanken aufs NAS. Dann entfällt die Sorge ;) Hab hier auch mal eine Anleitung dazu geschrieben.
Wenn du Hassos nutzt gibt es verschiedene Addons, um dein Backup irgendwo abzulegen. Ich selbst nutze das Samba Backup Addon und kopiere die Backups regelmäßig aufs NAS. Es gibt aber auch was für Google Drive.
 

remmiz

New member
Danke Euch für die Hilfe!
Werde erstmal das Backup angehen, dann nochmal mit der Raspi-deCONZ "Verlängerung" probieren. Habe gerade das Problem, dass das Zigbee bei uns im Haus, nicht vom Keller bis 1.OG/Büro reicht ...:cautious:
Im 1.OG steht der Raspi. Eigentlich sehr zentral im Haus...

Ich nutze im 1.OG halt diverse Xiaomi Mi Thermometer per Bluetooth. Die Konfiguration ging super einfach mit der integrierten BT Erweiterung in HA. Das müsste ich halt irgendwie "verlängern" ...

Ich habe jeweils den Conbee II als auch einen externen BT Dongle per USB Verlängerung an den Raspi angeschlossen. Einfach um die Störungen und Reichweiten damit zu erhöhen. Für Zigbee reicht das anscheinend nicht.

Müssen Zigbee Geräte, um als Repeater zu dienen, am selben GW angemeldet sein?
Ich habe eine Hue Bridge mit Hue Lampen und den Conbee II mit Thermometern und Schaltern gekoppelt.

Danke Euch
Viele Grüße
Björn
 

carsten_h

Active member
Werde erstmal das Backup angehen
Das ist top! Das sollte nach der Installation das erste sein, was man macht, vor allem anderen. Es wäre schön, wenn HA einfach keine Geräte erkennt, solange kein automatisiertes Backup läuft.
Und ohne die Releasenotes zu lesen sollte auch kein Update funktionieren. :)

Ich nutze im 1.OG halt diverse Xiaomi Mi Thermometer per Bluetooth.
Dann lies Dir einmal durch, was in den Releasenotes der 2022.9 zu den Bluetooth Proxies stand.

Ganz frisch aus den Releasenotes zur 2022.10: https://www.home-assistant.io/blog/2022/10/05/release-202210/#active-bluetooth-everywhere
Hier noch ein Bericht zur neuen Version: https://stadt-bremerhaven.de/home-a...verbesserungen-im-bereich-bluetooth-und-mehr/

Müssen Zigbee Geräte, um als Repeater zu dienen, am selben GW angemeldet sein?
Die Repeaten nur im eigenen Netz, würde ich sagen.

Ich habe eine Hue Bridge mit Hue Lampen und den Conbee II mit Thermometern und Schaltern gekoppelt.
Dann hast Du zwei voneinander völlig unabhängige Netze, die sich nicht kennen, aber gegenseitig stören können, wenn sie auf demselben Kanal senden.
 
Zuletzt bearbeitet:

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
1.334
Beiträge
17.775
Mitglieder
843
Neuestes Mitglied
smartloftnrw
Oben