VPN über Tailscale

legoor

New member
Hallo,

ich habe auf meinem Home Assistent (laufend auf einem Raspberry PI4) Tailscale eingerichtet und die entsprechende App für mein Iphone heruntergeladen. Ich kann hierüber auch problemlos eine VPN-Verbindung mit der IP-Adresse des Home Assistant herstellen. Wenn ich allerdings in die Handy App wechsele erhalte ich immer die Fehlermeldung "The internet connection appears to be offline. NSURLErrorDomain -1009". Somit kriege auch leider keinen Zugriff via VPN.

Was mache ich denn falsche oder habe ich vergessen?

Viele Grüße
Philipp
 

blurrrr

Well-known member
Hi,

kommt wohl darauf an.... a) wie die Verbindung eingerichtet wurde bzw. was alles in den Tunnel wandert (ggf. auch DNS-technisch) und b) wie Du die HA-Installation selbst ansprichst. Was hast Du denn bei internal und external URL bei HA angegeben?

entsprechende App für mein Iphone heruntergeladen. Ich kann hierüber auch problemlos eine VPN-Verbindung mit der IP-Adresse des Home Assistant herstellen.
Soweit verständlich...
Wenn ich allerdings in die Handy App wechsele
Nicht wirklich verständlich, es hat doch mit dem iPhone alles funktioniert, oder reden wir jetzt von einem anderen Handy und/oder einer anderen App, oder dem Zugriff auf HA via Browser?
 

legoor

New member
Da habe ich mich leider wohl missverständlich ausgedrückt... Ich meinte, ich kann über die Tailscale App eine VPN Verbindung herstellen. Wenn ich dann allerdings in die HA App auf dem Handy wechsele, dann kriege ich beschriebene Fehlermeldung. Hier wird also gar nicht erkannt, dass ich verbunden bin.

Wo finde ich denn die Angaben zu internal und external URL?
 

blurrrr

Well-known member
Wo finde ich denn die Angaben zu internal und external URL?
Die findest Du innerhalb von HomeAssistant.
Hier wird also gar nicht erkannt, dass ich verbunden bin.
Verbinde Dich mal via TailScale und schau dann, ob Du z.B. über den Smartphone-Browser auf die HA-Installation kommst (erstmal ohne "App"), sollte theoretisch funktionieren. Alternativ kannst Du auch einfach mal schauen, ob Du evtl. auf das Webinterface Deines Routers bei aktiviertem VPN kommst. Falls nicht, kann ich mir das nur so erklären, dass die TailScale-App nicht im Hintergrund aktiv laufen darf, so dass beim App-Wechsel der Tunnel wieder abgebaut wird, kann ich mir aber eigentlich nicht vorstellen. Ich selbst nutze die OpenVPN-App zwecks VPN und da wird die Verbindung jedenfalls nicht getrennt, wenn ich die App wechsel :)

Wahrscheinlicher ist allerdings, dass ggf. entsprechende Routen fehlen... Kleines Beispiel dazu:

Reguläres Netz: 192.168.1.0/24 (HA-Installation z.B. unter 192.168.1.10)
VPN-Netz: 10.0.0.0/24 (Server 10.0.0.1, Client 10.0.0.2)

Wenn die Route (der Weg) für das reguläre Netz nicht mit durch den Tunnel wandert (und die Gegenseite es auch nicht kennt - Weg zurück), wirst Du keine Verbindung herstellen können. Wenn das ganze auf der HA-Installation läuft, könntest Du es mit der HA-App mal mit der VPN-Server-IP versuchen. Wenn Du die HA-Installation über die "ganz normale interne IP" ansprechen willst, müssen bei der VPN-Verbindung zumindestens 2 Routen bekannt gemacht werden, einmal die für das VPN-Netz selbst (ggf. 10.x.x.x) und einmal für Dein reguläres Netzwerk (192.168.x.x).
 

Neueste Beiträge

Letzte Anleitungen

Statistik des Forums

Themen
647
Beiträge
9.532
Mitglieder
239
Neuestes Mitglied
Timyboy
Oben