Upload Probleme beim Streamen

fetterstein

New member
Hallo zusammen,

ich habe ein komisches und schwieriges Problem, beim Streamen (Live Video Upload) werden Frames aufgrund Überlastung des Netzwerkes ausgelassen:
1680883869283.png

Dies ist sehr komisch, da eine Glasfaser mit 500Mbit/s im Download und 50Mbit/s im Upload vorhanden ist und so ein kleiner Upload Stream von 10 Mbit/s sollte locker möglich sein.
Der erste Speedtest sieht gut aus.
1680884014977.png

Die benutzte Hardware:
Fritzbox 7490 (OS 07.29) mit einem Genexis fibertwist g2120b als externes Modem.
Ein Computer via Gigabit Lan direkt mit der Fritzbox verbunden. Keine anderen Geräte sind im Netzwerk.

Troubleshooting:
Ein weiterer Speedtest, der mehr Informationen ausgibt zeigt ein komisches verhalten im Upload, erst nach knapp 10 Sekunden wird die Leitung voll benutzt.
1680884067998.png

Bei genauer Betrachtung von anderen Speedtests ist dieses Verhalten auch zusehen.

Der Wireshark Mitschnitt zeigt TCP Fast Retrasmission und Out Of Order.
1680886297634.png

Der ISP ist bereits informiert, jedoch kann dieser das Problem nicht identifizieren. Er versucht erstmal den einfachsten Weg - Ich soll mir eine neue Fritzbox kaufen.

Kennt einer von euch das Problem? Was kann ich noch testen?
 
Hi,

versuch es mal besser via UDP, das eignet sich wesentlich besser zum streamen :)

EDIT: Vielleicht erläuterst Du Dein Konstrukt/Vorhaben auch einfach mal etwas näher?
 
Ist ein nicht gelisteter Youtube Stream, es gibt keine Möglichkeit das Protokoll einzustellen. Zudem möchte ich nicht das Problem umgehen sondern es Lösen.
 
Ist ein nicht gelisteter Youtube Stream
Was auch immer das sein soll.
Zudem möchte ich nicht das Problem umgehen sondern es Lösen.
Das "eckige" soll jetzt aber gefälligst in das "runde"! Na dann pack schon mal den Hammer aus... 😜

Ich formulier es jetzt mal "ganz einfach": Es gibt Protokolle, welche sich zum streamen eignen und dann gibt es Protokolle, welche sich "nicht" dafür eignen. Da hilft es grundsätzlich erstmal zu verstehen, wo der Unterschied zwischen "TCP" und "UDP" liegt:

TCP sorgt dafür, dass Daten "vollständig" ankommen. Sowas ist nötig, wenn Du z.B. ein Dokument verschickt. Kommen davon nur Bruchstücke an, kann das Dokument nicht geöffnet werden und ist somit unnütz. Verloren gegangene Pakete werden mit TCP erneut übertragen, so dass alles "vollständig" ankommt.

Anders sieht es aus bei z.B. Echtzeitanwendungen/Streaming. Hier ist es egal ob man ein Paket fehlt, wichtig ist, dass die Daten "schnell" ankommen. Fehlt z.B. ein einziges Paket in einem Telefonat über Internet, kriegt man das noch nichtmals mit, ähnlich verhält sich das bei Videos. Dafür gibt es dann z.B. UDP, was dafür sorgt, dass die Daten "schnell" geliefert werden.

Nutzt Du einen Stream via TCP und es kommt zu Paketverlust auf der Strecke ("Internet"), wird TCP stets versuchen, alle verloren gegangenen Pakete erneut zu übertragen (es fehlen ja welche!). UDP würde dies an dieser Stelle einfach "nicht" machen.

Wenn es Dich interessiert, lies Dich einfach mal ein bisschen ein: https://de.wikipedia.org/wiki/Transmission_Control_Protocol#Fast-Retransmit_und_Fast-Recovery, das erklärt Dir auch ein paar Dinge von Deinem Paketmitschnitt.

Unter'm Strich heisst es: Das Problem wird nicht "umgangen", sondern Du hast Dir das Problem schlichtweg selbst geschaffen, indem Du das falsche Protokoll nutzt. Würdest Du eine Video-"Datei" übertragen (also kein "Stream"), wäre hingegen TCP genau das richtige Protokoll :)
 
Zuletzt bearbeitet:
Danke für die schöne Erklärung. Es wird das RTMP fürs Streaming verwendet, dieses benutzt TCP für die Übertragung. Früher mit der 50Mbit Leitung hat es reibungslos funktioniert. Sich tausende Leute können dies auch ohne Probleme verwenden.

Ich möchte herausfinden wieso der Upload erst nach 10 Sekunden die Leistungsgrenze erreicht. Ist die Fritzbox zu Alt? Liegt es am externen Modem? Oder hat der ISP Probleme?

Gibt es eine Möglichkeit via CLI auf die FB zukommen? Gibt es bessere Auswertungstools? Die WebUI sagt nicht soviel aus. Gibt es eine Möglichkeit auf das externe Modem zukommen?
 
https://en.wikipedia.org/wiki/Real-Time_Messaging_Protocol, sofern verfügbar, ggf. mal mit RTMFP probieren. CLI auf die Fritzbox geht (meines Wissens nach) schon seit geraumer Zeit nicht mehr (früher ging es via Telnet, k.A. ob es heute doch noch irgendwie geht). Window-Size wäre theoretisch noch so ein Stichwort (warum es nicht "instant" 100% gibt), wobei "10" Sekunden da auch schon echt hart sind (sowas ist normalerweise doch schneller abgewickelt (ausser natürlich bei Paketverlusten) und ansonsten blieben noch die üblichen verdächtigen (Störungen in der Verbindung zum Router, z.B. Kabel, etc.), aber eben auch Dinge wie z.B. Antivirus-Lösungen, welche ggf. auch in die Verbindung eingreifen. Vielleicht einfach mal zum testen sowas mal kurzzeitig ausschalten und schauen, ob es ggf. Besserung bringt. Bezüglich der Fritzbox kannst Du Dir ja mal die Auslastung anschauen, aber ich denke nicht, dass da irgendwas auffällig sein wird (das "bisschen" da sollte eigentlich eine halbwegs aktuelle Fritzbox in keinster Weise tangieren) :)
 
Ein kleines Update: Vom ISP wurden 3 Servicetechniker rausgeschickt. Zuerst einen 1st Level, dann einen 2nd Level als letztes ein 3rd Level. Alle 3 konnten den Fehler feststellen, wobei der letzte sich am Straßenverteilerkasten auf die Leitung geschaltet hatte. Dieser ist dann zum Großverteiler 2km weiter gefahren und konnte dort auch den Fehler feststellen. Das Ticket ist mittlerweile im 3rd Level gelandet und ich habe heute einen Anruf bekommen. Der Fehler sei lokalisiert worden, es betrifft eine Upload Glasfaser im ISP Netz, diese soll sehr viele Paketverluste haben. Es seien mehrere Kunden betroffen, jedoch soll das Problem noch diese Woche behoben werden.
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
4.484
Beiträge
46.113
Mitglieder
4.111
Neuestes Mitglied
searchingnet
Zurück
Oben