Tasmota Integration konfigurieren - Button fehlt?!

Marc Mertens

New member
Hallo Home Assistant Communitiy,
unter "Integrationen" habe ich "Tasmota" hinzugefügt. Leider vermisse ich bei mir den KONFIGURIEREN Button. Bei einem anderen User sieht das so aus:
Tasmota2.JPG

Bei mir sieht das so aus:
Tasmota1.JPG

Bei diversen Integrationen gibt es bei mir diesen Button (z.B. hier MQTT), aber bei meiner Tasmota Integration nur das Logo, Tasmota-Schriftzug und die drei Punkte für das Menü (in dem es aber auch nichts gibt was mich weiter bringt).

Leider sind die Suchbegriffe für mein Problem zu allgemein um im Internet etwas zu finden.
Habt ihr einen Tipp oder sogar eine Lösung/Erklärung?

Danke und Gruß
Marc
 

Tobbes

New member
Normal stehen hier die Geräte und die Entitäten. "Konfigurieren" steht bei mir dort auch nicht.
Wurden evtl. keine tasmota Geräte erkannt? Die tasmota Firmware darf für die Erkennung nicht zu alt sein.
Hast Du einen Neustart von HA versucht?

Gruß tobbes
 

Marc Mertens

New member
Hi Tobbes,
HA wurde auf das letzte Update gebracht und neu gestartet.
"Nicht erkannt" passt ins Bild. Welche Version muss Tasmota denn haben?

Danke und Gruß, Marc
 

Marc Mertens

New member
Hm, auch nach Upgrade auf 12.1.1 auf mind. 4 Geräten, inkl. Neustart (auch von HA) findet die Tasmota Integration keine Geräte/Entitäten. Habe auch in der Tasmota Konsole SetOption19 0 ausgeführt.
Wo könnte ich noch etwas "verbogen/verstellt" haben?
@carsten_h: danke für das Bild/die Info
 

Marc Mertens

New member
Bevor ich die Integration von Tasmota vorgenommen habe, liefen alle Geräte über den Moskito broker in HA. Die Werte der Geräte konnte ich z.B. in NodeRed empfangen. Sollte also nicht daran liegen.
 

Tobbes

New member
Ich glaube für die Tasmota Erkennung in HA muss man den MQTT Server in den ESP eintragen und ein MQTT Broker laufen.
Wenn Du also ein FW Update gemacht hast, prüfe ob der MQTT Server korrekt eingetragen ist.
 

Marc Mertens

New member
GELÖST

PROBLEM: Tasmota-Integration in HomeAssistant findet keine Geräte/Entitäten

URSACHE:
Während eines Updates von/in HA wurden die Settings des MQTT-Brokers (Broker-Name (IP-Adresse), Benutzername, Passwort ) durch HA mit Default-Werten überschrieben. In den Tasmota-Geräten waren jedoch noch die ursprünglichen MQTT-Settings hinterlegt. Eine Kommunikation war somit nicht möglich.

LÖSUNG:
Nachdem ich die Default-Settings in der HA MQTT-Integration wieder auf meine ursprünglichen Werte gesetzt habe, lief wieder alles. Die Tasmota-Integration zeigt/findet die Entitäten seit dem automatisch. Das Update der Geräte von Tasmota v9.2 auf 12.1.1 hat die MQTT-Settings in den Tasmota-Geräten nicht verändert.

@carsten_h: du hattest recht, Name und Passwort waren falsch
@Tobbes: auch du hattest recht, als du geschrieben hast, hätte ich in allen Tasmota-Geräten die Setting der "neuen" MQTT-Integration eintragen müssen.

Etwas irritierend bei der Ursachenforschung war, dass meine Automation scheinbar funktionierte. Denn meine Tasmota-Geräte senden ausschließlich an NodeRed... ...und die Verbindung funktionierte ja noch.

Danke an alle die geholfen haben!
Gruß und Dank, Marc
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
1.725
Beiträge
21.437
Mitglieder
1.234
Neuestes Mitglied
Doneinei
Oben