RPI3 aus dem Standby wecken

turre

Member
RPI3 mit USB.M.2SSD , HA InfluxDB und Grafana soll Temperaturen aufzeichnen.
Aber wenn ich die Daten lesen will mit IP.8123 habe ich keinen Zugriff, muss Powerkabel ziehen und neu starten.
Wie kann ich das ändern?
 

Stationary

Active member
Der Raspberry Pi hat meines Wissens eigentlich gar keinen sleep/standby modus. Das was Du siehst (bzw. nicht siehst) könnte aber mit der Bildschirmabschaltung des Pi zu tun haben.
Was Du mal versuchen könntest, wäre ein Eintrag in /boot/firmware/config.txt:
hdmi_force_hotplug =1
Das sollte dazu führen, daß ständig ein Bildsignal generiert wird und die Bildschirmabschaltung nicht greift. Eventuell hilft das schon auch beim Zugriff über IP:8123
 

turre

Member
habe jetzt hdmi angeschlossen und man findet eine Konsole vor mit ha
weiss nur nicht was man damit anfangen kann.
 

turre

Member
noch eine Frage betreffend Blue Tooth, bekomme immer einen Fehler wegen BT, das aber garnicht verwendet wird. Wie kann ich das deaktivieren bzw rausschmeissen?
 

turre

Member
Jetzt zeigt mir der RPI an: undervoltage discovered. Benutze Originalnetzteil, USB-Kabel zur M.2-SSD ist 10cm lang.
 

carsten_h

Active member
undervoltage discovered.
Das passiert beim Raspberry Pi 3 ziemlich schnell. Die Spannung fällt halt stark ab, wenn da so etwas wie eine SSD an USB hängt.
Außerdem hat der Pi 3 ja nur USB 2 und dementsprechend liefert er darüber auch nur wenig Strom, der für eine SSD eventuell nicht ausreichend ist.

Eine Lösungsmöglichkeit wäre die SSD an einen stromversorgten USB Hub anzuschließen und den an den Pi. Aber ob der Pi dann davon noch booten kann ist die Frage. Oder bietet vielleicht das M.2 Gehäuse eine Möglichkeit dort Strom anzuschließen?
 

turre

Member
Habe ein doppeltes Problem:
-das Originalnetzteil hat bei 5V 2.0 A, für SSD zu wenig
-das swap file muss vergrößert werden.
Wenn ich eine micro-SD nehme, sollte das Powerproblem eigentlich nicht auftreten
 

the other

Well-known member
Moinsen,
naja, vielleicht mal nach ssd mit eigenem Netzteil suchen. Als früher die Raspi nach und nach mit hdds betrieben wurden, waren auch immer mal Probleme am Start, die dann mit hdd-eigenem Netzteil behoben werden konnten.
Die sd-card macht es da natürlich einfacher. Andererseits kommt es ja nun leider regelmäßig dazu, dass die Dinger von jetzt auf gleich "abschmieren" und kaputt gehen ohne, dass du vorher irgendeine Diagnose durchführen kannst.
Von daher: generell IMMER backups ziehen und ggf. eine (gute) sd-card vorhalten, die im Ernstfall schnell bespielt werden kann...
:)
 

the other

Well-known member
Moinsen,
nur nochmal kurz nachgefragt:
du hast auf dem Raspi nur das Home Assistant Betriebssystem (inkl. Grafana und co)? Oder nutzt du Home Assistant als docker container unter Raspian OS?
Wo ist das logfile? :)

Wie hast du die swap Partition erweitert?
;)
 

Progof

-
Moderator
Bitte das Log als Zitat formatiert einfügen und nicht als Datei. Nicht jeder möchte erst eine Datei runterladen müssen um evtl. helfen zu können. Vielen Dank.
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
968
Beiträge
14.038
Mitglieder
499
Neuestes Mitglied
John58
Oben