Pushover Sound ändern

Thrusty

Member
Hallo, kann mir jemand sagen ob und wenn ja wie man die Sound Ausgabe einer Pushover Meldung ändern kann?

Das einfache Einfügen von Sound: Bike funktioniert leider nicht, dann wird die PushMeldung gar nicht gesendet.
D.h. das Ausführen des Codes wird wohl an der Stelle wo Sound steht abgebrochen. Weil das matt publish dann auch nicht ausgeführt wird.

YAML:
alias: Post
description: ""
trigger:
  - platform: state
    entity_id:
      - switch.tasmota_2
    from: "off"
    to: "on"
condition: []
action:
  - service: notify.pushover
    data:
      message: Post 📮
      sound: Bike
  - service: mqtt.publish
    data:
      topic: cmnd/InfoLED/event
      payload: block5=7
mode: single

Ich habe hier noch eine andere Lösung gefunden und ausprobiert. Leider mit dem gleichen Resultat.

YAML:
alias: Post
description: ""
trigger:
  - platform: state
    entity_id:
      - switch.tasmota_2
    from: "off"
    to: "on"
condition: []
action:
  - service: notify.pushover
    data:
      message: Post 📮
      title: "Title of message"
      data:
      url: "https://www.home-assistant.io/"
      sound: Bike
      priority: 0
  - service: mqtt.publish
    data:
      topic: cmnd/InfoLED/event
      payload: block5=7
mode: single

Vielleicht habe ich auch nur ein Problem mit dem Einrücken der Zeilen!? Davon habe ich leider aber noch keine Ahnung.
Über Trace bekomme ich folgende Aussage:
Stopped because an error was encountered at 17. September 2022, 18:55:18 (runtime: 0.00 seconds)
expected dict for dictionary value @ data['data']
 
Zuletzt bearbeitet:

alexamend

Active member
Soweit ich das noch in Erinnerung habe...
Muss sound: und priority: nochmals eingerückt werden.

YAML:
action:
 - service: notify.pushover
   data:
     message: Post 📮
     title: "Title of message"
     data:
     url: "https://www.home-assistant.io/"
       sound: Bike
       priority: 0
 

Thrusty

Member
Da spielt yaml nicht mit. In der UI bekam ich es nicht rein, da hab ich es direkt in der configuration.yaml versucht und direkt diesen Fehler bekommen.

YAML:
bad indentation of a mapping entry (610:13)

 607 |       title: Titel of Message
 608 |       data:
 609 |       url: https://www.home-assistant.io/
 610 |        sound: Bike
---------------^
 611 |   - service: mqtt.publish
 

alexamend

Active member
Automatisierung sollte auch funktionieren, hatte aber einen Fehler drin, da vom Handy aus eingegeben... SORRY
url: muss auch noch mit eingerückt werden.

YAML:
action:
 - service: notify.pushover
   data:
     message: Post 📮
     title: "Title of message"
     data:
       url: "https://www.home-assistant.io/"
       sound: Bike
       priority: 0
 

Thrusty

Member
Das mit dem Einrücken ist nun OK. Kann man so ohne Fehlermeldung speichern.
Nur das Pushover das nicht akzeptiert, es wird kein anderer Sound ausgegeben. Ich hab verschiedene ausprobiert.
 

Thrusty

Member
Habe ich alles gemacht. Sonst würde ich ja gar keine Meldung aufs Handy bekommen.
Nur das der Sound immer der gleiche ist. Obwohl es die Möglichkeit gibt anderen zu empfangen.
Nur wie?
 

Thrusty

Member
Ich hatte noch ein paar andere Probleme. Die sind nun aber gelöst.
Nur das mit dem ausgewählten Sound bei einer Pushover Meldung geht nach wie vor leider nicht. Ich habe nun folgenden Code verwendenden:
YAML:
action:
  - service: notify.pushover
    data:
      message: Post 📮
      data:
        url: https://www.home-assistant.io/
        sound: Magic
Aber der Sound ist immer der gleiche, egal was ich im Code ändre.
 

alexamend

Active member
Versuche es mal so...
Hatte noch keine Zeit es bei mir zu testen, das ist die config Automatisierung Vorschlage von git.

YAML:
- service: notify.entity_id
  data:
    message: "This is the message"
    title: "Title of message"
    data:
      url: "https://www.home-assistant.io/"
      sound: magic
      priority: 0
 
Zuletzt bearbeitet:

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
968
Beiträge
14.028
Mitglieder
499
Neuestes Mitglied
John58
Oben