Netzwerkkarte mit Crossoverkabel betreiben

Willi0513

New member
Hallo Zusammen,

mein PC hat mittels einem WLAN-Stick Zugang zum Internet.

Jetzt habe ich meine Netzwerkarte mit meiner Zentrale zur Steuerung meiner Modellbahn mit einem Crossoverkabel verbunden.
Die Netzwerkkarte bekommt aber immer automatisch die IP 169.254.144.5, somit kann ich keine Verbindung zur Zentrale herstellen.
Meine Frage ist jetzt:
Wie kann ich meiner Netzwerkkarte manuell und dauerhaft eine gültige IP-Adresse zuweisen?

Viele Grüße
Willi
 

blurrrr

Well-known member
Hallo,

Das ist schon eine "gültige" IP, sowas bekommst Du, wenn Du nichts "fest" zugewiesen hast, oder etwas automatisch (wie z.B. vom Router) zugewiesen wurde. Du hast nun 2 Möglichkeiten:

a) Du vergibst Dir und der Zentrale "manuell" IP-Adressen (z.B. 192.168.250.1 + 192.168.250.2)
b) Du schliesst die Steuerung Deiner Eisenbahn direkt an Dein normales Netzwerk an (z.B. direkt an den Router)
 

FSC830

Active member
Jein.
Eine 169.254. Adresse wird automatisch vergeben, wenn die Schnittstelle auf DHCP eingestellt ist, aber kein DHCP Server erreichbar ist.
Du musst, wie o.a., der Netzwerkkarte eine feste IPv4 Adresse geben (zur IP der Bahnsteuerung passend).
Wenn der PC eine 1GB/s Schnittstelle hat, brauchst Du auch keine Crossoverkabel, ein normales Patchkabel Cat5 reicht aus.

Gruss
 

Willi0513

New member
Hallo,
vielen Dank für die schnellen Antworten.
Aber genau das war meine Frage: Wie kann ich der Netzwerkkarte eine feste IP-Adresse zuweisen.

Jetzt habe ich gerade ipconfig aufgerufen und sehe, dass mir die Netzwerkkarte gar nicht angezeigt wird und somit auch nicht im Netzwerk- und Freigabecenter.
Kann ich da manuell eingreifen, dass mit das wieder angezeigt wird?

Gruß
 

blurrrr

Well-known member
Schau mal via "ipconfig /all", wenn da auch nix auftaucht, guckste mal im Geräte-Manager, ob die Karte überhaupt "erkannt" wurde (mal unabhängig von Treibern).
 

blurrrr

Well-known member
Btw die Frage nach der statischen IP... Wäre erstmal die Frage, ob Du die Steuerung nicht mit ins normale Netzwerk integrierst? Falls nicht (und das definitiv nicht), wäre der Weg wie folgt:

- "Netzwerk- und Interneteinstellungen" öffnen
- "Adapteroptionen ändern"
- entsprechende Netzwerkkarte auswählen, Rechtsklick -> Eigenschaften
- "Internetprotokoll, Version 4" auswählen, Klick auf Button "Eigenschaften"
- Umstellen von "automatisch" auf "folgende IP-Adresse verwenden"
- Dort die gewünschten Daten eintragen (nur IP + Subnetzmaske, Rest brauchst Du dort nicht)

Sieht dann z.B. so aus:

1666955003950.png

Wenn Du Deinem Rechner die z.B. 192.168.250.10 gibst, sollte die Steuerung der Bahn auch eine IP aus diesem Segment bekommen (z.B. 192.168.250.20 / 255.255.255.0) :)
 

Willi0513

New member
Mit ipconfig /allzeigt er mir meine Realtek-Karte mit der physischen Adresse an.
DHCP ist nicht aktiviert, Autokonfiguration ist aktiviert.

Wenn ich die Karte wieder sehe, werde ich die IP-Adressen mal eintragen.
 

FSC830

Active member
Verstehe ich nicht :unsure: . Die Karte muss zu sehen sein, selbst wenn sie deaktiviert ist.
Ist die Karte nicht zu sehen, dann fehlt ein Treiber oder der PC/die Karte ist defekt.

Und was ist mit "Autokonfiguration" gemeint? Wenn damit die Einstellung "IP Adresse automatisch beziehen" (siehe o.a. Screenshot) gemeint ist, dann ist das DHCP.

Gruss
 

Barungar

Well-known member
@FSC830

DHCP in Windows 11-Sprech:
1666964901450.png

Autokonfiguration in Windows 11-Sprech:
1666964932791.png

Beides aus den erweiterten Netzwerk-Einstellungen...

Das Erste ist wie gesagt DHCP und über die zweite Option steuert man, was sonst passiert.
Da kann man default eine Autokonfiguration oder eine manuelle IP hinterlegen; die nichts mit der manuellen IP zu tun hat, die man alternativ zu DHCP erfassen kann.
 

Willi0513

New member
Hallo zusammen,

mein Heimnetzwerk beginnt mit 192.168.178.xxx
Mein Programm zur Steuerung der Modellbahn erlaubt nur IP-Adressen bis 192.168.60.xxx
Ich müsste jetzt alle meine IP-Adressen ändern, dazu habe ich aber keine Lust.
D.h. ich werde meine Zentrale mit einem ganz langen Kabel quer durch die Wohnung mit meinem Router verbinden.
Schade, ich dachte es geht auch ohne Stolperfallen in der Wohnung.

Gruß
 

blurrrr

Well-known member
Naja, das geht ja schon, wenn Du den PC (in der Nähe der Zentrale) direkt mit der Zentrale verbindest. Du musst halt nur beide Seiten entsprechenden konfigurieren, z.B.:

PC (2. Netzwerkkarte)
IP: 192.168.60.10
Netzmaske: 255.255.255.0

Zentrale
IP: 192.168.60.20
Netzmaske: 255.255.255.0
 

Willi0513

New member
Hab ich schon probiert.
Dann bekomme ich die Meldung, dass die Zentrale auf ein Ping geantwortet hat, aber nicht auf eine Testnachricht.
Scheint doch komplizierter zu sein, als gedacht.
Und ich bin mir nicht sicher, ob es nicht andere Konflikte gibt, wenn mein Heimnetz weiterhin mit der 192.168.178.xxx
läuft.
 

blurrrr

Well-known member
Bevor das in massive Umbauten ausartet, lass Dein Heimnetz lieber so, wie es derzeit ist. Wenn die Zentrale auf einen Ping antwortet, ist die Hälfte der Miete doch schon im Sack :) Heisst, dass die Kommunikation soweit erstmal steht und beide miteinander kommunizieren könnten.

Nächste Frage wäre halt, "wie" der Client mit der Zentrale reden muss. Eventuell sind bestimmte Ports vorgegeben, an welche Du Dich halten musst (oder ggf. muss erst noch bei der Zentrale etwas nachkonfiguriert werden). Da müsste die Anleitung Deiner Zentrale aber entsprechende Infos zum Vorschein bringen.
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
1.725
Beiträge
21.437
Mitglieder
1.234
Neuestes Mitglied
Doneinei
Oben