Mqtt Verbindungsprobleme Mit Esp32 Cam Wasserzähler

Fehler404

New member
Hallo Liebe Community habe Versucht die esp32 cam Wasserzähler zu Mqtt einzurichten habe aber
Probleme mit der Verbindung habe vor ein Paar Tagen Home Assistant auf einem Raspberry Pi 4
Eingerichtet
Habe auch geschafft den Zigbee stick cc2531 Zu Verbinden aber die esp cam will nicht so ganz
Habe noch ein paar Screenshots mit geschickt vielleicht erkennt jemand wo das Problem ist
oder ich habe was Vergessen
Der Benutzername und das Passwort auf (Bild1) habe ich bei Person MQTT Broker (Bild2) auch das selbe eingetragen.
und beim Wasserzähler Benutzer Passwort das gleiche wie (Bild1) und (Bild2)
und noch etwas ich weiß nicht ob es relevant ist ich kann Home Assistant nicht über meine ip Abrufen
nur so http://homeassistant.local:8123/ Wenn ich versuche nur
die ip einzugeben kommt Die Website ist nicht erreichbar 192.168.***.*** hat die Verbindung abgelehnt.
aber wenn ich die ip eingebe und am ende den Port :8123 dann geht es (Bild3)
Ich hoffe dass mir einer Helfen kann ich Bedanke mich schonmal im voraus

grüße
Lukas
ps: Bin Anfänger
Blank 2 Grids Collage.png

Google Chrome 07.01.2023 15_16_19 (2).png
Bild3
---------------------------------------------------------------------------------------------------------------------------------------------------------------------
Home Assistant - Google Chrome 07.01.2023 13_52_25 (2).png
Bild4
------------------------------------------------------------------------------------------------------------------------------------------------------------------
Home Assistant - Google Chrome 07.01.2023 13_54_51 (2).png
Bild5

-----------------------------------------------------------------------------------------------------------------------------------------------------------------

Bild6
Home Assistant - Google Chrome 07.01.2023 13_55_06 (2).png
 

the other

Well-known member
Moinsen und willkommen,
Zu Wasserzählern und esp...keine Ahnung.
Zum Aufrufen per IP:
Was ergibt ein http(s)://IP.VON.HOME.ASSISTANT:5001 ?

Edit. Autokorrektur korrigiert...
 

the other

Well-known member
Moinsen nochmals,
Der von dir genutzte port ist eigentlich für den remote Zugriff gedacht:
https://www.home-assistant.io/docs/configuration/remote/

Du kannst ihn für den Zugriff unter bestimmten Bedingungen ändern.Der 5001er zB ist hier für https für home assistant eingerichtet. Der Aufruf gelingt lokal sowohl mit IP als auch mit hostname von home assistant PLUS Angabe des Ports.
Da ich aber meist eh via app zugreifen oder am PC ein Lesezeichen alias für home assistant angelegt habe, ist es nur ein Klick, keine manuelle Eingabe.
Wie die Angaben für den lokalen und remote Zugriff sein sollten ist auch noch hier:
https://www.home-assistant.io/installation/raspberrypi
beschrieben.
Wenn du also dahingehend nichts eingestellt hast...wie ist es mit der Eingabe von
Http://IP.VON.HOME.ASSISTANT.local:8123
?
 

u5zzug

Active member
der Port muss immer mit angegeben werden, auch bei der IP. 192.168.1.1:8123, steht ja auch so in dem einen Bild.
Du brauchst keine Person, nur einen User.
Ich schreibe die immer in die addon config, der Rest ist mir zu umständlich und ich meine auch, da ging mal was nicht.
 

Fehler404

New member
Ah ok Denn Fernzugriff ja so weit bin ich noch gar nicht erst mal local alles Testen
ich benutze auch die App ist ne feine Sache überhaupt Home Assistant schon nicht schlecht
was da alles geht.
ich Frage mich nur ob das ein Problem ist für denn esp wenn ich über die ip adresse keinen zugriff auf Home Assistant habe Hostname ist kein Problem und am ende mit ip :8123 auch nicht aber die reine ip geht halt nicht.
 

carsten_h

Active member
Du brauchst übrigens Deine lokalen IP Adressen nicht zu verstecken, damit kann von außen niemand etwas anfangen.
 

alexamend

Active member
das Homeassistant Webinterface läuft auf dem PORT:8123,
(immer davon ausgehend, es wurden die default PORT´s nicht geändert)

http://homeassistant.local:8123
http://192.168.xxx.xxx:8123 bzw. http://<IP_VON_HA>:8123

die verbindung zu mqtt "core-mosquitto"
mqtt://192.168.xxx.xxx:1883 bzw. mqtt://<IP_VON_HA>:1883

nur kann ich deiner Frage leider nicht Ganz entnehmen was jetzt mit deinem Wasserzähler nicht reibungslos funktioniert.
 

Slevin

New member
Moin,

dass du Home Assistant nur mit IP + Port in der Adresszeile erreichst ist normal.

Hatte ähnliche Probleme mit einem anderen Projekt.
(Optional): Ich habe in MQTT einen neuen User angelegt, extra für die Verbindung.

Aber die eigentliche Lösung war es bei der Serververbindung die Lokale Adresse von HomeAssistant anzugeben und am Ende den Port von MQTT.

Gruß Slevin
 

Slevin

New member
Moin,

dass du Home Assistant nur mit IP + Port in der Adresszeile erreichst ist normal.

Hatte ähnliche Probleme mit einem anderen Projekt.
(Optional): Ich habe in MQTT einen neuen User angelegt, extra für die Verbindung.

Aber die eigentliche Lösung war es bei der Serververbindung die Lokale Adresse von HomeAssistant anzugeben und am Ende den Port von MQTT.

Gruß Slevin
Korrektur:
Ich habe einen User in Home Assistant angelegt und in MQTT hinterlegt anschließend diesen zur Anmeldung genutzt.

Sprich in meinem Fall musste ich die Lokale HA IP mit dem Port von MQTT angeben und als Login den extra angelegten User.

Gruß Slevin
 

Fehler404

New member
Ja das gleiche habe ich auch gemacht eine Person angelegt Name MQTT Broker
und in den Einstellungen Benutzer und Passwort.
ich habe noch in den Mqtt settings bei Client-ID einfach mal wasser eingegeben und wo sich nichts geändert hat
habe ich es wieder weg gemacht das wasser später habe ich in denn mqtt Protokoll geschaut und dann stand das da
ich weiß nicht ob es was damit zu tun hat
closing old connection
keine Ahnung warum er die Verbindung schließt
aber was gut ist er zeigt die ip vom Wasserzähler
schlecht er will sich nicht verbinden oder die Verbindung halten
hat jemand ne idee

Home Assistant.png
 

Slevin

New member
Du hast ja geschrieben, dass der Wasserzähler nicht unter Geräte angezeigt wird.
Aber hast du mal geprüft, ob du neue Entitäten hast?
 

Fehler404

New member
ich bin ganz neu bei HA wenn du mir sagen würdest im Detail was das ist Entitäten ??
dann könnte ich nachschauen.
am Protokoll sieht man ja schon das er die Connection schließt aus was für einen Grund auch immer
ich denke aus diesem Grund steht auch bei geräte nichts denke ich.
 

u5zzug

Active member
Manchmal sind Entities nicht einem Gerät zugeordnet.
Z.B. die Bluetti hat nur sowas wie Update, verfügbar. ...
Die ganzen Sensoren sind ohne Gerätezuordnung unter Entitäte.n zu finden
 

Slevin

New member
meinst du bei Entwicklerwerkzeuge, Zustände, Aktuelle Entitäten
wenn du das meinst da steht auch nichts.

Dort siehst du es auch.

Du kannst die Entitäten aber auch unter Einstellungen -> Geräte & Dienste -> im Reiter Integrationen -> MQTT mit XX Geräte und XX Entitäten.

Schade das du nicht weiter kommst....
 

Slevin

New member
Hast du im Webinterface bei MQTT Uri bisher nur mqtt://<IP_VON_HA>:1883 oder auch http://<IP_VON_HA>:1883 getestet?
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
1.709
Beiträge
21.286
Mitglieder
1.217
Neuestes Mitglied
DUC750
Oben