Kiosk-mode Auflösung

Ocean100

New member
Hallo


Ich nutze einen raspberry pi 4 im kiosk-mode für homeassistant, mein Touchscreen unterstützt maximal 1366x768 Auflösung. Diese hab ich auch über raspi-config eingestellt, aber wenn er die Oberfläche vom homeassistant startet stellt er wieder auf 1920x1080 um was dann unscharf aussieht. Muss ich da irgendwo noch was ändern?

Mfg
 

blurrrr

Well-known member
Hi,

ich bin mir jetzt nicht sicher, was genau Du mit "Oberfläche von HomeAssistant" meinst (das ist ja eigentlich nur eine Website?), aber wenn der Raspi generell auf 1366x768 gestellt ist, sollte sich da beim Aufruf von irgendwas eigentlich auch nichts ändern, ausser wir reden auf der einen Seite von der Konsolen-Auflösung und auf der anderen Seite von der Auflösung vom X-Server (falls da sowas involviert sein sollte, habe HomeAssistant-Oberfläche nie direkt auf dem Raspi aufgerufen, falls sowas überhaupt möglich ist). Touchscreen direkt am Raspi angeschlossen? Alternativ müsste man ggf. die Auflösung direkt am Touchscreen/Endgerät ändern (sofern möglich).
 

Stationary

Active member
Hast Du den Wert für den hdmi_mode und hdmi_group korrekt geändert?

1920x1080 klingt wie
hdmi_group=2
hdmi_mode=82

oder

hdmi_group=1
hdmi_mode=16

Was Du brauchst, ist eher der folgende Eintrag:

framebuffer_width=1360 (nicht 1366!)
framebuffer_height=768
hdmi_group=2
hdmi_mode=39

Alternativ sollte auch das folgende Setting funktionieren:

hdmi_group=2
hdmi_cvt=1366 768 60
hdmi_mode=87

Optional kannst Du noch versuchen:

hdmi_group=2
hdmi_cvt=1366 768 60 3 0 0 1
hdmi_mode=87

Wenn das auch nicht gut aussieht, kannst Du noch einmal versuchen hdmi_mode 81 oder 86 auszuprobieren.


Außerdem würde ich grundsätzlich noch den folgenden Eintrag setzen:

hdmi_force_hotplug=1
 
Zuletzt bearbeitet:

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
1.334
Beiträge
17.778
Mitglieder
843
Neuestes Mitglied
smartloftnrw
Oben