host.domäne.tld verweist auf Diskstation

Frank73

Member
Hallo,

Aktuell sieht es so aus:
Nutzung des Paketes "DNS" (kein Adguard oder PiHole).
Als Zonen-ID eingetragen: "domäne.tld"
Div. A-Records mit IP -Verweis auf den DNS-Server (NAS)
Nutzung Reverse-Proxy auf die verschiedenen Hosts (Drucker, Pi, SIP-Telefone) --> Zugriff per SSL möglich, da diese Domäne zertifiziert ist.
Als Forwarder: IP der FB

Mir ist jetzt folgendes aufgefallen:

Netzerkdrucker ist ausgeschaltet und somit ist die Adminoberfläche über den Browser (Firefox) nicht erreichbar.
  • Bei der Eingabe im Browser "drucker.domäne.tld" öffnet sich die Eingabemaske des DSM.
    --> im Browser erscheint dann die Adresse "drucker.domäne.tld:5000/#/signin" :unsure:
  • Bei der Eingabe im Browser "ht**s://drucker.domäne.tld" erscheint der Hinweis, dass die Seite aktuell nicht erreichbar ist --> so hatte ich das auch erwartet
  • Bei der Eingabe im Browser "123.45.678.90" erscheint der Hinweis, dass die Seite aktuell nicht erreichbar ist --> auch so erwartet

Muss ich da irgendwo noch was administrieren, oder ist das einfach so?
 
Zuletzt bearbeitet:
Worauf zeigt denn drucker.domain.tld, den Drucker, den Reverse-Proxy (Standalone oder der von der Syno) oder direkt auf die Syno? Theoretisch sollte der Record direkt auf die Drucker-IP zeigen, wenn Du den Drucker direkt über den FQDN ansprechen möchtest. Für mich sieht das eher so aus, als würde der Record auch auf den RP/die Syno zeigen. Mitunter ist dort nur ein Eintrag für "HTTPS" und nicht "HTTP" vorhanden, so dass da evtl. ein Fallback auf den Standard-vHost (DSM) stattfindet? 🙃
 
Im DNS steht ein A-Record mit folgendem Eintrag:
"drucker.domäne.tld" (kein "http" oder "https" vorgestellt) und die IP zeigt auf die Syno/DNS

Im Reverse-Proxy ist folgender Eintrag:
Quelle:
Protokoll: HTTPS
Hostname: "drucker.domäne.tld"
Port: 443
HSTS: aktiviert

Ziel:
Protokoll: HTTPS
Hostname: IP des Druckers
Port: 443
 
Achso, Dir geht es dabei "nur" um das Webinterface des Druckers und nicht um den Drucker selbst... okay... Najo, ich sag mal so: Die Syno reagiert normalerweise auch einfach nur auf die IP, im Grunde kann man sich das ganze (ähnlich wie beim DNS) wie folgt vorstellen:

* : Port -> Default
Spezifisch1 : Port -> Eintrag1
Spezifisch2 : Port -> Eintrag2

Heisst übersetzt: Solange etwas spezifiziert ist, wird auch versucht, diese Anweisung umzusetzen. Ist es nicht genauer definiert, wird eine allgemein gültige Regel greifen. Im o.g. Fall wäre es z.B. so, dass wenn man mit "Spezifisch3" anrücken würde, dafür aber kein Eintrag existiert, halt die erste Regel greifen würde ("* : Port -> Default").

Du hast bei Dir auf dem Reverse-Proxy nur eine Regel für HTTPS laufen. Jetzt kommt die Anfrage aber via HTTP an ("host.domain.tld" in den Browser einzugeben ist gleichbedeutend mit "http:// host.domain.tld"). Existiert keine Weiterleitung von HTTP auf HTTPS, greift erstmal die Default-Regel der Syno (für "alles andere", z.B. auch Ansprache direkt via IP), welche besagt: "Umleiten auf Port 5000" (andernfalls bliebe es beim Port 80 (HTTP) und es gäbe eine Fehlermeldung). Das gleiche kannst Du beobachten, wenn Du einfach nur die IP der Syno in den Browser eingibst. Das wäre auch gleichbedeutend mit http://<IP>, dort findet allerdings in erster Linie ein Redirect auf Port 5000 statt.

Entweder kümmerst Du Dich noch darum, dass Du auch entsprechend einen Eintrag im RP für "http" machst, oder Du lebst damit. Ich persönlich halte es gern einfach und lebe einfach mit letzterem, denn so oft muss ich nun wirklich nicht auf das Webinterface des Druckers... einmal eingerichtet, bin ich da jetzt seit Jahren auch nicht mehr dran gewesen ☺️

EDIT: Nur nochmal zur Klarstellung: Hast Du auch eine entsprechende Regel für "HTTP" würdest Du dort dann bei ausgeschaltetem Drucker auch die gleiche Fehlermeldung wie bei der Ansprache via HTTPS bekommen (Ziel des RP ist in dem Fall ja nicht ansprechbar) :)
 
Zuletzt bearbeitet:
Vielen Dank @blurrrr für die ausführliche Erklärung.

Jetzt verstehe ich auch die Zusammenhänge. :)
Ich halte es so ähnlich wie du. Ich lebe damit (mir ging es im Wesentlichen um Verständnis)
 
Nochmal als kleiner Vorführeffekt. Ich habe grade mal eine Zone angelegt (frank73.local) und dort einen A-Record (test123) auf die Syno-IP zeigen lassen, sieht dann direkt so aus beim Aufruf von "test123.frank73.local" im Browser:

1677940053280.png

Rückt also erst via Port 80 (http) an und wird dann direkt weitergeleitet auf Port 5000 :)
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
4.872
Beiträge
49.053
Mitglieder
4.533
Neuestes Mitglied
Karlmaster
Zurück
Oben