Home Assistant und Influxdb auf RPI3

turre

New member
hallo bin neu hier.
Habe mir Teil 1+2 der Einrichtung Influxdb und Grafana angeschaut:
HA auf RPI3, Infuxdb zeigt homeassistant.autogen keine Daten "no Measurement selected". Ich hänge mal die config dran.
Vielleicht hat jemand eine Idee und kann mir weiterhelfen.Danke

Code:
# Loads default set of integrations. Do not remove.
default_config:

# Text to speech
tts:
  - platform: google_translate

automation: !include automations.yaml
script: !include scripts.yaml
scene: !include scenes.yaml

lovelace:
  mode: yaml
#Heizung
modbus:
  - name: SYSTAComfort2
    host: 192.168.178.20
    type: tcp
    port: 502
    sensors:
      - name: "AußentemperaturTA"
        scan_interval: 100
        slave: 1
        input_type: input
        scale: 0.1
        unit_of_measurement: °C
        address: 0
        data_type: int16
      - name: "Vorlauftemp HK1 TV"
        scan_interval: 100
        slave: 1
        input_type: input
        scale: 0.1
        unit_of_measurement: °C
        address: 1
        data_type: int16
      - name: "Rücklauftemp HK1 TR"
        scan_interval: 100
        slave: 1
        input_type: input
        scale: 0.1
        unit_of_measurement: °C
        address: 2
        data_type: int16
      - name: "Warmwassertemp Oben TWO"
        scan_interval: 100
        slave: 1
        input_type: input
        scale: 0.1
        unit_of_measurement: °C
        address: 3
        data_type: int16
      - name: "Vorlauftemp Kessel FATV"
        scan_interval: 100
        slave: 1
        input_type: input
        scale: 0.1
        unit_of_measurement: °C
        address: 12
        data_type: int16
      - name: "Rücklauf Kessel FATR"
        scan_interval: 100
        slave: 1
        input_type: input
        scale: 0.1
        unit_of_measurement: °C
        address: 13
        data_type: int16
      - name: "Volumenstrom Solar S"
        scan_interval: 100
        slave: 1
        input_type: input
        scale: 0.1
        unit_of_measurement: l/min
        address: 35
        data_type: int16
      - name: "Kollektortemperatur 1 TSA1"
        scan_interval: 100
        slave: 1
        input_type: input
        scale: 0.1
        unit_of_measurement: °C
        address: 38
        data_type: uint16
      - name: "Betriebsstunden Kessel"
        scan_interval: 100
        slave: 1
        unit_of_measurement: h
        scale: 1
        address: 27
        data_type: uint32
      - name: "Anzahl Starts Kessel"
        scan_interval: 100
        slave: 1
        input_type: holding
        unit_of_measurement: 1
        scale: 1
        address: 29
        data_type: uint32
        
influxdb:
  host: 192.168.1.67
  port: 8086
  database: homeassistant
  username: homeassistant
  password: xxxx
  ssl: true
  verify_ssl: true
  max_retries: 3
  default_measurement: state
  include:
    domains:
       - sensor
 
Zuletzt bearbeitet von einem Moderator:

blurrrr

Well-known member
Herzlich Willkommen :)

Da @azrael783 die Anleitung geschrieben hat, warten wir mal ab, was er dazu sagt...

Aber schon mal vorab:

In der Anleitung ist SSL "deaktiviert" (bei Dir aktiviert). Da sich das ja nun wieder rein intern abspielt und (wenn überhaupt) mit selbst-signierten Zertifikaten gebaut wurde, ist der Parameter "verify_ssl: true" mitunter ziemlich fatal (solange da nix auf dem anderen Host importiert wurde). Ich würde es definitiv erstmal OHNE SSL versuchen ("ssl: false" + "verify_ssl" ganz raus), dann hast Du erstmal eine Baustelle weniger, welche Dir Probleme bereiten kann.

Wenn es dann noch immer nicht funktioniert, kannst Du aber schon mal ausschliessen, dass es irgendwas mit SSL zu tun hat :)
 

turre

New member
Danke, schon passiert, aber keine Änderung. Ichmuss noch was hinzufügen:
 

Anhänge

  • Screenshot 2022-07-06 152113.jpg
    Screenshot 2022-07-06 152113.jpg
    100,5 KB · Aufrufe: 4

azrael783

Active member
Probier doch mal noch andere Sachen hinzuzufügen, bspw. den Sensor für die Sonne (sun.sun), oder die binären Sensoren. Dann siehst du ja ob es generell klappt und nur an deinen Modbus Sensoren liegt.
 

turre

New member
Das funktioniert.
Mein Problem ist die Sensor_ID
Im Überblick wird alles richtig angezeigt.
Die Sensoradressen habe ich aus dem Modbus-Protokoll des Heizungsreglers, nur fehlt mir die Kenntnis woher ich die Sensor_ID bekomme.
 

azrael783

Active member
Die bekommst du nirgends her. Die wird entweder von HA selbst erstellt, oder du gibst sie in der Konfig an. Also einfach deine Einträge um ein "sensor_id: <unique_id> erweitern.
 

turre

New member
modbus:
- name: SYSTAComfort2
host: 192.168.178.20
type: tcp
port: 502
sensors:
- name: "Aussentemp TA"
scan_interval: 100
slave: 1
input_type: input
sensor_id: sensor.aussentemp_ta_2
scale: 0.1
unit_of_measurement: °C
address: 0
data_type: int16


Invalid config for [modbus]: [sensor_id] is an invalid option for [modbus]. Check: modbus->modbus->0->sensors->0->sensor_id. (See /config/configuration.yaml, line 16).
ich habe das geändert in unique_id: sensor.aussentemp_ta_2
die Konfigurationsüberprüfung beschwert sich nicht mehr.
Aber wie wähle ich jetzt "measurements" für influxdb unter Explore und der Datenbasis erscheinen keine measurements
 

Anhänge

  • Screenshot 2022-07-08 081521.jpg
    Screenshot 2022-07-08 081521.jpg
    90,4 KB · Aufrufe: 2
Zuletzt bearbeitet:

azrael783

Active member
Nutzt du das Addon von HA? Wie bereits gesagt, ich würde mal weitere Sensoren unter "include:" einfügen und schauen was passiert. Hast du die Logs mal geprüft, ob das was dazu steht?

Edit: ich habe grade mal bei mir in die Konfig geschaut. Ich habe default_measurement: units angegeben. Ich muss aber auch dazu sagen, dass ich influxDB in der Version 2.x nutze. Bei dir @turre sieht es mir eher nach v1.x aus.
 

turre

New member
Ja, habe das Addon aus dem Store installiert - gabs keine Auswahl Version 4.5.0 , also anstatt domains entity include
 

azrael783

Active member
Du kannst beides gleichzeitig nutzen. Ich habe zb. das drin:

YAML:
  include:
    domains:
      - sensor
      - switch
      - binary_sensor
    entities:
      - weather.home

Ich habe das Addon auch gerade mal installiert. Die Version des Addons (4.5.0) hat nur bedingt was mit der Version von inlfuxDB zu tun und das Addon verwendet noch die influxDB Version 1.x. Ab Version 2.x braucht man Chronograf nämlich nicht mehr. Da ist das Dashboard bereits integriert. So sieht dann die Oberfläche der 2er Version aus:

2022-07-08.png
 
Zuletzt bearbeitet:

turre

New member
danke für den Hinweis: werde mal schauen, wie ich das updaten kann.
habe die HA-Version für RPI3 32bit installiert - geht dann influxdb 2 überhaupt?
 
Zuletzt bearbeitet:

turre

New member
Kann man influxdb 2 in HA-OS installieren ? in den Addons ist nur die oben erwähnte Version verfügbar.
 

azrael783

Active member
Ich vermute nicht. Ich habe eine 64bit Version von HA-OS installiert und das Addon ist ja das gleiche. Ich habe influxDB auf meinem NAS installiert, deswegen kann ich die Version 2.x nutezn.
 

turre

New member
Wie oben beschrieben möchte ich die Heizungsdaten via Modbus auf dem RPI3 aufzeichnen.Im HA werden die korrekten Daten angezeigt und im Verlauf kann man die Daten über der Zeit verfolgen.
Was ist eine einfachere Methode: Telegraf,Influxdb 2 und Grafana?
 

azrael783

Active member
Generell sollten die Daten ja auch bei der Version 1.x in der influxDB landen. War ja bei mir auch so. Hast du denn jetzt mal weitere Sensoren hinzugefügt, oder die Logs mal näher betrachtet? Evtl auch mal in den Log vom influxDB Addon reinschauen (auf der Log Seite kann man oben rechts umschalten, welche Logs man sehen möchte).
 

turre

New member
neu auf gesetzt -altes Problem. Die Heizungstemperaturen etc werden im Überblick korrekt angezeigt, aber im Influxdb rührt sich nichts. Vermute, dass es der Modbus ist - kenne mich mit den Definitionen nicht aus. Vielleicht muss noch ein Register oder sowas Ähnliches hinzugefügt werden.
Gebe mal den Link für den Modbus meiner Heizungssteuerung - besser gesagt das Darstellen von Messwerten. Vielleicht kennt sich jemand damit aus.
 

turre

New member
habe den Fehler gefunden: sd-Karte zu oft beschrieben - obwohl sd-Formatter eingesetzt. und User einmal homeassistant und einmal home_assistant.
Danke für eure Unterstützung.
 

Zurzeit aktive Besucher

Neueste Beiträge

Letzte Anleitungen

Statistik des Forums

Themen
750
Beiträge
11.129
Mitglieder
310
Neuestes Mitglied
DirkHH
Oben