Home Assistant probleme in verbindung mit Adguard-Home

user91

New member
Hallo, vlt kann mir hier jemand weiterhelfen.
Ich habe folgendes Problem:

Wenn ich den Adguard -dns in der Fritzbox eintrage kommt es teilweise vor, dass meine Smart Home Geräte sich nicht steuern lassen. Egal ob über Alexa, oder einfach nur über Bewegungsmelder. Nach ein paar sekunden geht es dann wieder. ( Zigbee, (deconz stick mit rasperry pi 3b+ ) Es kommt wie gesagt nicht immer vor und sobald ich den dns wieder rausnehme läuft alles 1a.
hier mal 2 log dateien.

Logger: homeassistant.components.alexa.state_report Source: components/alexa/state_report.py:153 Integration: Amazon Alexa (documentation, issues) First occurred: 7. Mai 2022, 19:00:34 (6589 occurrences) Last logged: 09:47:56 Timeout sending report to Alexa for light.wohnzimmer Timeout sending report to Alexa for sensor.sofa_temperature Timeout sending report to Alexa for light.extended_color_light_9 Timeout sending report to Alexa for light.badlicht Timeout sending report to Alexa for light.bad


Logger: homeassistant.components.websocket_api.http.connection Source: components/deconz/switch.py:75 Integration: Home Assistant WebSocket API (documentation, issues) First occurred: 16:07:01 (1 occurrences) Last logged: 16:07:01 [1693872168] Error requesting data from core-deconz: Cannot connect to host core-deconz:40850 ssl:default [Try again] Traceback (most recent call last): File "/usr/src/homeassistant/homeassistant/components/websocket_api/commands.py", line 189, in handle_call_service await hass.services.async_call( File "/usr/src/homeassistant/homeassistant/core.py", line 1627, in async_call task.result() File "/usr/src/homeassistant/homeassistant/core.py", line 1664, in _execute_service await cast(Callable[[ServiceCall], Awaitable[None]], handler.job.target)( File "/usr/src/homeassistant/homeassistant/helpers/entity_component.py", line 204, in handle_service await service.entity_service_call( File "/usr/src/homeassistant/homeassistant/helpers/service.py", line 677, in entity_service_call future.result() # pop exception if have File "/usr/src/homeassistant/homeassistant/helpers/entity.py", line 964, in async_request_call await coro File "/usr/src/homeassistant/homeassistant/helpers/service.py", line 714, in _handle_entity_call await result File "/usr/src/homeassistant/homeassistant/components/deconz/switch.py", line 75, in async_turn_on await self._device.set_state(on=True) File "/usr/local/lib/python3.9/site-packages/pydeconz/models/light/light.py", line 203, in set_state return await self.request(field=f"{self.deconz_id}/state", data=data) File "/usr/local/lib/python3.9/site-packages/pydeconz/models/api.py", line 95, in request return await self._request("put", path=field, json=data) File "/usr/local/lib/python3.9/site-packages/pydeconz/gateway.py", line 189, in request response: dict[str, Any] = await self._request( File "/usr/local/lib/python3.9/site-packages/pydeconz/gateway.py", line 221, in _request raise RequestError( pydeconz.errors.RequestError: Error requesting data from core-deconz: Cannot connect to host core-deconz:40850 ssl:default [Try again]
 

rednag

Well-known member
Hallo und willkommen im Forum.

Passiert das ganze ausschließlich mit dem AdGuard-DNS? Sind sort etwaige Filter gesetzt?
Was ist für ein Upstream-DNS eingetragen?
 

user91

New member
Hallo und vielen Dank schonmal.

Um genauer zu sein ist mein Setup so.
Auf meinem Raspberry pi 3 3b+ läuft Home Assistant (kein docker) und darauf das Addon "Adguard home".
Genau, nur wenn AdGuard dns in der fritzbox eingetragen ist und dann auch nicht immer, sondern nur ein paar mal am Tag. Sonst hab ich wie gesagt keine Probleme.
Filter? ich hab ein paar Listen, daran sollte es ja aber eigentl. nicht liegen? Sonst hätte ich das Problem ja immer?
Upstream-DNS ist= 1.1.1.1

Momentan hab ich wie gesagt kein dns in der Fritzbox eingetragen, sondern die dns Einstellungen an den Endgeräten vorgenommen. Dies funktioniert auch, nur bei meinem Handy (Huawei p40 pro) hab ich trotzdem Werbung damit. Das hatte ich beim Fritzbox dns change nicht. Handy steht in der Clients Liste bei Adguard.
 

UdoAA

Active member
Bist Du sicher, dass der Raspi die beiden Prozesse auch verkraftet?
Ich habe auch einen 3B+ und der war nicht unbedingt der flotteste, vor allem ist das Ethernet auf ca. 300 MBit/s beschränkt.
Evtl. mal einen 4B zusätzlich anschaffen und einen Prozess darauf auslagern.
 

blurrrr

Well-known member
Beim Deinen Tests auch immer brav die DNS-Caches geleert? Auffällig ist dabei übrigens, dass Du einmal einen "lokalen" Namen ansprichst (Cannot connect to host core-deconz:40850) und einmal einen "externen" (Alexa). Das kannst Du schlecht alles in einen Topf werfen, die interne Namensauflösung (bei nicht-vorhandener interner Domain) funktioniert etwas anders als die externe Auflösung. Kannst Du Denn mit Deiner AdGuard-Installation die internen Namen alle vernünftig auflösen? Ich kenne AdGuard übrigens nicht 🙃
 

UdoAA

Active member
Kann bei der Performance eben auch dran liegen, dass der 3B+ nur 1 GB RAM hat.
Wenn dann mal etwas auf die SD-Card ausgelagert wird, wartet man halt.
Hast du eine 32 Bit oder 64 Bit Distro drauf laufen?
 

user91

New member
@blurrrr Das liegt wahrscheinlich daran, dass ich die Cloud von nabu casa nutze . Ansonsten funktionierte alles. Wie gesagt, ich glaub wie hier schon gesagt wurde es liegt tatsächlich an der leistung. Es kam ja nicht immer vor, nur paar mal am Tag.
 

blurrrr

Well-known member
Wie gesagt, ich glaub wie hier schon gesagt wurde es liegt tatsächlich an der leistung. Es kam ja nicht immer vor, nur paar mal am Tag.
Sollte man im Zweifelsfall aber vielleicht auch einfach mal etwas im Auge behalten ("messen")... Keine Ahnung, ob es da ggf. was für HA direkt gibt.
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
913
Beiträge
13.424
Mitglieder
440
Neuestes Mitglied
nrnrp
Oben