Heimserver via DynDNS erreichen nicht möglich

cybermailer

New member
Hallo,
wie oben angeführt erreiche ich meine Infrastruktur via DynDNS nicht.

Was wurde gemacht:
-) dyndns eingerichtet -> getestet funktioniert -> bei Router Neustart wird neue IP Adresse angezeigt (Dienst von ALL INKL wird genutzt)
-) Portweiterleitung eingerichtet 59xx an interne IP 192.168.x.x internen Port 80

Test -> Wenn ich nun mit der öffentlichen IP direkt zugreifen möchte funktioniert alles perfekt.
Beispiel: http://62.XXX.212.6:5469/web.visu/

Sobald ich via dyndns zugreifen möchte:
Beispiel: http://ddns_dienst.exampleurl.at:5469/web.visu/

erhalte ich: 400 - Bad Request
Nach Internetrecherchen auf DNS Rebind Problem gestoßen - versucht Ausnahmen zu definieren.

In den Ausnahmen habe ich folgendes jeweils in eine Zeile geschrieben:
ddns_dienst
exampleurl
ddns_dienst.exampleurl

auch schon so probiert
ddns_dienst.at
exampleurl.at
ddns_dienst.exampleurl.at

AVM nennt als Beispiele:
my-domain.com
my_domain.dyndns.org

Eine andere Blogseite meinte wiederum ohne die Endungen...

Egal. Nach jeder Änderung Box neugestartet wie gefordert gebracht hat es nichts. Der Fehler ist noch aufrecht.

Hat jemand eine Idee wie ich via DynDNS und der DNS in der URL zugreifen kann?

Dankeschön!
 
DNS Rebind Schutz kommt nur ins Spiel, wenn man aus dem lokalen Netz eine öffentliche Adresse zugreifen will die wieder ins lokale Netz zurück verweist.

Hast du es von einem anderen Internetanschluss oder aus dem Mobilfunknetz schon probiert?

Ein Bad Request kommt auch gerne, wenn man z.b. Per http auf ein https Dienst zugreift, oder umgekehrt.
 
Hast Du mal ipconfig /flushdns versucht (im Windows Terminal)? Bzw. sudo killall -HUP mDNSResponder (im MacOS Terminal).
 
Also kann ich die Einstellungen im Rebind verwerfen -> Danke!

Also ich muss auf einen Webserver der eine Visualisierung hostet für Smarthome.
Dieser Webserver hat kein https nur http.

Wenn ich den LINK öffne:
http://IP:5469/web.visu/

komme ich ja schon rauf
IP getauscht gegen den DYNDNS geht nicht.
 
Achja bereits mit Handy und anderen Geräten und Internetanbindungen getestet (DSL + Mobilfunk)

Dann fällt ipconfig /flushdns auch flach oder?
 
Kann auch die ddns pingen und es wird mir auch die korrekte ip angezeigt. Also die Auflösung vom DNS Dienst passt auch.
 
Browser-Cache löschen, Webserver neustarten, ggf. beim Webserver mal schauen, ob Du irgendwo den gewünschten FQDN hinterlegen kannst? 🙃
 
Moinsen,
Und die fritzbox selber hat den dyndns Eintrag? Diese ggf. dann ebenfalls schon neu gestartet?
 
Wie ist das ggf. mit der Portweiterleitung. Vielleicht einmal löschen und neu eingeben. Hatte ich schon mal, danach konnte ich auf die Dienste zugreifen.
Wie schaut es mit DNS-Server im eigenen Netz aus?
 
Ich hab keinen speziellen dns Server im eigenen Netz. Dns Auflösung macht die Fritzbox. Brauche ich einen extra dns Eintrag? Der DynDNS Service verknüpft ja den DNS und IP. Die DNS ist weltweit pingbar. Innerhalb des lokalen Netzwerkes brauche ich ja nix extra oder?

Die Portweiterleitung funktioniert mit IP bereits nur mit DNS nicht.
 
problem gelöst. anscheinend hält mich der webserver vom eibport v3 von Narren. Mit IP kann ich ihn ansprechend und sobald ich dns anspreche nicht. Mache ich das gleiche mit qnap nas geht es problemlos.
 
ggf. beim Webserver mal schauen, ob Du irgendwo den gewünschten FQDN hinterlegen kannst?
? 🙃

EDIT: Schon gut... Im Handbuch hab ich nach kurzem überfliegen nix dergleichen gesehen, aber folgendes gefunden:
Es gibt im Internet kostenlose Dienste (z.B.: dyndns.org), die dynamische IP-Adressen mit einem sog. Domänennamen (Domain) verbinden. Darüber hinaus hat das den Vorteil, dass sich der Benutzer keine unhandliche Zahlenkombination, sondern nur einen Namen wie z.B. „zuHause.dyndns.org“ merken muss. Mit dieser einmaligen Adresse kann der EIBPORT immer erreicht werden, obwohl sich die eigentliche Adresse dahinter ständig ändert.
(Quelle: https://bab-technologie.com/downloads/EIBPORT-Dokumentation-393-DE-220413.pdf, Seite 311)

Demnach "sollte" das eigentlich einfach funktionieren... Da es das nicht tut... vielleicht einfach mal den Hersteller kontaktieren unter https://bab-technologie.com/kontakt/? :)
 
Zuletzt bearbeitet:

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
4.708
Beiträge
47.998
Mitglieder
4.351
Neuestes Mitglied
Misiaczek
Zurück
Oben