HA aus Node Red nicht erreichbar

Beagel

New member
Hallo Zusammen,

bin ein Neuling
Home Assistant 2022.10.5 läuft im Docker Container,
Node Red nicht im Docker Container
nun zu meinem Problem, leider kann ich aus Node Red den Home Assistant nicht erreichen.
Langzeit Token wurde in HA erstellt und in NR ein Server erstellt ,dort den Token eingetragen und die IP unter der HA im Browser erreichbar ist. Dann wird unter den Knoten nur connecting angezeigt aber keine Entitäten, auch hab ich es mit http://Localhost:8123 probiert das gleiche.

komme jetzt nicht wirklich weiter, vielleicht hat ja einer eine Idee

Gruß
Dieter
 

Beagel

New member
@blurrrr
im log von HA kann ich nichts finden, was auf einen Aufruf von NR deutet,
in der syslog auf dem Raspberry:
Dec 31 08:10:32 Homepi Node-RED[431]: 31 Dec 08:10:32 - [info] [server:Home Assistant] Connecting to http://192.168.xxx.xxx:8123
Dec 31 08:10:34 Homepi Node-RED[431]: 31 Dec 08:10:34 - [info] [zigbee2mqtt-out:Weihnachten Tannenbaum] Published to mqtt topic: zigbee2mqtt/Steckdose_12/set : {"state":"on"}
Dec 31 08:10:34 Homepi systemd[1]: run-docker-runtime\x2drunc-moby-e8db7e86bf0bdffa19643b33a4172ef16ea4bdbee7881fd409fa09d4a0f53c40-runc.i5OtQo.mount: Succeeded.
Dec 31 08:10:34 Homepi systemd[3362961]: run-docker-runtime\x2drunc-moby-e8db7e86bf0bdffa19643b33a4172ef16ea4bdbee7881fd409fa09d4a0f53c40-runc.i5OtQo.mount: Succeeded.
Dec 31 08:10:34 Homepi Node-RED[431]: 31 Dec 08:10:34 - [error] [api-get-history:4d09dd44f51d76d7] Error get-history: Request failed with status code 403
Dec 31 08:10:37 Homepi Node-RED[431]: 31 Dec 08:10:37 - [info] [server:Home Assistant] Connecting to http://192.168.xxx.xxx:8123
Dec 31 08:10:41 Homepi Node-RED[431]: 31 Dec 08:10:41 - [info] [zigbee2mqtt-out:Weihnachten Fernseher] Published to mqtt topic: zigbee2mqtt/Steckdose_9/set : {"state":"on"}
Dec 31 08:10:42 Homepi Node-RED[431]: 31 Dec 08:10:42 - [info] [server:Home Assistant] Connecting to http://192.168.xxx.xxx:8123
Dec 31 08:10:42 Homepi Node-RED[431]: 31 Dec 08:10:42 - [info] [zigbee2mqtt-out:Weihnachten Wo. Fenster] Published to mqtt topic: zigbee2mqtt/Steckdose_11/set : {"state":"on"}
Dec 31 08:10:47 Homepi Node-RED[431]: 31 Dec 08:10:47 - [info] [server:Home Assistant] Connecting to http://192.168.xxx.xxx:8123

hoffe das ist die richtige Logdatei, bin nicht so der große Computerfachmann muß mir leider alles er googlen.
 

blurrrr

Well-known member
Hey :)

HomeAssistant/NodeRed mal neugestartet? Ist ja eigentlich immer das erste, was man instinktiv macht 😁 Dazu kommt auch noch, dass man zwischenzeitlich die Seite im Browser auch mal komplett neu lädt (STRG+F5). Das ist mir bei HomeAssistant schon öfters mal auf die Füsse gefallen 😅

Bin grade noch über jenen hier gestolpert: https://community.home-assistant.io/t/solved-constantly-trying-to-connect-to-supervisor/334777
when I clicked on edit server, everything appeared correct.
however, when I clicked the drop down, I saw 2 additional server entries.
neither of them had any server configuration. I removed them and restarted node red. the problem has gone away

Grundsätzlich sieht Dein Log aber nicht so aus, als würde es da groß zu Fehlern kommen bei der Verbindung zu HomeAssistant, abgesehen von jenem Teil hier:
Dec 31 08:10:34 Homepi Node-RED[431]: 31 Dec 08:10:34 - [error] [api-get-history:4d09dd44f51d76d7] Error get-history: Request failed with status code 403
403 bedeutet "forbidden"... Liest sich jetzt erstmal so, als würde da bei der Authentifizierung etwas fehlschlagen (bzw. ggf. auch einfach verboten sein, keine Ahnung).

Ich muss dazu aber auch sagen, dass ich sogut wie keine Ahnung von HomeAssistant habe und gar keine in Sachen NodeRed, aber da können vllt noch andere weiterhelfen :)
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
1.725
Beiträge
21.436
Mitglieder
1.234
Neuestes Mitglied
Doneinei
Oben