Gerät wird trotz Umbenennung und richtiger Anzeige innrhalb der FB extern noch unter alem Namen angezeigt

Ramrod

New member
Hallo zusammen,


ich habe ein Gerät innerhalb der Fritzbox umbenannt. Dies wurde mir per Nachricht: "Dieses Gerät ist zukünftig unter http://... erreichbar" quittiert. Innerhalb der Fritz Box wird das Gerät auch unter dem neuen Namen richtig aufgeführt, allerdings wird es extern von Systemen bspw. unter WLAN noch unter dem alten Namen aufgeführt. Ebenso habe ich per Linux über ssh root@hostname keinerlei Zugriff. Nur über ssh root@ip bekomme ich eine Verbindung. Irgendwo steckt da der Wurm drin. Innerhalb des Linux-Systems solle alles ordnungsgemäß geändert sein. Ich vermute, dass etwas mit dem Nameserver innerhalb der Fritz Box nicht passt oder ich irgendwas falsch gemacht habe.


Ich bin seit 2 tagen an diesem Thema dran und bekomme es einfach nicht in den Griff. Daher wende ich mich verzweifelt an euch, in der Hoffnung, dass jemand zufällig weiß wo es hier genau hakt. Vor allem die ssh Verbindung per hostname anstele der Angabe der IP wäre sehr wichtig.


Schon mal besten Dank im Voraus.
 

FSC830

Active member
Da war mal was...aber ich erinnere mich nicht mehr genau.
Ich glaube der DNS in der FB hat einen Bug. Die Fritte schon mal durchgestartet?
Und ich meine, bei AVM in der KB etwas darüber gelesen zu haben, aber das ist mind. 2-3 Jahre her!
Aber alles ohne Gewähr, nur irgendwie kommt mir das bekannt vor. :confused:

Gruss
 

the other

Well-known member
Moinsen,
falls es mit der Frizbox partout nicht geht: die Hosts-Datei des jeweils zugreifenden Gerätes anpassen und dort den Eintrag setzen...

Unter windows spare ich mir die Arbeit und verlinke mal frech zu heise.de:
https://www.heise.de/tipps-tricks/Hosts-Datei-in-Windows-10-bearbeiten-4928321.html
Unter zB Ubuntu:
1. Terminalfenster öffnen
2. Eingabe von sudo nano /etc/hosts
3. In der dann einsehbaren hosts Datei den gewünschten Eintrag setzen nach dem Muster
IP.des.jeweiligen.Gerätes Hostname_des_jeweilgen Gerätes
also etwa
192.168.178.2 mein_geraet_xyz
4. Speichern mit STRG und "o"
5. schließen mit STRG und "x"
Einmal neustarten (damit alles verfrühstückt wird), dann sollte ein

ssh root@mein_geraet_xyz auch durchgehen

So als workaround, wenn die Fritzbox weiter stur bleibt...
;)
 

the other

Well-known member
ps:
was sagt ein ping IP und ping hostname?
Nur um abzuklären, dass es nicht an etwas anderem hakt...
Und: welche Firmware Version ist auf der Fritzbox enthalten?
Edit: und natürlich: hast du die Fritzbox nach Änderung des Namens mal neu gestartet??
:)
 
Zuletzt bearbeitet:

Ramrod

New member
Erst mal danke für eure schnellen Antworten. Top! Ja, scheint wirklich irgendwie buggy zu sein. Hatte sowas nämlich auch schon und irgendwann ging es wie von Geisterhand. Box und Gerät habe ich nach den Änderungen mehrfach gestartet, hat aber keinen Erfolg gebracht.

Die Anpassung in der /etc/hosts habe ich schon gemacht, hat aber leider auch nicht zu einer Besserung geführt.

ping ip funktioniert, ping hostname dagegen nicht.

Sagt mal, habe ich den Namen in der FB vielleicht an der falschen Stelle angepasst? Bin einfach nur unter Heimnetz/Netzwerk bei den entsprechenden Gerät auf bearbeiten gegangen und habe den Namen geändert.

Edit:
Ist eine 7590 mit der, laut GUI, aktuellsten Version 07.29.
 
Zuletzt bearbeitet:

the other

Well-known member
Moinsen,
nein, du bist schon ganz richtig an der Stelle. (y)
Wie gesagt, das passiert leider immer mal.
Du könntest noch versuchen, das betreffende Gerät mal ganz zu entfernen (vorher die MAC notieren) und dann neustarten und erneut anlegen, ich befürchte aber...
Wenn du aber zB von den Zugriff per Hostname nur von deinem PC aus machst, dann ist der Eintrag unter der host-Datei vermutlich am einfachsten und verlässlichsten.
 

UdoAA

Active member
Hmm, wie hast Du denn den hostname in Linux (welche Distro?) geändert?

Unter Ubuntu geht das mit dem Befehl
Code:
hostnamectl set-hostname NEUER-Hostname
ein simpler Eintrag in die hosts-Detei reicht nicht.
 

Digedag64

Member
Sagt mal, habe ich den Namen in der FB vielleicht an der falschen Stelle angepasst? Bin einfach nur unter Heimnetz/Netzwerk bei den entsprechenden Gerät auf bearbeiten gegangen und habe den Namen geändert.
Was für ein Gerät ist es denn?
Einige Arten/Typen von "Geräten" sind keineswegs beeindruckt, wenn ihr Hostname in der FritzBox _für die dortige Ansicht_ geändert wird, u.U. muss der Hostname des Gerätes selbst (meist auch am oder auf dem Gerät selbst) geändert werden und nicht nur sein Anzeigename im Router ...

Ansonsten in deinem Fall auch mal im DHCP-Server der FritzBox schauen (ober bei Netzwerk?), ob sich noch ein alter Eintrag mit aktueller IP-Adresse und vorherigem Hostnamen findet. Gut möglich, dass so ein alter Eintrag mit gleicher MAC-Adresse dieses nicht näher bezeichnteten Gerätes dir dazwischenfunkt.
 

the other

Well-known member
Moinsen,
bin bei meinem Tipp davon ausgegangen, dass das fragliche Gerät bereits selber den passenden hostname hat, daher der reine Verweis beim zugreifenden Gerät den Eintrag in die /host zu setzen.
Ansonsten, ja natürlich erst den hostname selber ändern wie @UdoAA beschrieben hat... :)
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
1.334
Beiträge
17.775
Mitglieder
843
Neuestes Mitglied
smartloftnrw
Oben