FritzBox-Kindersicherung: Ticket-Popup stört Einbinden eines Druckers in eine VM

Stationary

Active member
In der Fritzbox lassen sich ja Geräte komplett für den Internetzugriff sperren. Bei Druckern, Scannern und Kameras ist das auch kein Problem. Auf Computern kommt dann aber beim Einschalten direkt nach dem Hochfahren die entsprechende Nachricht der Fritzbox und muß/kann weggeklickt werden.

Hier nun mein Problem: meine Diskstation legt sich jeden Abend schlafen und fährt jeden Morgen wieder hoch. Auf der Diskstation läuft auch eine virtuelle Maschine auf Ubuntu 20.04 LTS-Basis im VMM, die wird kurz nach dem Hochfahren der DS auch gestartet. Diese virtuelle Maschine bekommt eine eigene IP in der Fritzbox. Sperre ich nun diese IP in der Fritzbox komplett mittels Kindersicherung, so kommt direkt nach dem Starten eben die AVM-Meldung hoch, die besagt, daß der Internetzugang gesperrt ist, und daß man eine Ticketnummer eingeben kann.
Soweit so gut, die Kindersicherung macht also, was sie soll. Solange aber diese Sperrnachricht der Fritzbox angezeigt wird, macht das Ubuntu dummerweise nichts anderes, insbesondere wird ein später eingeschalteter Drucker nicht automatisch eingebunden. Da die Ubuntu-VM aber natürlich ohne weitere Überwachung läuft/laufen soll, ist das aber ein Problem, da sie dann nicht automatisch drucken kann. Genaugenommen ist ”sie macht nichts anderes“ inkorrekt. Ein Crontab-Job läuft und macht fast was er soll: ein Verzeichnis überwachen, den Inhalt an den Drucker weiterschieben, und den Inhalt des Verzeichnisses hinterher löschen. Ist die AVM-Meldung noch auf dem Bildschirm, wird das Verzeichnis überwacht und der Inhalt gelöscht, weil der Drucker nicht eingebunden wird, solange die AVM-Meldung noch da ist, wird nichts gedruckt. Klickt man die Meldung weg, wird der Drucker umstandslos sofort danach eingebunden und nachfolgend funktioniert alles wie es soll.
Ich möchte das Ganze aber ja nicht selbst überwachen, das muß im Hintergrund laufen können, ohne daß ich jemals in die VM schaue. Wenn die VM in der Fritzbox keine Internetsperre hat, funktioniert alles, wie es soll. Mit Internetsperre nur dann, wenn die Meldung weggeklickt ist.

Hat jemand eine Idee, wie ich entweder 1) die Fritzbox daran hindern kann, die Sperr-/Ticketmeldung überhaupt auszuliefern, 2) Ubuntu daran hindern kann, diese Meldung überhaupt anzunehmen und sich so teilweise blockieren zu lassen, oder 3) wie es gelingen kann, trotz der Sperrmeldung den Drucker einzubinden (der wird manchmal erst Stunden später, wenn die VM schon lange läuft, eingeschaltet)?
 

FSC830

Active member
Frage: wenn die Ubuntu VM nicht ins Internet darf, warum gibst Du ihr nicht eine feste VM ohne Gateway?
Das root PW kennst sicher nur Du? Dann brauchst Du sie in der Fritz nicht zu sperren und alles läuft.
Oder habe ich Dich irgendwo falsch verstanden?

Gruss
 

tiermutter

Well-known member
Internetsperre durch Gatewayentzug? Das machen doch nur Schmutzfinken :)
Aber ich bin ein großer Fan davon und mache es auch so damit meine FW erst gar nichts damit zu tun bekommt und in Ruhe gelassen wird ;)
 

Barungar

Active member
Ich wüsste ja eine Lösung... :D Der Drucker und die VM brauchen eine ULA... Also der Drucker gerne auch IPv4, GA und ULA. Aber die VM nur eine ULA, dann geht die auch nicht ins Internet UND der Druck läuft modern auf IPv6. ;)

Ich habe mittlerweile sogar Linux-Systeme bei mir, da ist IPv4 deaktiviert! Die sind IPv6 only...
 

tiermutter

Well-known member
Du bekommst doch bestimmt für jede vergebene v6 Adresse einen Cent so wie Du v6 anpreist, oder? :p
Ist aber eine elegante Lösung, hoch lebe v6 :)
 

Stationary

Active member
Ohne Gateway ist vermutlich beim derzeitigen Setup die einzig gangbare Variante. Ich hatte die Hoffnung, daß da noch jemand einen besseren Vorschlag hat. Aber trotzdem vielen Dank!
 

Barungar

Active member
Du bekommst doch bestimmt für jede vergebene v6 Adresse einen Cent so wie Du v6 anpreist, oder? :p
Ist aber eine elegante Lösung, hoch lebe v6 :)
Ne, meine Partnership mit der IANA und RIPE NCC müsste ich mal neu verhandeln. :D

Ohne Gateway ist vermutlich beim derzeitigen Setup die einzig gangbare Variante. Ich hatte die Hoffnung, daß da noch jemand einen besseren Vorschlag hat. Aber trotzdem vielen Dank!

Ich finde nicht, dass ich den Thread gekapert habe. Ich habe lediglich einen Lösungsvorschlag gegeben, der nicht so "dreckig" ist wie kein Gateway. Und der bequem, modern und elegant mit IPv6 umgesetz ist. ;)
 

Stationary

Active member
Habe es jetzt versucht, anders zu lösen, nachdem der AVM-Support mir gesagt hat, daß der die Meldung auslösende Faktor nicht die Fritzbox ist, sondern das Endgerät (in meinem Fall die VM), das eine Internetverbindung herzustellen versucht. Ich war bei meiner Frage an Euch davon ausgegangen, daß die Fritzbox diese Nachricht ausspielt, sobald sich ein Gerät bei ihr anmeldet. Tatsächlich kommt die Nachricht aber erst, wenn das Gerät versucht, die Internetverbindung zu prüfen, dann leitet die Fritzbox auf eine interne Seite um und weist auf die Sperre hin.
Mein Lösungversuch war daher wie folgt:

sudo nano /var/lib/NetworkManager/NetworkManager-intern.conf

.set.enabled=false #stand vorher auf true

sudo systemctl restart NetworkManager

Das unterbindet die Konnektivitätsprüfung beim Hochfahren der VM und die Meldung kommt nicht mehr. Dummerweise verbindet sich der Drucker jetzt nicht mehr automatisch, soll heißen, die VM prüft das Verzeichnis und löscht den Inhalt, druckt aber ins Nirwana. Wo mache ich denn da jetzt wohl den Denkfehler, was hat das Einbinden des Netzwerkdruckers mit der Internetkonnektivitätsprüfung zu tun?
 
Zuletzt bearbeitet:

Stationary

Active member
Wenn ich die Prüfung bei laufender VM einschalte kommt sofort der Fritzbox Sperrbildschirm, wie zu erwarten. Und tja, was soll ich sagen…gedruckt wird auch, wenn ich das wieder wegklicke. Kopfkratz. Ich glaube, ich laß‘ es sein, die VM bekommt Internetzugang und gut ist. Dann funktioniert alles sofort.
 

Zurzeit aktive Besucher

Keine Mitglieder online.

Letzte Anleitungen

Statistik des Forums

Themen
568
Beiträge
8.288
Mitglieder
195
Neuestes Mitglied
hauzi
Oben