Foscam IP-Camera zeigt keinen Stream mit der Foscam-Integration in einer erstellten Karte an

a-wing

New member
Hallo,
ich versuche gerade eine Foscam C2 mit der entsprechenden Integration von Foscam in Home Assistant einzubinden.
Die passende Integration wird von Foscam bereitgestellt und folgende Daten abgefragt:
- IP-Adresse (Host)
- Port
- Benutzername
- Passwort
- Streamauswahl (Main oder Sub)
- RTSP-Port

Alle Eingaben werden akzeptiert und eine Entität angelegt. Ich habe mir eine passende Anzeigekarte auf der Übersicht angelegt und es wird mir ein Standbild, welches sich alle 10sec aktualisiert, angezeigt.
Klicke ich einmal auf das Bild, sollte eigentlich der Stream im Vollbild angezeigt werden, jedoch wird mir kein Stream angezeigt, sondern nur die Vollbildüberschrift mit INFO; EINSTELLUNGEN; VERWANDTE.
Was fehlt mir hier noch für die Streamdarstellung? 🤷‍♂️
Wenn ich dieselbe Camera mit der Integration Generic Camera einrichte und mir ebenfalls eine Anzeigekarte auf der Übersicht anlege, dann wird mir bei Anklicken ein Vollbild mit laufenden Stream angezeigt. :unsure:
Ich habe den Eindruck das die Integration Generic Camera mit einem Trick den Stream im Hintergrund erst wandelt, damit er angezeigt werden kann. Das Bild ist immer leicht dunkler als das originale von Foscam.
Woran kann ich den feststellen, ob HomeAssistat überhaupt mpg-Files mit h.264/h.265 anzeigen kann?🥴

Gruß
Andreas
 

a-wing

New member
Hier noch die Protokolldetails (FEHLER)
Logger: homeassistant.components.stream.stream.camera.foscam_192_168_178_205_81
Source: components/stream/__init__.py:428
Integration: Stream (documentation, issues)
First occurred: 18:51:19 (27 occurrences)
Last logged: 19:49:49

Error from stream worker: Error opening stream (ERRORTYPE_111, Connection refused) rtsp://****:****@192.168.178.205:554/videoMain
 

a-wing

New member
Ja, im VLC funktioniert er. Der fehler liegt an dem fest zugewiesenen RTSP-Port 554
Im VLC muss er heißen: rtsp://****:****@192.168.178.205:81/videoMain
Allerdings läst die Foscam Integration nicht zu das der normale Port gleich dem des RTSP Port ist, was nunmal bei diesem Kameratyp so ist.🥴
Allerdings habe ich immer noch nicht herausgefunden wo man die Einstellungen im sogenannten YAML-Code sehen und ändern könnte.
Habe mir schon extra das Addon FileEditor geladen, aber da sehe ich auch keine Geräte in der configuration.yaml. Die sieht mit ihren 10 Zeilen recht leer aus. :unsure:
 

Nival

-
Moderator
@a-wing wie sieht es in den anderen .yaml-Dateien aus die von der configuration.yaml eingebunden werden oder aber im Lovelace-YAML-Code? Ist da etwas zu dem Gerät zu finden?
 

Stationary

Active member
Sollte eigentlich gehen. Bei Foscam ist doch schon 81 nicht der normale Port, sondern ab Werk sollte das 88 sein. Man kann das aber in den Netzwerk-Einstellungen der Kamera einstellen, soweit ich mich erinnere. Wenn ich nachher zurück bin, schaue ich mal bei meinen kurz hinein.
 

a-wing

New member
Kannst Du die Ports nicht auf der Cam selbst umstellen? Hier ist noch ein Artikel bzgl. RTSP, aber vermutlich kennst Du den schon ☺️
Nein, man kann bei dieser Foscam keinen expezieten RTSP-Port einstellen, da läuft der RTSP-Stream über den normalen Port 88. Und da ich mehrere Cameras habe, benötigen die alle einen eigenen Port wie zB 81.
Es muss doch in HA eine Stelle geben wo ich den Code manipulieren könnte.
 

Stationary

Active member
Läßt sich hier nicht irgendetwas einstellen?
Screenshot 2022-10-15 at 14.05.36.pngScreenshot 2022-10-15 at 14.06.11.png

Das mit den mehreren Kameras und dem jeweils eigenen Port habe ich jetzt auch nicht ganz verstanden, vielleicht mache ich da gerade einen Denkfehler. Aber so wie ich auf mehreren Geräten für den SSH-Zugang als Port 22 haben kann (der Unterschied liegt in der IP-Adresse), und ich auf allen meinen Kameras als Port für die Surveillance Station 88 verwende, kannst Du doch einfach in allen Deinen Kameras den Port auf 554 umstellen. Da braucht doch nicht jede Kamera einen anderen Port, Deine sechs Kameras haben doch sechs verschiedene IP-Adressen.
 
Zuletzt bearbeitet:

a-wing

New member
Deine Idee muss ich mal testen, das mit den Ports ist so gewachsen, es wurde immer mal eine Camera mehr und war für mich bei den Einstellungen leichter auseinander zu halten.
 
Zuletzt bearbeitet:

a-wing

New member
@Stationary habe es heute mal mit einer Kamera probiert und den HTTP Port auf 554 gestellt. Die Foscam Integration hat diese Kombi dann akzeptiert. Soweit so gut, werde das ganze jetzt nochmal für alle Testen und Umstellen müssen.

Gruß
Andreas
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
1.334
Beiträge
17.778
Mitglieder
843
Neuestes Mitglied
smartloftnrw
Oben