Migrieren von vorhandenen Storage Pools

xposity

New member
Hi zusammen


...knack grad einem Problem..

hab auf einem SR pool knappe 10 VMs...

..dann mit Clonezilla XCP-NG auf einen älteren Stand
zurückgesetzt... ;-)

klar..
XCP-NG kennt das LVM Storage zu dem Zeitpunkt natürlich nicht..
..wie kann ich das wieder vollständig migrieren ?

..
Schau grad schon seit ner Weile; falls Ihr einen Tipp habt,
und auch vor dem Problem gestanden seid...
gerne her damit :)
 

blurrrr

Well-known member
Ich vermute mal, dass es Dir um die Disks geht? Wenn Du auf die Storage-Übersicht gehst und dort auf den entsprechenden Storage klickst, kannst Du oben auf "Rescan all disks" klicken. Falls der ganze Storage nicht da ist, aber ein vorhandener eingebunden werden soll, hilft mitunter dieser Link hier weiter: https://support.citrix.com/article/CTX121896
 

xposity

New member
Den Link kannte ich schon. ;-) Danke blurrr

macht nix,

setz nochmal neu auf mit dem SR u image meine Testumgebung
also XCP-NG nochmalig zurück.

...und schau ob ichs nochmal (weil vorhanden aber noch nicht bekannt) einbinden kann.
 

xposity

New member
Ok bin weiter...

Step1:
pvscan:
1644871954773.png

Step2:
Zuordnen des XenStorages:
1644872020625.png
1644872064694.png

Step3:
Devs auflisten
ls -l /dev/disk/by-id/
1644872124144.png
gemacht... Ziel wäre hier sdb...

... Fortsetzung ---
 

Anhänge

  • 1644872034343.png
    1644872034343.png
    3 KB · Aufrufe: 0

xposity

New member
Step 4:
Hostname in Erfahrung bringen

1644872289396.png

Step 5:
Verheiraten der Konfiguration: sr-uuid / mit DISK ID und Host-UUID
1644872357736.png

wirft folgende UUID aus:

1644872401641.png


--Fortsetzung--
 

Anhänge

  • 1644872368970.png
    1644872368970.png
    3 KB · Aufrufe: 0
  • 1644872266174.png
    1644872266174.png
    11,7 KB · Aufrufe: 0

xposity

New member
Hat diese zwar angelegt ...




1644872577848.png


allerdings taucht hier noch die ursprüngliche auf.... die habe ich dann vergessen lassen ;-)
selektiert.. und

1644872644473.png

weg damit...


Bleibt dann nur die Local (s.o.) übrig
mit der Daten der Test VM....

allerdings wird die VM an sich nicht angezeigt...
sondern nur das DiskImage... kann es sein das die ConfigDaten der VM woanders liegen ?

1644872771552.png
 

blurrrr

Well-known member
Die VM-Definition (CPU, RAM, NIC (MAC), etc.) selbst hat doch erstmal nichts mit dem Image zu tun, das Image ist Bestandteil der Config (also der Verweis darauf). Die VMs wirst Du neu anlegen und diesen das entsprechende Image zuweisen müssen. Wenn Du eine VM "exportierst" sollten alle entsprechenden Informationen darin vorhanden sein, handelt es sich nur um das Disk-Image, fehlen diese Informationen.
 

xposity

New member
Hmm Danke für Deine Info Blurr..
:)

Das mit dem Export ist klar.
Dachte das die Daten auch auf dem SR liegen.

Ok. Also... :)

ich kann nicht einfach einen Pool übernehmen da die ConfigDaten (s.o.) wohl auf den XCP-Server liegen; macht Sinn.
Wenn Backup.... dann alle VMs via NFS exportieren und ..nach dem Restore des Servers wieder alles importieren ?

oder .. klappt andersherum wohl nur dann einfach
... wenn ich ein komplettes Backup fahre... das heisst...

SSD1(sda) : XCP Server

+

SSD2(sdb): dazugehörige SR mit den VMs...

...dann spar ich mir das importieren..
;-)
 

blurrrr

Well-known member
Ein "Backup" sollte ebenfalls alle notwendigen Dinge zum Betrieb einer entsprechenden VM beinhalten. Vermutlich werden die IDs von Pool, Storage, Network, etc. aber gänzlichst anders sein nach einer Neuinstallation, so dass man diese Dinge bei den VMs auch erst wieder entsprechend nachjustieren muss. Eine VM wird auf einen entsprechendn Storage (ID) wiederhergestellt, allerdings passen dann hinterlegte IDs vom z.B. Netzwerk nicht, da muss man dann vermutlich auch wieder händisch hinterher (oder kann es schon direkt beim Restore mit angeben, k.A.). Kann da auch schwerlich was zu sagen, bisher war das halt eher Weg-werf-Spielkram in Bezug auf andere Thematiken, produktiv nutze ich kein XCP.
 

underwood

Active member
Ist dafür nicht die Funktion für Backup von Pool Meta Daten und XO config? Desaster Recovery und Continuous Replication sollte eigentlich auch alle Infos für die Widerherstellung erhalten. Export auf jeden Fall. Wegen neuer SSD und weil ich zuerst mit LVM Dateisystem installiert hab, hab ich den Server komplett neu installiert und die vorher exportierten VMs wieder Importiert und ich mußte nichts neu anlegen. Sogar die Backup Jobs und externen SRs waren wieder da, weil ich XO auch mit exportier hatte.
 

Zurzeit aktive Besucher

Keine Mitglieder online.

Letzte Anleitungen

Statistik des Forums

Themen
568
Beiträge
8.288
Mitglieder
195
Neuestes Mitglied
hauzi
Oben