Kein MQTT Device trotz Empfang der Werte im MQTT Explorer

Navin

New member
Hi,
bekomme keine Werte von meinem Wasserzähler in den HAS. Das heist, unter MQTT fehlt dieses Device und entsprechend werden auch keine Entitäten erzeugt.
Irgendwas muß wohl noch in der mqtt.yaml und der configuration.yaml angepasst werden. Alle Einträge dort blieben aber ohne jede funktion.
Die Werte kommen aber im Has an. Kann sie im mqtt Explorer sehen.

Code:
MAC = 40:xx:xx:xx:xx:xx
IP = 192.168.20.75
hostname = watermeter
interval = 5.0
connection = connected
uptime = 34568
freeMem = 850831
wifiRSSI = -87
CPUtemp = 55
main
error = Rate too high - Read: 14055000 - Pre: 4541 - Rate: 14050459
raw = 14055000
json = { "value": "", "raw": "14055000", "pre": "4541", "error": "Rate too high - Read: 14055000 - Pre: 4541 - Rate: 14050459", "rate": "", "timestamp": "" }

Welcher Eintrag fehlt bzw was ist falsch ?

Code:
sensor:
  - name: "Wasserzaehler"
    state_topic: "watermeter/main/value"
    unit_of_measurement: "m3"
    icon: "mdi:water-pump"
    state_class: total_increasing
  - name: "Wasserzaehler_Liter"
    state_topic: "watermeter/main/value"
    value_template: "{{( value | float * 1000 ) | round(2)}}"
    unit_of_measurement: "l"
    icon: "mdi:water-pump"
  - name: "Wasserzaehler Flussrate"
    state_topic: "watermeter/main/rate"
    value_template: "{{ value }}"
    icon: "mdi:swap-vertical"
  - name: "Wasserzaehler letzter Wert"
    state_topic: "watermeter/main/timestamp"
    value_template: "{{ value }}"
    icon: "mdi:clock-outline"
  - name: "water_meter_value"
    state_topic: "watermeter/main/value"
    device_class: water
    state_class: total_increasing
    unit_of_measurement: "m³"
binary_sensor:
  - name: "Wasserzähler Fehler"
    state_topic: "watermeter/main/error"
    value_template: "{{ value != 'no error' }}"
    json_attributes_topic: "watermeter/main/json"
    icon: "mdi:alert-circle"
Danke
 
Was ist dein 1. Code, ESPHome?
Und wo steht der 2.? Da steht nichts von MQTT.
Falls ESPHome kannst du die HA API benutzen, da erscheinen alle Sensoren ohne weiteres in HA.
Ansonsten kann man die Geräte in MQTT definieren, aber ich weiß nicht, wie.
 
der 1.Code ist die Ausgabe im Mqtt Explorer
der 2.Code ist die mqtt.yaml
Da dieser ESP nicht über HA programmiert wurde, komme ich da nicht weiter.
 
Zuletzt bearbeitet:
Ich würde mal tippen, dass dein Wasserzähler nicht korrekt arbeitet, bzw. ein Problem hat da: error = Rate too high - Read: 14055000 - Pre: 4541 - Rate: 14050459 und zum weiteren Debuggen bezüglich MQTT fehlt die Info auf welchen Topics der Wasserzähler die Werte published.
 
error rate to high ist nicht das problem.
Das pasisiert manchmal bei lesefehlern.
Wenn ich den prev. Wert anpasse ändern das nichts.
Auch falsche Werte müssen im HA ankommen.
Das kommt jetzt gerade:
Code:
MAC = 40:xx:xx:xx:xx:xx
IP = 192.168.20.75
hostname = watermeter
interval = 5.0
connection = connected
uptime = 1577
freeMem = 852755
wifiRSSI = -85
CPUtemp = 56
main
error = no error
raw = 14094000
json = { "value": "14094000", "raw": "14094000", "pre": "14094000", "error": "no error", "rate": "0.000000", "timestamp": "2023-12-06T12:19:11+0100" }
value = 14094000
rate = 0.000000
rate_per_time_unit = 0.000000
changeabsolut = 0
rate_per_digitalization_round = 0
timestamp = 2023-12-06T12:19:11+0100

was meinst du mit
MQTT fehlt die Info auf welchen Topics der Wasserzähler die Werte published
genau da ist mein problem. Alles wieder vergessen. Hab das alles vor 2 Jahren eingerichtet und es lief. Mußte aber mein Netzwerk umbauen und deshlab einiges neu aufstzen
 
Nutzt du beim Zähler AI on the Edge? Dann kannst du einfach HA Autodiscovery nutzen und musst keine Config Yaml MQTT Einträge machen
 
ja ... nutze ich . wie geht das mit der autodiscovery ?
muß vorher alles aus den yamls raus ?
 
In den Settings / Configuration im Ai. Unter MQTT kann das aktiviert werden.

Ich vermute das die Sache in der Yaml nicht nötig sind, ich habe da diesbezüglich nichts eingetragen
 
Du meinst UI (User Interface) nicht AI (KI) oder habe ich da was verpasst ?
Da ist es eingestellt. Werde mal versuchen alle anderem mqtt einstellungen in den yamls zu deaktivieren.
Vielleicht geht es dann
 
danke !
so einfach ein Mausklick und es geht ... habe stunden in den config files rum probiert .
Kleines Problem noch. In dem Energieboard wird der 1. Zählerstand als Verbrauch heute angezeigt.
wäre ein bisschen viel. Kann man diesen Wert dort löschen ?
 
habe mir gerade videos dazu angeschaut. Sollte so passen. Ab morgen stimmen die Werte. Damit kann ich leben.
Danke nochmal
 

Zurzeit aktive Besucher

Letzte Anleitungen

Statistik des Forums

Themen
4.213
Beiträge
43.951
Mitglieder
3.806
Neuestes Mitglied
Andy74
Zurück
Oben