ESPHome - Platine nach dem Flashen nicht online

topic13

New member
Hallo!
Ich bin relativ neu in der Home Assistant-Welt. Nach den ersten erfolgreichen Projekten, möchte ich jetzt Temperaturen der Heizung mittels eines einer ESP32-Platine auslesen und an HA übermitteln.
Ich habe also das ESPHome Add-on installiert und die ESP32-Platine an meinem Home Assistant-Rechner mit USB gehängt. Der Flash-Vorgang scheint auch "normal" durchzulaufen. Jedenfalls steht dann auch etwas von "success". Das Log-File bietet mit aber auch nach längerem Warten nie Option an "Close" sondern ich kann nur stoppen. Wenn ich auf Stop gehe, bleibt die ESP32-Platine allerdings offline in HA. Wenn ich in meinen Unifi-Controller schaue, findet sie sich da aber. Und auch wenn ich die IP-Adresse eingebe, habe ich Zugriff auf die Platine.

Weiß jemand vielleicht, wo mein Fehler liegt?

Ich füge mal die letzten Zeilen des Logs an:

Code:
[14:38:13][W][component:170]: Component wifi cleared Warning flag
[14:38:13][W][component:157]: Component api set Warning flag: unspecified
[14:38:13][I][app:100]: ESPHome version 2024.5.0 compiled on May 19 2024, 13:47:42
[14:38:13][C][wifi:580]: WiFi:
[14:38:13][C][wifi:408]:   Local MAC: D4:8A:FC:A5:3D:38
[14:38:13][C][wifi:413]:   SSID: [redacted]
[14:38:13][C][wifi:416]:   IP Address: 10.75.40.151
[14:38:13][C][wifi:420]:   BSSID: [redacted]
[14:38:13][C][wifi:421]:   Hostname: 'i2'
[14:38:13][C][wifi:423]:   Signal strength: -18 dB ▂▄▆█
[14:38:13][C][wifi:427]:   Channel: 1
[14:38:13][C][wifi:428]:   Subnet: 255.255.255.0
[14:38:13][C][wifi:429]:   Gateway: 10.75.40.1
[14:38:13][C][wifi:430]:   DNS1: 1.1.1.1
[14:38:13][C][wifi:431]:   DNS2: 8.8.8.8
[14:38:13][C][logger:185]: Logger:
[14:38:13][C][logger:186]:   Level: DEBUG
[14:38:13][C][logger:188]:   Log Baud Rate: 115200
[14:38:13][C][logger:189]:   Hardware UART: UART0
[14:38:13][C][captive_portal:088]: Captive Portal:
[14:38:13][C][mdns:115]: mDNS:
[14:38:13][C][mdns:116]:   Hostname: i2
[14:38:13][C][ota:096]: Over-The-Air Updates:
[14:38:13][C][ota:097]:   Address: i2.local:3232
[14:38:13][C][ota:100]:   Using Password.
[14:38:13][C][ota:103]:   OTA version: 2.
[14:38:13][C][api:139]: API Server:
[14:38:13][C][api:140]:   Address: i2.local:6053
[14:38:13][C][api:142]:   Using noise encryption: YES
[14:42:49][I][ota:117]: Boot seems successful, resetting boot loop counter.
[14:42:49][D][esp32.preferences:114]: Saving 1 preferences to flash...
[14:42:49][D][esp32.preferences:143]: Saving 1 preferences to flash: 0 cached, 1 written, 0 failed

Vielen Dank für Eure Hilfe!
 

Ihr Gerät mit Home Assistant verbinden

Sobald Ihre Konfiguration auf Ihrem ESP-Gerät installiert und online ist, wird sie automatisch von Home Assistant erkannt und zur Einrichtung auf Ihrem Integrationsbildschirm angeboten:

Öffnen Sie Ihre Home Assistant-Instanz und beginnen Sie mit der Einrichtung einer neuen Integration.
Alternativ können Sie das Gerät manuell auf der Seite „Home Assistant-Integrationen“ hinzufügen. Klicken Sie auf die Schaltfläche „Integration hinzufügen“ (unten rechts), suchen Sie nach esphome und geben Sie den Hostnamen ein, z. B. „<NODE_NAME>.local“ als Host. Verwenden Sie den gleichen Vorgang, um mehrere esphome-Geräte hinzuzufügen.

../_images/gpio-ui1.png
Nach der ersten Installation werden Sie das USB-Kabel wahrscheinlich nie wieder verwenden müssen, da alle Funktionen von ESPHome auch aus der Ferne aktiviert werden.

Du kannst das also über integration manuell hinzufügen, du hast ja die ip-Adresse.
 

Letzte Anleitungen

Statistik des Forums

Themen
4.796
Beiträge
48.629
Mitglieder
4.456
Neuestes Mitglied
Fahren
Zurück
Oben